ANN: Grails 3.0 M2 Released

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
13 messages Options
Reply | Threaded
Open this post in threaded view
|

ANN: Grails 3.0 M2 Released

Graeme Rocher-2
Hi all,

We released Grails 3.0 M2, this include a whole bunch of bug fixes
from M1 and a number of new features as well restoring lost features.

We are pretty much feature complete with just loose ends to tidy up.
Please try it out and upgrade your plugins!

The upgrade guide can be found here:
http://grails.github.io/grails-doc/latest/guide/upgrading.html

Thanks and enjoy!

Cheers

--
Graeme Rocher

--
You received this message because you are subscribed to the Google Groups "Grails Dev Discuss" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/grails-dev-discuss/CAO_wNocH2vZfu18esLGi%2B3mODE9jK%3DPpZDXHwetpLgdUHOw%2Bsg%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

Re: ANN: Grails 3.0 M2 Released

zyro
hi,

tyvm. it is already awesome and still keeps getting better :)

whats the recommended way at the moment to publish grails3 plugins?

- grailsCentral (grailsCentralPublishing.gradle)? cannot log in to
repo.grails.org with my grails.org credentials. is publishing with the
grails.org account the way it is supposed to work?

- bintray (bintrayPublishing.gradle)? that one looks like it is very
much tied to https://github.com/grails3-plugins which is not where my
plugin is located?

- own bintray account/repository/package?

im currently only interested in snapshots/milestones but will there
still be some kind of grails plugin portal notification when its final?

thanks, zyro

-------- Original Message  --------
Subject: ANN: Grails 3.0 M2 Released
From: Graeme Rocher <[hidden email]>
To: [hidden email]
<[hidden email]>
Date: Thu, 26 Feb 2015 20:00:57 +0100

> Hi all,
>
> We released Grails 3.0 M2, this include a whole bunch of bug fixes
> from M1 and a number of new features as well restoring lost features.
>
> We are pretty much feature complete with just loose ends to tidy up.
> Please try it out and upgrade your plugins!
>
> The upgrade guide can be found here:
> http://grails.github.io/grails-doc/latest/guide/upgrading.html
>
> Thanks and enjoy!
>
> Cheers
>

--
You received this message because you are subscribed to the Google Groups "Grails Dev Discuss" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/grails-dev-discuss/54EF7E85.6040207%40zyro.net.
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

Re: ANN: Grails 3.0 M2 Released

sbglasius
In reply to this post by Graeme Rocher-2
Hi,

Trying to create an app or a plugin I get this:

sbg$ grails create-app --stacktrace g3
| Error Could not checkout tag for Grails release [3.0.0.M2]: Ref v3.0.0.M2 can not be resolved (NOTE: Stack trace has been filtered. Use --verbose to see entire trace.)
org.eclipse.jgit.api.errors.RefNotFoundException: Ref v3.0.0.M2 can not be resolved
at org.eclipse.jgit.api.CheckoutCommand.call(CheckoutCommand.java:244)
at org.grails.cli.profile.git.GitProfileRepository.checkoutTagForRelease(GitProfileRepository.groovy:128)
at org.grails.cli.profile.git.GitProfileRepository.createOrUpdateRepository(GitProfileRepository.groovy:116)
at org.grails.cli.profile.git.GitProfileRepository.getProfile(GitProfileRepository.groovy:56)
at org.grails.cli.profile.commands.CreateAppCommand.handle(CreateAppCommand.groovy:70)
at org.grails.cli.GrailsCli.execute(GrailsCli.groovy:174)
at org.grails.cli.GrailsCli.main(GrailsCli.groovy:100)
| Error Could not checkout tag for Grails release [3.0.0.M2]: Ref v3.0.0.M2 can not be resolved
| Application created at /Users/sbg/projects/diverse/g3

Going to the directory and issuing a grails run-app I get this:

Done.
| Error Could not checkout tag for Grails release [3.0.0.M2]: Ref v3.0.0.M2 can not be resolved (Use --stacktrace to see the full trace)
:compileJava UP-TO-DATE
:compileGroovy
:processResources
:classes
:findMainClass
:run
objc[89085]: Class JavaLaunchHelper is implemented in both /Library/Java/JavaVirtualMachines/jdk1.7.0_75.jdk/Contents/Home/bin/java and /Library/Java/JavaVirtualMachines/jdk1.7.0_75.jdk/Contents/Home/jre/lib/libinstrument.dylib. One of the two will be used. Which one is undefined.
ERROR grails.boot.GrailsApp - Application startup failed
Exception in thread "main" org.springframework.beans.factory.BeanDefinitionStoreException: Invalid bean definition with name 'hibernateDatastore' defined in null: Could not resolve placeholder 'PWD##*/' in string value "echo -ne "\033];${PWD##*/}\007"; :"; nested exception is java.lang.IllegalArgumentException: Could not resolve placeholder 'PWD##*/' in string value "echo -ne "\033];${PWD##*/}\007"; :"
org.springframework.beans.factory.BeanDefinitionStoreException: Invalid bean definition with name 'hibernateDatastore' defined in null: Could not resolve placeholder 'PWD##*/' in string value "echo -ne "\033];${PWD##*/}\007"; :"; nested exception is java.lang.IllegalArgumentException: Could not resolve placeholder 'PWD##*/' in string value "echo -ne "\033];${PWD##*/}\007"; :"
at org.springframework.beans.factory.config.PlaceholderConfigurerSupport.doProcessProperties(PlaceholderConfigurerSupport.java:211) ~[spring-beans-4.1.5.RELEASE.jar:4.1.5.RELEASE]
at org.springframework.beans.factory.config.PlaceholderConfigurerSupport.doProcessProperties(PlaceholderConfigurerSupport.java:211)
at org.springframework.context.support.PropertySourcesPlaceholderConfigurer.processProperties(PropertySourcesPlaceholderConfigurer.java:180)
at org.springframework.context.support.PropertySourcesPlaceholderConfigurer.processProperties(PropertySourcesPlaceholderConfigurer.java:180) ~[spring-context-4.1.5.RELEASE.jar:4.1.5.RELEASE]
at org.springframework.context.support.PropertySourcesPlaceholderConfigurer.postProcessBeanFactory(PropertySourcesPlaceholderConfigurer.java:155) ~[spring-context-4.1.5.RELEASE.jar:4.1.5.RELEASE]
at org.springframework.context.support.PropertySourcesPlaceholderConfigurer.postProcessBeanFactory(PropertySourcesPlaceholderConfigurer.java:155)
at org.springframework.context.support.PostProcessorRegistrationDelegate.invokeBeanFactoryPostProcessors(PostProcessorRegistrationDelegate.java:265) ~[spring-context-4.1.5.RELEASE.jar:4.1.5.RELEASE]
at org.springframework.context.support.PostProcessorRegistrationDelegate.invokeBeanFactoryPostProcessors(PostProcessorRegistrationDelegate.java:265)
at org.springframework.context.support.PostProcessorRegistrationDelegate.invokeBeanFactoryPostProcessors(PostProcessorRegistrationDelegate.java:162) ~[spring-context-4.1.5.RELEASE.jar:4.1.5.RELEASE]
at org.springframework.context.support.PostProcessorRegistrationDelegate.invokeBeanFactoryPostProcessors(PostProcessorRegistrationDelegate.java:162)
at org.springframework.context.support.AbstractApplicationContext.invokeBeanFactoryPostProcessors(AbstractApplicationContext.java:606) ~[spring-context-4.1.5.RELEASE.jar:4.1.5.RELEASE]
at org.springframework.context.support.AbstractApplicationContext.invokeBeanFactoryPostProcessors(AbstractApplicationContext.java:606)
at org.springframework.context.support.AbstractApplicationContext.refresh(AbstractApplicationContext.java:462) ~[spring-context-4.1.5.RELEASE.jar:4.1.5.RELEASE]
at org.springframework.context.support.AbstractApplicationContext.refresh(AbstractApplicationContext.java:462)
at org.springframework.boot.context.embedded.EmbeddedWebApplicationContext.refresh(EmbeddedWebApplicationContext.java:118) ~[spring-boot-1.2.1.RELEASE.jar:1.2.1.RELEASE]
at org.springframework.boot.context.embedded.EmbeddedWebApplicationContext.refresh(EmbeddedWebApplicationContext.java:118)
at org.springframework.boot.SpringApplication.refresh(SpringApplication.java:691) ~[spring-boot-1.2.1.RELEASE.jar:1.2.1.at org.springframework.boot.SpringApplication.refresh(SpringApplication.java:691)
LEASE]
at org.springframework.boot.SpringApplication.run(SpringApplication.java:321)
at org.springframework.boot.SpringApplication.run(SpringApplication.java:321) ~[spring-boot-1.2.1.RELEASE.jar:1.2.1.RELEASE]
at grails.boot.GrailsApp.run(GrailsApp.groovy:43)
at grails.boot.GrailsApp.run(GrailsApp.groovy:43) [grails-core-3.0.0.M2.jar:3.0.0.M2]
at grails.boot.GrailsApp.run(GrailsApp.groovy:207)
at grails.boot.GrailsApp.run(GrailsApp.groovy:207) [grails-core-3.0.0.M2.jar:3.0.0.M2]
at grails.boot.GrailsApp.run(GrailsApp.groovy:196)
at grails.boot.GrailsApp.run(GrailsApp.groovy:196) [grails-core-3.0.0.M2.jar:3.0.0.M2]
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) ~[na:1.7.0_75]
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57) ~[na:1.7.0_75]
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43) ~[na:1.7.0_75]
at java.lang.refat java.lang.reflect.Method.invoke(Method.java:606) ~[na:1.7.0_75]
Method.invoke(Method.java:606)
at org.springsource.loaded.ri.ReflectiveInterceptor.jlrMethodInvoke(ReflectiveInterceptor.java:1270) [springloaded-1.2.1.RELEASE.jar:1.2.1.RELEASE]
at org.springsource.loaded.ri.ReflectiveInterceptor.jlrMethodInvoke(ReflectiveInterceptor.java:1270)
at org.codehaus.groovy.reflection.CachedMethod.invoke(CachedMethod.java:90) [groovy-2.4.1.jar:2.4.1]
at org.codehaus.groovy.reflection.CachedMethod.invoke(CachedMethod.java:90)
at groovy.lang.MetaMethod.doMethodInvoke(MetaMethod.java:324) [groovy-2.4.1.jar:2.4.1]
at groovy.lang.MetaMethod.doMethodInvoke(MetaMethod.java:324)
at org.codehaus.groovy.runtime.callsite.StaticMetaMethodSite.invoke(StaticMetaMethodSite.java:43) [groovy-2.4.1.jar:2.4.1]
at org.codehaus.groovy.runtime.callsite.StaticMetaMethodSite.invoke(StaticMetaMethodSite.java:43)
at org.codehaus.groovy.runtime.callsite.StaticMetaMethodSite.call(StaticMetaMethodSite.java:88) [groovy-2.4.1.jar:2.4.1]
at org.codehaus.groovy.runtime.callsite.StaticMetaMethodSite.call(StaticMetaMethodSite.java:88)
at org.codehaus.groovy.runtime.callsite.CallSiteArray.defaultCall(CallSiteArray.java:45) [groovy-2.4.1.jar:2.4.1]
at org.codehaus.groovy.runtime.callsite.CallSiteArray.defaultCall(CallSiteArray.java:45)
at org.codehaus.groovy.runtime.callsite.AbstractCallSite.call(AbstractCallSite.java:110) [groovy-2.4.1.jar:2.4.1]
at org.codehaus.groovy.runtime.callsite.AbstractCallSite.call(AbstractCallSite.java:110)
at org.codehaus.groovy.runtime.callsite.AbstractCallSite.call(AbstractCallSite.java:122) [groovy-2.4.1.jar:2.4.1]
at org.codehaus.groovy.runtime.callsite.AbstractCallSite.call(AbstractCallSite.java:122)
at g3.Application.main(Application.groovy:8) [main/:na]
at g3.Application.main(Application.groovy:8)
Caused by: java.lang.IllegalArgumentException: Could not resolve placeholder 'PWD##*/' in string value "echo -ne "\033];${PWD##*/}\007"; :"
Caused by: java.lang.IllegalArgumentException: Could not resolve placeholder 'PWD##*/' in string value "echo -ne "\033];${PWD##*/}\007"; :"
at org.springframework.util.PropertyPlaceholderHelper.parseStringValue(PropertyPlaceholderHelper.java:174) ~[spring-core-4.1.5.RELEASE.jar:4.1.5.RELEASE]
at org.springframework.util.PropertyPlaceholderHelper.parseStringValue(PropertyPlaceholderHelper.java:174)
at org.springfraat org.springframework.util.PropertyPlaceholderHelper.replacePlaceholders(PropertyPlaceholderHelper.java:126)
rk.util.PropertyPlaceholderHelper.replacePlaceholders(PropertyPlaceholderHelper.java:126) ~[spring-core-4.1.5.RELEASE.jar:4.1.5.RELEASE]
at org.springframework.core.env.AbstractPropertyResolver.doResolvePlaceholders(AbstractPropertyResolver.java:204)
at org.springframework.core.env.AbstractPropertyResolver.doResolvePlaceholders(AbstractPropertyResolver.java:204) ~[spring-core-4.1.5.RELEASE.jar:4.1.5.RELEASE]
at org.springframework.core.env.AbstractPropertyResolver.resolveRequiredPlaceholders(AbstractPropertyResolver.java:178)
at org.springframework.core.env.AbstractPropertyResolver.resolveRequiredPlaceholders(AbstractPropertyResolver.java:178) ~[spring-core-4.1.5.RELEASE.jar:4.1.5.RELEASE]
at org.springframework.context.support.PropertySourcesPlaceholderConfigurer$2.resolveStringValue(PropertySourcesPlaceholderConfigurer.java:175)
at org.springframework.beans.factory.config.BeanDefinitionVisitor.resolveStringValue(BeanDefinitionVisitor.java:282)
at org.springframework.beans.factory.config.BeanDefinitionVisitor.resolveValue(BeanDefinitionVisitor.java:209)
at org.springframework.context.support.PropertySourcesPlaceholderConfigurer$2.resolveStringValue(PropertySourcesPlaceholderConfigurer.java:175) ~[spring-context-4.1.5.RELEASE.jar:4.1.5.RELEASE]
at org.springframework.beans.factory.config.BeanDefinitionVisitor.visitMap(BeanDefinitionVisitor.java:262)
at org.springframework.beans.factory.config.BeanDefinitionVisitor.resolveStringValue(BeanDefinitionVisitor.java:282) ~[spring-beans-4.1.5.RELEASE.jar:4.1.5.RELEASE]
at org.springframework.beans.factory.config.BeanDefinitionVisitor.resolveValue(BeanDefinitionVisitor.java:198)
at org.springframework.beans.factory.config.BeanDefinitionVisitor.resolveValue(BeanDefinitionVisitor.java:209) ~[spring-beans-4.1.5.RELEASE.jar:4.1.5.RELEASE]
at org.springframework.beans.factory.config.BeanDefinitionVisitor.visitGat org.springframework.beans.factory.config.BeanDefinitionVisitor.visitMap(BeanDefinitionVisitor.java:262) ~[spring-beans-4.1.5.RELEASE.jar:4.1.5.RELEASE]
enericArgumentValues(BeanDefinitionVisitor.java:159)
at org.springframework.beans.factory.config.BeanDefinitionVisitor.resolveValue(BeanDefinitionVisitor.java:198) ~[spring-beans-4.1.5.RELEASE.jar:4.1.5.RELEASE]
at org.springframework.beans.factory.config.BeanDefinitionVisitor.visitBeanDefinition(BeanDefinitionVisitor.java:85)
at org.springframework.beans.factory.config.BeanDefinitionVisitor.visitGenericArgumentValues(BeanDefinitionVisitor.java:159) ~[spring-beans-4.1.5.RELEASE.jar:4.1.5.RELEASE]
at org.springframework.beans.factory.config.PlaceholderConfigurerSupport.doProcessProperties(PlaceholderConfigurerSupport.java:208)
... 25 more
at org.springframework.beans.factory.config.BeanDefinitionVisitor.visitBeanDefinition(BeanDefinitionVisitor.java:85) ~[spring-beans-4.1.5.RELEASE.jar:4.1.5.RELEASE]
at org.springframework.beans.factory.config.PlaceholderConfigurerSupport.doProcessProperties(PlaceholderConfigurerSupport.java:208) ~[spring-beans-4.1.5.RELEASE.jar:4.1.5.RELEASE]
... 25 common frames omitted
:run FAILED

FAILURE: Build failed with an exception.

* What went wrong:
Execution failed for task ':run'.
> Process 'command '/Library/Java/JavaVirtualMachines/jdk1.7.0_75.jdk/Contents/Home/bin/java'' finished with non-zero exit value 1

* Try:
Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output.

BUILD FAILED

Total time: 10.183 secs
| Error Failed to start server (Use --stacktrace to see the full trace)

I can file a JIRA, but don't know what causes the problem.

This is 3.0.0.M2 just downloaded by gvm.


Best regards / Med venlig hilsen,
Søren Berg Glasius

40 Stevenson Ave, Berkeley, CA 94708
Mobile: (+1)510 984 8362, Skype: sbglasius
--- Press ESC once to quit - twice to save the changes.

On 26 February 2015 at 11:00, Graeme Rocher <[hidden email]> wrote:
Hi all,

We released Grails 3.0 M2, this include a whole bunch of bug fixes
from M1 and a number of new features as well restoring lost features.

We are pretty much feature complete with just loose ends to tidy up.
Please try it out and upgrade your plugins!

The upgrade guide can be found here:
http://grails.github.io/grails-doc/latest/guide/upgrading.html

Thanks and enjoy!

Cheers

--
Graeme Rocher

--
You received this message because you are subscribed to the Google Groups "Grails Dev Discuss" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/grails-dev-discuss/CAO_wNocH2vZfu18esLGi%2B3mODE9jK%3DPpZDXHwetpLgdUHOw%2Bsg%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "Grails Dev Discuss" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/grails-dev-discuss/CAGY%2BWWT%3DBTa0jpGEgpFpRftsZLBGFJMCT4fjq1o%2B_1XyvWvL1A%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

Re: ANN: Grails 3.0 M2 Released

Jeff Scott Brown-3

> On Feb 26, 2015, at 5:08 PM, Søren Berg Glasius <[hidden email]> wrote:
>
> Hi,
>
> Trying to create an app or a plugin I get this:
>
> sbg$ grails create-app --stacktrace g3
> | Error Could not checkout tag for Grails release [3.0.0.M2]: Ref v3.0.0.M2 can not be resolved (NOTE: Stack trace has been filtered. Use --verbose to see entire trace.)
> org.eclipse.jgit.api.errors.RefNotFoundException: Ref v3.0.0.M2 can not be resolved
> at org.eclipse.jgit.api.CheckoutCommand.call(CheckoutCommand.java:244)
> at org.grails.cli.profile.git.GitProfileRepository.checkoutTagForRelease(GitProfileRepository.groovy:128)
> at org.grails.cli.profile.git.GitProfileRepository.createOrUpdateRepository(GitProfileRepository.groovy:116)
> at org.grails.cli.profile.git.GitProfileRepository.getProfile(GitProfileRepository.groovy:56)
> at org.grails.cli.profile.commands.CreateAppCommand.handle(CreateAppCommand.groovy:70)
> at org.grails.cli.GrailsCli.execute(GrailsCli.groovy:174)
> at org.grails.cli.GrailsCli.main(GrailsCli.groovy:100)
> | Error Could not checkout tag for Grails release [3.0.0.M2]: Ref v3.0.0.M2 can not be resolved
> | Application created at /Users/sbg/projects/diverse/g3
>
> Going to the directory and issuing a grails run-app I get this:
>
> BUILD SUCCESSFUL


If you delete your ~/.grails/repository/ folder, does the problem go away?



JSB
--
Jeff Scott Brown
[hidden email]

Autism Strikes 1 in 166
Find The Cause ~ Find The Cure
http://www.autismspeaks.org/



--
You received this message because you are subscribed to the Google Groups "Grails Dev Discuss" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/grails-dev-discuss/9C342D86-3698-456A-860A-DA36297E51BB%40pivotal.io.
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

Re: ANN: Grails 3.0 M2 Released

sbglasius
Hi Jeff

If I remove .grails/repository the first error goes away, but the second is persistent:

ERROR grails.boot.GrailsApp - Application startup failed
Exception in thread "main" org.springframework.beans.factory.BeanDefinitionStoreException: Invalid bean definition with name 'hibernateDatastore' defined in null: Could not resolve placeholder 'PWD##*/' in string value "echo -ne "\033];${PWD##*/}\007"; :"; nested exception is java.lang.IllegalArgumentException: Could not resolve placeholder 'PWD##*/' in string value "echo -ne "\033];${PWD##*/}\007"; :"
org.springframework.beans.factory.BeanDefinitionStoreException: Invalid bean definition with name 'hibernateDatastore' defined in null: Could not resolve placeholder 'PWD##*/' in string value "echo -ne "\033];${PWD##*/}\007"; :"; nested exception is java.lang.IllegalArgumentException: Could not resolve placeholder 'PWD##*/' in string value "echo -ne "\033];${PWD##*/}\007"; :"
at org.springframework.beans.factory.config.PlaceholderConfigurerSupport.doProcessProperties(PlaceholderConfigurerSupport.java:211) ~[spring-beans-4.1.5.RELEASE.jar:4.1.5.RELEASE]

I also removed ~/.grails/.slcache and the project .gradle directory, but get the same error. If you have other suggestions, please reach out (you know how to find me)


Best regards / Med venlig hilsen,
Søren Berg Glasius

40 Stevenson Ave, Berkeley, CA 94708
Mobile: (+1)510 984 8362, Skype: sbglasius
--- Press ESC once to quit - twice to save the changes.

On 26 February 2015 at 15:33, Jeff Scott Brown <[hidden email]> wrote:

> On Feb 26, 2015, at 5:08 PM, Søren Berg Glasius <[hidden email]> wrote:
>
> Hi,
>
> Trying to create an app or a plugin I get this:
>
> sbg$ grails create-app --stacktrace g3
> | Error Could not checkout tag for Grails release [3.0.0.M2]: Ref v3.0.0.M2 can not be resolved (NOTE: Stack trace has been filtered. Use --verbose to see entire trace.)
> org.eclipse.jgit.api.errors.RefNotFoundException: Ref v3.0.0.M2 can not be resolved
>       at org.eclipse.jgit.api.CheckoutCommand.call(CheckoutCommand.java:244)
>       at org.grails.cli.profile.git.GitProfileRepository.checkoutTagForRelease(GitProfileRepository.groovy:128)
>       at org.grails.cli.profile.git.GitProfileRepository.createOrUpdateRepository(GitProfileRepository.groovy:116)
>       at org.grails.cli.profile.git.GitProfileRepository.getProfile(GitProfileRepository.groovy:56)
>       at org.grails.cli.profile.commands.CreateAppCommand.handle(CreateAppCommand.groovy:70)
>       at org.grails.cli.GrailsCli.execute(GrailsCli.groovy:174)
>       at org.grails.cli.GrailsCli.main(GrailsCli.groovy:100)
> | Error Could not checkout tag for Grails release [3.0.0.M2]: Ref v3.0.0.M2 can not be resolved
> | Application created at /Users/sbg/projects/diverse/g3
>
> Going to the directory and issuing a grails run-app I get this:
>
> BUILD SUCCESSFUL


If you delete your ~/.grails/repository/ folder, does the problem go away?



JSB
--
Jeff Scott Brown
[hidden email]

Autism Strikes 1 in 166
Find The Cause ~ Find The Cure
http://www.autismspeaks.org/



--
You received this message because you are subscribed to the Google Groups "Grails Dev Discuss" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/grails-dev-discuss/9C342D86-3698-456A-860A-DA36297E51BB%40pivotal.io.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "Grails Dev Discuss" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/grails-dev-discuss/CAGY%2BWWRbKRKvs0tbhCaHO4DErce_wAZ5dskASdbu%2BSLuKN4d7Q%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

Re: ANN: Grails 3.0 M2 Released

Graeme Rocher-2
You have some environment variable that is being read by Grails and causing the error

On Friday, February 27, 2015, Søren Berg Glasius <[hidden email]> wrote:
Hi Jeff

If I remove .grails/repository the first error goes away, but the second is persistent:

ERROR grails.boot.GrailsApp - Application startup failed
Exception in thread "main" org.springframework.beans.factory.BeanDefinitionStoreException: Invalid bean definition with name 'hibernateDatastore' defined in null: Could not resolve placeholder 'PWD##*/' in string value "echo -ne "\033];${PWD##*/}\007"; :"; nested exception is java.lang.IllegalArgumentException: Could not resolve placeholder 'PWD##*/' in string value "echo -ne "\033];${PWD##*/}\007"; :"
org.springframework.beans.factory.BeanDefinitionStoreException: Invalid bean definition with name 'hibernateDatastore' defined in null: Could not resolve placeholder 'PWD##*/' in string value "echo -ne "\033];${PWD##*/}\007"; :"; nested exception is java.lang.IllegalArgumentException: Could not resolve placeholder 'PWD##*/' in string value "echo -ne "\033];${PWD##*/}\007"; :"
at org.springframework.beans.factory.config.PlaceholderConfigurerSupport.doProcessProperties(PlaceholderConfigurerSupport.java:211) ~[spring-beans-4.1.5.RELEASE.jar:4.1.5.RELEASE]

I also removed ~/.grails/.slcache and the project .gradle directory, but get the same error. If you have other suggestions, please reach out (you know how to find me)


Best regards / Med venlig hilsen,
Søren Berg Glasius

40 Stevenson Ave, Berkeley, CA 94708
Mobile: (+1)510 984 8362, Skype: sbglasius
--- Press ESC once to quit - twice to save the changes.

On 26 February 2015 at 15:33, Jeff Scott Brown <<a href="javascript:_e(%7B%7D,&#39;cvml&#39;,&#39;jbrown@pivotal.io&#39;);" target="_blank">jbrown@...> wrote:

> On Feb 26, 2015, at 5:08 PM, Søren Berg Glasius <<a href="javascript:_e(%7B%7D,&#39;cvml&#39;,&#39;soeren@glasius.dk&#39;);" target="_blank">soeren@...> wrote:
>
> Hi,
>
> Trying to create an app or a plugin I get this:
>
> sbg$ grails create-app --stacktrace g3
> | Error Could not checkout tag for Grails release [3.0.0.M2]: Ref v3.0.0.M2 can not be resolved (NOTE: Stack trace has been filtered. Use --verbose to see entire trace.)
> org.eclipse.jgit.api.errors.RefNotFoundException: Ref v3.0.0.M2 can not be resolved
>       at org.eclipse.jgit.api.CheckoutCommand.call(CheckoutCommand.java:244)
>       at org.grails.cli.profile.git.GitProfileRepository.checkoutTagForRelease(GitProfileRepository.groovy:128)
>       at org.grails.cli.profile.git.GitProfileRepository.createOrUpdateRepository(GitProfileRepository.groovy:116)
>       at org.grails.cli.profile.git.GitProfileRepository.getProfile(GitProfileRepository.groovy:56)
>       at org.grails.cli.profile.commands.CreateAppCommand.handle(CreateAppCommand.groovy:70)
>       at org.grails.cli.GrailsCli.execute(GrailsCli.groovy:174)
>       at org.grails.cli.GrailsCli.main(GrailsCli.groovy:100)
> | Error Could not checkout tag for Grails release [3.0.0.M2]: Ref v3.0.0.M2 can not be resolved
> | Application created at /Users/sbg/projects/diverse/g3
>
> Going to the directory and issuing a grails run-app I get this:
>
> BUILD SUCCESSFUL


If you delete your ~/.grails/repository/ folder, does the problem go away?



JSB
--
Jeff Scott Brown
<a href="javascript:_e(%7B%7D,&#39;cvml&#39;,&#39;jbrown@pivotal.io&#39;);" target="_blank">jbrown@...

Autism Strikes 1 in 166
Find The Cause ~ Find The Cure
http://www.autismspeaks.org/



--
You received this message because you are subscribed to the Google Groups "Grails Dev Discuss" group.
To unsubscribe from this group and stop receiving emails from it, send an email to <a href="javascript:_e(%7B%7D,&#39;cvml&#39;,&#39;grails-dev-discuss%2Bunsubscribe@googlegroups.com&#39;);" target="_blank">grails-dev-discuss+unsubscribe@....
To post to this group, send email to <a href="javascript:_e(%7B%7D,&#39;cvml&#39;,&#39;grails-dev-discuss@googlegroups.com&#39;);" target="_blank">grails-dev-discuss@....
To view this discussion on the web visit https://groups.google.com/d/msgid/grails-dev-discuss/9C342D86-3698-456A-860A-DA36297E51BB%40pivotal.io.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "Grails Dev Discuss" group.
To unsubscribe from this group and stop receiving emails from it, send an email to <a href="javascript:_e(%7B%7D,&#39;cvml&#39;,&#39;grails-dev-discuss%2Bunsubscribe@googlegroups.com&#39;);" target="_blank">grails-dev-discuss+unsubscribe@....
To post to this group, send email to <a href="javascript:_e(%7B%7D,&#39;cvml&#39;,&#39;grails-dev-discuss@googlegroups.com&#39;);" target="_blank">grails-dev-discuss@....
To view this discussion on the web visit https://groups.google.com/d/msgid/grails-dev-discuss/CAGY%2BWWRbKRKvs0tbhCaHO4DErce_wAZ5dskASdbu%2BSLuKN4d7Q%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.


--
Graeme Rocher

--
You received this message because you are subscribed to the Google Groups "Grails Dev Discuss" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/grails-dev-discuss/CAO_wNofjYAt8ZzQ4gTwP3VYFkctQ8pwOQqfBX5C7NRvk5KoVoA%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

Re: ANN: Grails 3.0 M2 Released

Graeme Rocher-2
In reply to this post by zyro
The current plan is that folks should publish their plugins to
Bintray. Each plugin gets published with metadata identifying the
plugin, we can then query bintray for all Grails plugins. If you want
to publish a plugin you simply have to configure bintray appropriately
with your user, key, organisation and repo. See
https://github.com/bintray/gradle-bintray-plugin

In the near future we will build a portal that queries bintray for
available Grails plugins very much like http://plugins.gradle.org

It is obviously not as turnkey as the current Grails 2.x system, but
if you have any suggestions to improve on this plan let me know.

The alternative would be to do something similar as what we have now
with the website controlling authentication, permissions and
publishing approvals. The good thing is by externalising the Gradle
configuration to Github we can alter these in the future if necessary.

Cheers

On Thu, Feb 26, 2015 at 9:13 PM, zyro <[hidden email]> wrote:

> hi,
>
> tyvm. it is already awesome and still keeps getting better :)
>
> whats the recommended way at the moment to publish grails3 plugins?
>
> - grailsCentral (grailsCentralPublishing.gradle)? cannot log in to
> repo.grails.org with my grails.org credentials. is publishing with the
> grails.org account the way it is supposed to work?
>
> - bintray (bintrayPublishing.gradle)? that one looks like it is very much
> tied to https://github.com/grails3-plugins which is not where my plugin is
> located?
>
> - own bintray account/repository/package?
>
> im currently only interested in snapshots/milestones but will there still be
> some kind of grails plugin portal notification when its final?
>
> thanks, zyro
>
>
> -------- Original Message  --------
> Subject: ANN: Grails 3.0 M2 Released
> From: Graeme Rocher <[hidden email]>
> To: [hidden email]
> <[hidden email]>
> Date: Thu, 26 Feb 2015 20:00:57 +0100
>
>> Hi all,
>>
>> We released Grails 3.0 M2, this include a whole bunch of bug fixes
>> from M1 and a number of new features as well restoring lost features.
>>
>> We are pretty much feature complete with just loose ends to tidy up.
>> Please try it out and upgrade your plugins!
>>
>> The upgrade guide can be found here:
>> http://grails.github.io/grails-doc/latest/guide/upgrading.html
>>
>> Thanks and enjoy!
>>
>> Cheers
>>
>
> --
> You received this message because you are subscribed to the Google Groups
> "Grails Dev Discuss" group.
> To unsubscribe from this group and stop receiving emails from it, send an
> email to [hidden email].
> To post to this group, send email to [hidden email].
> To view this discussion on the web visit
> https://groups.google.com/d/msgid/grails-dev-discuss/54EF7E85.6040207%40zyro.net.
> For more options, visit https://groups.google.com/d/optout.



--
Graeme Rocher

--
You received this message because you are subscribed to the Google Groups "Grails Dev Discuss" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/grails-dev-discuss/CAO_wNofv7S2q-CH2su0pz%2BD7gO%3DsYyYDFpMbNtuj0kA5E-t%3DMA%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

Re: ANN: Grails 3.0 M2 Released

sbglasius
In reply to this post by Graeme Rocher-2
You're right, I have a PROMPT_COMMAND, but why is that interferring with executing my Grails script? I can disable it, but I'd rather not have to.

Is this coming from Gradle or Grails?

the PROMPT_COMMAND is specifically setting my iTerm tab title to current directory name. 


Best regards / Med venlig hilsen,
Søren Berg Glasius

40 Stevenson Ave, Berkeley, CA 94708
Mobile: (+1)510 984 8362, Skype: sbglasius
--- Press ESC once to quit - twice to save the changes.

On 26 February 2015 at 23:17, Graeme Rocher <[hidden email]> wrote:
You have some environment variable that is being read by Grails and causing the error


On Friday, February 27, 2015, Søren Berg Glasius <[hidden email]> wrote:
Hi Jeff

If I remove .grails/repository the first error goes away, but the second is persistent:

ERROR grails.boot.GrailsApp - Application startup failed
Exception in thread "main" org.springframework.beans.factory.BeanDefinitionStoreException: Invalid bean definition with name 'hibernateDatastore' defined in null: Could not resolve placeholder 'PWD##*/' in string value "echo -ne "\033];${PWD##*/}\007"; :"; nested exception is java.lang.IllegalArgumentException: Could not resolve placeholder 'PWD##*/' in string value "echo -ne "\033];${PWD##*/}\007"; :"
org.springframework.beans.factory.BeanDefinitionStoreException: Invalid bean definition with name 'hibernateDatastore' defined in null: Could not resolve placeholder 'PWD##*/' in string value "echo -ne "\033];${PWD##*/}\007"; :"; nested exception is java.lang.IllegalArgumentException: Could not resolve placeholder 'PWD##*/' in string value "echo -ne "\033];${PWD##*/}\007"; :"
at org.springframework.beans.factory.config.PlaceholderConfigurerSupport.doProcessProperties(PlaceholderConfigurerSupport.java:211) ~[spring-beans-4.1.5.RELEASE.jar:4.1.5.RELEASE]

I also removed ~/.grails/.slcache and the project .gradle directory, but get the same error. If you have other suggestions, please reach out (you know how to find me)


Best regards / Med venlig hilsen,
Søren Berg Glasius

40 Stevenson Ave, Berkeley, CA 94708
Mobile: <a href="tel:%28%2B1%29510%20984%208362" value="+15109848362" target="_blank">(+1)510 984 8362, Skype: sbglasius
--- Press ESC once to quit - twice to save the changes.

On 26 February 2015 at 15:33, Jeff Scott Brown <[hidden email]> wrote:

> On Feb 26, 2015, at 5:08 PM, Søren Berg Glasius <[hidden email]> wrote:
>
> Hi,
>
> Trying to create an app or a plugin I get this:
>
> sbg$ grails create-app --stacktrace g3
> | Error Could not checkout tag for Grails release [3.0.0.M2]: Ref v3.0.0.M2 can not be resolved (NOTE: Stack trace has been filtered. Use --verbose to see entire trace.)
> org.eclipse.jgit.api.errors.RefNotFoundException: Ref v3.0.0.M2 can not be resolved
>       at org.eclipse.jgit.api.CheckoutCommand.call(CheckoutCommand.java:244)
>       at org.grails.cli.profile.git.GitProfileRepository.checkoutTagForRelease(GitProfileRepository.groovy:128)
>       at org.grails.cli.profile.git.GitProfileRepository.createOrUpdateRepository(GitProfileRepository.groovy:116)
>       at org.grails.cli.profile.git.GitProfileRepository.getProfile(GitProfileRepository.groovy:56)
>       at org.grails.cli.profile.commands.CreateAppCommand.handle(CreateAppCommand.groovy:70)
>       at org.grails.cli.GrailsCli.execute(GrailsCli.groovy:174)
>       at org.grails.cli.GrailsCli.main(GrailsCli.groovy:100)
> | Error Could not checkout tag for Grails release [3.0.0.M2]: Ref v3.0.0.M2 can not be resolved
> | Application created at /Users/sbg/projects/diverse/g3
>
> Going to the directory and issuing a grails run-app I get this:
>
> BUILD SUCCESSFUL


If you delete your ~/.grails/repository/ folder, does the problem go away?



JSB
--
Jeff Scott Brown
[hidden email]

Autism Strikes 1 in 166
Find The Cause ~ Find The Cure
http://www.autismspeaks.org/



--
You received this message because you are subscribed to the Google Groups "Grails Dev Discuss" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/grails-dev-discuss/9C342D86-3698-456A-860A-DA36297E51BB%40pivotal.io.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "Grails Dev Discuss" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/grails-dev-discuss/CAGY%2BWWRbKRKvs0tbhCaHO4DErce_wAZ5dskASdbu%2BSLuKN4d7Q%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.


--
Graeme Rocher

--
You received this message because you are subscribed to the Google Groups "Grails Dev Discuss" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/grails-dev-discuss/CAO_wNofjYAt8ZzQ4gTwP3VYFkctQ8pwOQqfBX5C7NRvk5KoVoA%40mail.gmail.com.

For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "Grails Dev Discuss" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/grails-dev-discuss/CAGY%2BWWSZWAgu1S-RTa38cQ0fJDALSSk%3DJGgfpQgb-AKcPB4nSw%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

Re: ANN: Grails 3.0 M2 Released

Ronny Løvtangen
In reply to this post by sbglasius
I had the same problem with ~/.grails/repository/, had to remove it.

Best regards
Ronny Løvtangen

On 27 Feb 2015, at 06:51, Søren Berg Glasius <[hidden email]> wrote:

Hi Jeff

If I remove .grails/repository the first error goes away, but the second is persistent:

ERROR grails.boot.GrailsApp - Application startup failed
Exception in thread "main" org.springframework.beans.factory.BeanDefinitionStoreException: Invalid bean definition with name 'hibernateDatastore' defined in null: Could not resolve placeholder 'PWD##*/' in string value "echo -ne "\033];${PWD##*/}\007"; :"; nested exception is java.lang.IllegalArgumentException: Could not resolve placeholder 'PWD##*/' in string value "echo -ne "\033];${PWD##*/}\007"; :"
org.springframework.beans.factory.BeanDefinitionStoreException: Invalid bean definition with name 'hibernateDatastore' defined in null: Could not resolve placeholder 'PWD##*/' in string value "echo -ne "\033];${PWD##*/}\007"; :"; nested exception is java.lang.IllegalArgumentException: Could not resolve placeholder 'PWD##*/' in string value "echo -ne "\033];${PWD##*/}\007"; :"
at org.springframework.beans.factory.config.PlaceholderConfigurerSupport.doProcessProperties(PlaceholderConfigurerSupport.java:211) ~[spring-beans-4.1.5.RELEASE.jar:4.1.5.RELEASE]

I also removed ~/.grails/.slcache and the project .gradle directory, but get the same error. If you have other suggestions, please reach out (you know how to find me)


Best regards / Med venlig hilsen,
Søren Berg Glasius

40 Stevenson Ave, Berkeley, CA 94708
Mobile: (+1)510 984 8362, Skype: sbglasius
--- Press ESC once to quit - twice to save the changes.

On 26 February 2015 at 15:33, Jeff Scott Brown <[hidden email]> wrote:

> On Feb 26, 2015, at 5:08 PM, Søren Berg Glasius <[hidden email]> wrote:
>
> Hi,
>
> Trying to create an app or a plugin I get this:
>
> sbg$ grails create-app --stacktrace g3
> | Error Could not checkout tag for Grails release [3.0.0.M2]: Ref v3.0.0.M2 can not be resolved (NOTE: Stack trace has been filtered. Use --verbose to see entire trace.)
> org.eclipse.jgit.api.errors.RefNotFoundException: Ref v3.0.0.M2 can not be resolved
>       at org.eclipse.jgit.api.CheckoutCommand.call(CheckoutCommand.java:244)
>       at org.grails.cli.profile.git.GitProfileRepository.checkoutTagForRelease(GitProfileRepository.groovy:128)
>       at org.grails.cli.profile.git.GitProfileRepository.createOrUpdateRepository(GitProfileRepository.groovy:116)
>       at org.grails.cli.profile.git.GitProfileRepository.getProfile(GitProfileRepository.groovy:56)
>       at org.grails.cli.profile.commands.CreateAppCommand.handle(CreateAppCommand.groovy:70)
>       at org.grails.cli.GrailsCli.execute(GrailsCli.groovy:174)
>       at org.grails.cli.GrailsCli.main(GrailsCli.groovy:100)
> | Error Could not checkout tag for Grails release [3.0.0.M2]: Ref v3.0.0.M2 can not be resolved
> | Application created at /Users/sbg/projects/diverse/g3
>
> Going to the directory and issuing a grails run-app I get this:
>
> BUILD SUCCESSFUL


If you delete your ~/.grails/repository/ folder, does the problem go away?



JSB
--
Jeff Scott Brown
[hidden email]

Autism Strikes 1 in 166
Find The Cause ~ Find The Cure
http://www.autismspeaks.org/



--
You received this message because you are subscribed to the Google Groups "Grails Dev Discuss" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/grails-dev-discuss/9C342D86-3698-456A-860A-DA36297E51BB%40pivotal.io.
For more options, visit https://groups.google.com/d/optout.


--
You received this message because you are subscribed to the Google Groups "Grails Dev Discuss" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/grails-dev-discuss/CAGY%2BWWRbKRKvs0tbhCaHO4DErce_wAZ5dskASdbu%2BSLuKN4d7Q%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "Grails Dev Discuss" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/grails-dev-discuss/B118148E-7600-4FDD-A698-16E6F9F742E5%40lovtangen.com.
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

Re: ANN: Grails 3.0 M2 Released

Sumanth
In reply to this post by Graeme Rocher-2
How to participate with eventCompileStart in grails3 and gradle  

for example that is the equivalent method for Grails 2 code:

_Events.groovy
if (appName != 'grails-spring-batch') { //don't do this when compiling just the plugin.
    eventCompileStart = {
        if (new File("${basedir}/grails-app/batch").exists()) {
            ant.copy(todir:"$classesDirPath/batch", preservelastmodified:true) {
                fileset(dir:"${basedir}/grails-app/batch", includes:"**/*BatchConfig.groovy")
            }
        }
    }
}
 
Reply | Threaded
Open this post in threaded view
|

Re: ANN: Grails 3.0 M2 Released

Dave Brooks
In reply to this post by Graeme Rocher-2
New to Grails and following the documentation on the grails.org site. The documentation is marked with 3.0.0-M2, but the downloads, all seem to point to 2.4.4. What am I missing?

Thanks
Dave

On Thursday, February 26, 2015 at 2:01:19 PM UTC-5, Graeme Rocher wrote:
Hi all,

We released Grails 3.0 M2, this include a whole bunch of bug fixes
from M1 and a number of new features as well restoring lost features.

We are pretty much feature complete with just loose ends to tidy up.
Please try it out and upgrade your plugins!

The upgrade guide can be found here:
<a href="http://grails.github.io/grails-doc/latest/guide/upgrading.html" target="_blank" rel="nofollow" onmousedown="this.href='http://www.google.com/url?q\75http%3A%2F%2Fgrails.github.io%2Fgrails-doc%2Flatest%2Fguide%2Fupgrading.html\46sa\75D\46sntz\0751\46usg\75AFQjCNFhONxZFYJTak0LFbASgmMm_kiDwg';return true;" onclick="this.href='http://www.google.com/url?q\75http%3A%2F%2Fgrails.github.io%2Fgrails-doc%2Flatest%2Fguide%2Fupgrading.html\46sa\75D\46sntz\0751\46usg\75AFQjCNFhONxZFYJTak0LFbASgmMm_kiDwg';return true;">http://grails.github.io/grails-doc/latest/guide/upgrading.html

Thanks and enjoy!

Cheers

--
Graeme Rocher

--
You received this message because you are subscribed to the Google Groups "Grails Dev Discuss" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/grails-dev-discuss/b39032ce-0241-4009-baeb-1e90203223b2%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

Re: ANN: Grails 3.0 M2 Released

Graeme Rocher-2
You can obtain documentation for 2.4.4 by selecting the "Documentation
for older versions" select box at the bottom of the documentation page

On Mon, Mar 2, 2015 at 4:16 AM, Dave Brooks <[hidden email]> wrote:

> New to Grails and following the documentation on the grails.org site. The
> documentation is marked with 3.0.0-M2, but the downloads, all seem to point
> to 2.4.4. What am I missing?
>
> Thanks
> Dave
>
>
> On Thursday, February 26, 2015 at 2:01:19 PM UTC-5, Graeme Rocher wrote:
>>
>> Hi all,
>>
>> We released Grails 3.0 M2, this include a whole bunch of bug fixes
>> from M1 and a number of new features as well restoring lost features.
>>
>> We are pretty much feature complete with just loose ends to tidy up.
>> Please try it out and upgrade your plugins!
>>
>> The upgrade guide can be found here:
>> http://grails.github.io/grails-doc/latest/guide/upgrading.html
>>
>> Thanks and enjoy!
>>
>> Cheers
>>
>> --
>> Graeme Rocher
>
> --
> You received this message because you are subscribed to the Google Groups
> "Grails Dev Discuss" group.
> To unsubscribe from this group and stop receiving emails from it, send an
> email to [hidden email].
> To post to this group, send email to [hidden email].
> To view this discussion on the web visit
> https://groups.google.com/d/msgid/grails-dev-discuss/b39032ce-0241-4009-baeb-1e90203223b2%40googlegroups.com.
>
> For more options, visit https://groups.google.com/d/optout.



--
Graeme Rocher

--
You received this message because you are subscribed to the Google Groups "Grails Dev Discuss" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/grails-dev-discuss/CAO_wNodGnNL5XYHF0OcjyBDPkkvk0gwrFExk36-8Ruxd49G-0w%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

Re: ANN: Grails 3.0 M2 Released

Graeme Rocher-2
In reply to this post by Sumanth
generally in Gradle you define everything as tasks and dependencies,
so the same thing can be achieved with roughly (not tested example):

task copyBatchFiles(Copy) {
   from ${basedir}/grails-app/batch"
   into "$classesDirPath/batch"
}

compileGroovy.dependsOn(copyBatchFiles)

On Sat, Feb 28, 2015 at 8:28 PM, Sumanth <[hidden email]> wrote:

> How to participate with *eventCompileStart* in grails3 and gradle
>
> for example that is the equivalent method for Grails 2 code:
>
> _Events.groovy
> if (appName != 'grails-spring-batch') { //don't do this when compiling just
> the plugin.
>     eventCompileStart = {
>         if (new File("${basedir}/grails-app/batch").exists()) {
>             ant.copy(todir:"$classesDirPath/batch",
> preservelastmodified:true) {
>                 fileset(dir:"${basedir}/grails-app/batch",
> includes:"**/*BatchConfig.groovy")
>             }
>         }
>     }
> }
>
>
>
>
> --
> View this message in context: http://grails.1312388.n4.nabble.com/ANN-Grails-3-0-M2-Released-tp4658750p4658776.html
> Sent from the Grails Dev Discuss mailing list archive at Nabble.com.
>
> --
> You received this message because you are subscribed to the Google Groups "Grails Dev Discuss" group.
> To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
> To post to this group, send email to [hidden email].
> To view this discussion on the web visit https://groups.google.com/d/msgid/grails-dev-discuss/1425151730044-4658776.post%40n4.nabble.com.
> For more options, visit https://groups.google.com/d/optout.



--
Graeme Rocher

--
You received this message because you are subscribed to the Google Groups "Grails Dev Discuss" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/grails-dev-discuss/CAO_wNocJi8Aed61BW-xfWCZEGaR9sTiLF9CbQLUv4RO6qp3iPA%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.