CodeNarc 0.17 plugin download fails - but why?

classic Classic list List threaded Threaded
8 messages Options
Reply | Threaded
Open this post in threaded view
|

CodeNarc 0.17 plugin download fails - but why?

Georg S.
Hello,

when I tried to reinstall a project, I realized that the dependency to CodeNarc plugin must have changed, since the plugin couldn't be found on the repositories.

BuildConfig said:

plugins {
  compile ":codenarc:0.17"
 .. }


I had to see that http://m2repo.spockframework.org cannot be DNS-resolved :-/  (where does Ivy / Grails / actually retrieve the information from saying that this artifact is hosted on spockframework.org?)

After some researches I figured out that the name has been changed from "codenarc" to "CodeNarc" -
see http://repo.grails.org/grails/webapp/search/artifact?4&q=codenarc

As the artifact with version 0.17 (which seems to be the latest one) is on repo1-cache and not plugins-releases-local, it cannot be downloaded...

Any hint what to do?

Thanks and kind regards
 George
Reply | Threaded
Open this post in threaded view
|

Re: CodeNarc 0.17 plugin download fails - but why?

Jeff Scott Brown
Georg S. wrote:

> Hello,
>
> when I tried to reinstall a project, I realized that the dependency to
> CodeNarc plugin must have changed, since the plugin couldn't be found on the
> repositories.
>
> BuildConfig said:
>
> plugins {
>    compile ":codenarc:0.17"
>   .. }
>
>
> I had to see that http://m2repo.spockframework.org cannot be DNS-resolved
> :-/  (where does Ivy / Grails / actually retrieve the information from
> saying that this artifact is hosted on spockframework.org?)
>
> After some researches I figured out that the name has been changed from
> "codenarc" to "CodeNarc" -
> see http://repo.grails.org/grails/webapp/search/artifact?4&q=codenarc
>
> As the artifact with version 0.17 (which seems to be the latest one) is on
> repo1-cache and not plugins-releases-local, it cannot be downloaded...
>
> Any hint what to do?
>
> Thanks and kind regards
>   George
>
> --
> View this message in context: http://grails.1312388.n4.nabble.com/CodeNarc-0-17-plugin-download-fails-but-why-tp4628889.html
> Sent from the Grails - user mailing list archive at Nabble.com.
>
> ---------------------------------------------------------------------
> To unsubscribe from this list, please visit:
>
>      http://xircles.codehaus.org/manage_email
>
>

It looks like 0.17 still needs to be migrated to the new repo.  There is
a small snaggle in doing that so it may not happen immediately but we
will get it done asap and as soon as that happens, we will report back
here to let everyone know.

Thanks for the patience.



jb

--
Jeff Brown
SpringSource
http://www.springsource.com/

Autism Strikes 1 in 166
Find The Cause ~ Find The Cure
http://www.autismspeaks.org/

---------------------------------------------------------------------
To unsubscribe from this list, please visit:

    http://xircles.codehaus.org/manage_email


Reply | Threaded
Open this post in threaded view
|

Re: CodeNarc 0.17 plugin download fails - but why?

Graeme Rocher
Administrator
In reply to this post by Georg S.
Thanks, this should be corrected now

Cheers

On Wed, May 23, 2012 at 6:02 PM, Georg S. <[hidden email]> wrote:

> Hello,
>
> when I tried to reinstall a project, I realized that the dependency to
> CodeNarc plugin must have changed, since the plugin couldn't be found on the
> repositories.
>
> BuildConfig said:
>
> plugins {
>  compile ":codenarc:0.17"
>  .. }
>
>
> I had to see that http://m2repo.spockframework.org cannot be DNS-resolved
> :-/  (where does Ivy / Grails / actually retrieve the information from
> saying that this artifact is hosted on spockframework.org?)
>
> After some researches I figured out that the name has been changed from
> "codenarc" to "CodeNarc" -
> see http://repo.grails.org/grails/webapp/search/artifact?4&q=codenarc
>
> As the artifact with version 0.17 (which seems to be the latest one) is on
> repo1-cache and not plugins-releases-local, it cannot be downloaded...
>
> Any hint what to do?
>
> Thanks and kind regards
>  George
>
> --
> View this message in context: http://grails.1312388.n4.nabble.com/CodeNarc-0-17-plugin-download-fails-but-why-tp4628889.html
> Sent from the Grails - user mailing list archive at Nabble.com.
>
> ---------------------------------------------------------------------
> To unsubscribe from this list, please visit:
>
>    http://xircles.codehaus.org/manage_email
>
>



--
Graeme Rocher
Grails Project Lead
SpringSource - A Division of VMware
http://www.springsource.com

---------------------------------------------------------------------
To unsubscribe from this list, please visit:

    http://xircles.codehaus.org/manage_email


Reply | Threaded
Open this post in threaded view
|

Re: CodeNarc 0.17 plugin download fails - but why?

bond_
Hi Graeme,

I'm still getting:

        ::::::::::::::::::::::::::::::::::::::::::::::
        ::          UNRESOLVED DEPENDENCIES         ::
        ::::::::::::::::::::::::::::::::::::::::::::::
        :: org.springframework.ldap#org.springframework.ldap;1.3.0.RELEASE: not found
        :: org.springframework.security#org.springframework.security.ldap;3.0.4.RELEASE: not found
        ::::::::::::::::::::::::::::::::::::::::::::::

| Error Failed to resolve dependencies (Set log level to 'warn' in BuildConfig.groovy for more information):

- org.springframework.ldap:org.springframework.ldap:1.3.0.RELEASE
- org.springframework.security:org.springframework.security.ldap:3.0.4.RELEASE


On Thu, May 24, 2012 at 12:43 PM, Graeme Rocher <[hidden email]> wrote:
Thanks, this should be corrected now

Cheers

On Wed, May 23, 2012 at 6:02 PM, Georg S. <[hidden email]> wrote:
> Hello,
>
> when I tried to reinstall a project, I realized that the dependency to
> CodeNarc plugin must have changed, since the plugin couldn't be found on the
> repositories.
>
> BuildConfig said:
>
> plugins {
>  compile ":codenarc:0.17"
>  .. }
>
>
> I had to see that http://m2repo.spockframework.org cannot be DNS-resolved
> :-/  (where does Ivy / Grails / actually retrieve the information from
> saying that this artifact is hosted on spockframework.org?)
>
> After some researches I figured out that the name has been changed from
> "codenarc" to "CodeNarc" -
> see http://repo.grails.org/grails/webapp/search/artifact?4&q=codenarc
>
> As the artifact with version 0.17 (which seems to be the latest one) is on
> repo1-cache and not plugins-releases-local, it cannot be downloaded...
>
> Any hint what to do?
>
> Thanks and kind regards
>  George
>
> --
> View this message in context: http://grails.1312388.n4.nabble.com/CodeNarc-0-17-plugin-download-fails-but-why-tp4628889.html
> Sent from the Grails - user mailing list archive at Nabble.com.
>
> ---------------------------------------------------------------------
> To unsubscribe from this list, please visit:
>
>    http://xircles.codehaus.org/manage_email
>
>



--
Graeme Rocher
Grails Project Lead
SpringSource - A Division of VMware
http://www.springsource.com

---------------------------------------------------------------------
To unsubscribe from this list, please visit:

   http://xircles.codehaus.org/manage_email





--
Thanks and regards,
Ravi Teja

Reply | Threaded
Open this post in threaded view
|

Re: CodeNarc 0.17 plugin download fails - but why?

Georg S.
In reply to this post by Graeme Rocher
Hi Graeme,

thanks go to you :)
Unfortunately I still get the same error... I've cleaned the ivy-cache and tried to clean the application itself.

This is the list of servers that have been accessed:

        ==== grailsHome: tried
          -- artifact org.grails.plugins#CodeNarc;0.17!CodeNarc.zip:
          /Users/georg/Projekte/shared/libs/grails-2.0.3/plugins/CodeNarc-0.17.zip
        ==== grailsCentral: tried
          http://plugins.grails.org/grails-CodeNarc/tags/RELEASE_0.17/CodeNarc-0.17.pom
          -- artifact org.grails.plugins#CodeNarc;0.17!CodeNarc.zip:
          http://plugins.grails.org/grails-CodeNarc/tags/RELEASE_0.17/grails-CodeNarc-0.17.zip
        ==== http://repo.grails.org/grails/plugins: tried
          http://repo.grails.org/grails/plugins/org/grails/plugins/CodeNarc/0.17/CodeNarc-0.17.pom
          -- artifact org.grails.plugins#CodeNarc;0.17!CodeNarc.zip:
          http://repo.grails.org/grails/plugins/org/grails/plugins/CodeNarc/0.17/CodeNarc-0.17.zip
        ==== http://repo.grails.org/grails/core: tried
          http://repo.grails.org/grails/core/org/grails/plugins/CodeNarc/0.17/CodeNarc-0.17.pom
          -- artifact org.grails.plugins#CodeNarc;0.17!CodeNarc.zip:
          http://repo.grails.org/grails/core/org/grails/plugins/CodeNarc/0.17/CodeNarc-0.17.zip
        ==== grailsCore: tried
          http://svn.codehaus.org/grails/trunk/grails-plugins/grails-CodeNarc/tags/RELEASE_0.17/CodeNarc-0.17.pom
          -- artifact org.grails.plugins#CodeNarc;0.17!CodeNarc.zip:
          http://svn.codehaus.org/grails/trunk/grails-plugins/grails-CodeNarc/tags/RELEASE_0.17/grails-CodeNarc-0.17.zip
        ==== mavenCentral: tried
          http://repo1.maven.org/maven2/org/grails/plugins/CodeNarc/0.17/CodeNarc-0.17.pom
          -- artifact org.grails.plugins#CodeNarc;0.17!CodeNarc.zip:
          http://repo1.maven.org/maven2/org/grails/plugins/CodeNarc/0.17/CodeNarc-0.17.zip
        ==== http://repository.codehaus.org: tried
          http://repository.codehaus.org/org/grails/plugins/CodeNarc/0.17/CodeNarc-0.17.pom
          -- artifact org.grails.plugins#CodeNarc;0.17!CodeNarc.zip:
          http://repository.codehaus.org/org/grails/plugins/CodeNarc/0.17/CodeNarc-0.17.zip
        ==== http://download.java.net/maven/2/: tried
          http://download.java.net/maven/2/org/grails/plugins/CodeNarc/0.17/CodeNarc-0.17.pom
          -- artifact org.grails.plugins#CodeNarc;0.17!CodeNarc.zip:
          http://download.java.net/maven/2/org/grails/plugins/CodeNarc/0.17/CodeNarc-0.17.zip
        ==== http://maven.jenkins-ci.org/content/repositories/releases/: tried
          http://maven.jenkins-ci.org/content/repositories/releases/org/grails/plugins/CodeNarc/0.17/CodeNarc-0.17.pom
          -- artifact org.grails.plugins#CodeNarc;0.17!CodeNarc.zip:
          http://maven.jenkins-ci.org/content/repositories/releases/org/grails/plugins/CodeNarc/0.17/CodeNarc-0.17.zip
        ==== http://download.csssprites.org/maven2: tried
          http://download.csssprites.org/maven2/org/grails/plugins/CodeNarc/0.17/CodeNarc-0.17.pom
          -- artifact org.grails.plugins#CodeNarc;0.17!CodeNarc.zip:
          http://download.csssprites.org/maven2/org/grails/plugins/CodeNarc/0.17/CodeNarc-0.17.zip
        ==== http://oss.sonatype.org/content/repositories/github-releases: tried
          http://oss.sonatype.org/content/repositories/github-releases/org/grails/plugins/CodeNarc/0.17/CodeNarc-0.17.pom
          -- artifact org.grails.plugins#CodeNarc;0.17!CodeNarc.zip:
          http://oss.sonatype.org/content/repositories/github-releases/org/grails/plugins/CodeNarc/0.17/CodeNarc-0.17.zip
        ==== localMavenResolver: tried
          /Users/georg/.m2/repository/org/grails/plugins/CodeNarc/0.17/CodeNarc-0.17.pom
          -- artifact org.grails.plugins#CodeNarc;0.17!CodeNarc.zip:
          /Users/georg/.m2/repository/org/grails/plugins/CodeNarc/0.17/CodeNarc-0.17.zip
        ==== localMavenResolver: tried
          /Users/georg/.m2/repository/org/grails/plugins/CodeNarc/0.17/CodeNarc-0.17.pom
          -- artifact org.grails.plugins#CodeNarc;0.17!CodeNarc.zip:
          /Users/georg/.m2/repository/org/grails/plugins/CodeNarc/0.17/CodeNarc-0.17.zip
        ==== http://m2repo.spockframework.org/ext/: tried
          http://m2repo.spockframework.org/ext/org/grails/plugins/CodeNarc/0.17/CodeNarc-0.17.pom
          -- artifact org.grails.plugins#CodeNarc;0.17!CodeNarc.zip:
          http://m2repo.spockframework.org/ext/org/grails/plugins/CodeNarc/0.17/CodeNarc-0.17.zip
        ==== http://m2repo.spockframework.org/snapshots/: tried
          http://m2repo.spockframework.org/snapshots/org/grails/plugins/CodeNarc/0.17/CodeNarc-0.17.pom
          -- artifact org.grails.plugins#CodeNarc;0.17!CodeNarc.zip:
          http://m2repo.spockframework.org/snapshots/org/grails/plugins/CodeNarc/0.17/CodeNarc-0.17.zip

                ::::::::::::::::::::::::::::::::::::::::::::::
                ::          UNRESOLVED DEPENDENCIES         ::
                ::::::::::::::::::::::::::::::::::::::::::::::
                :: org.grails.plugins#CodeNarc;0.17: not found
                ::::::::::::::::::::::::::::::::::::::::::::::
Reply | Threaded
Open this post in threaded view
|

Re: CodeNarc 0.17 plugin download fails - but why?

burtbeckwith
In reply to this post by bond_

Different issue. Either upgrade to spring-security-ldap 1.0.6 or add the ebr() repo as I showed in the other thread.

Burt 

 


On May 24, 2012 at 3:46 AM Raviteja Lokineni <[hidden email]> wrote:

> Hi Graeme,
>
> I'm still getting:
>
>         ::::::::::::::::::::::::::::::::::::::::::::::
>         ::          UNRESOLVED DEPENDENCIES         ::
>         ::::::::::::::::::::::::::::::::::::::::::::::
>         :: org.springframework.ldap#org.springframework.ldap;1.3.0.RELEASE:
> not found
>         ::
> org.springframework.security#org.springframework.security.ldap;3.0.4.RELEASE:
> not found
>         ::::::::::::::::::::::::::::::::::::::::::::::
>
> | Error Failed to resolve dependencies (Set log level to 'warn' in
> BuildConfig.groovy for more information):
>
> - org.springframework.ldap:org.springframework.ldap:1.3.0.RELEASE
> -
> org.springframework.security:org.springframework.security.ldap:3.0.4.RELEASE
>
>
> On Thu, May 24, 2012 at 12:43 PM, Graeme Rocher <[hidden email]> wrote:
>
> > Thanks, this should be corrected now
> >
> > Cheers
> >
> > On Wed, May 23, 2012 at 6:02 PM, Georg S. <[hidden email]>
> > wrote:
> > > Hello,
> > >
> > > when I tried to reinstall a project, I realized that the dependency to
> > > CodeNarc plugin must have changed, since the plugin couldn't be found on
> > the
> > > repositories.
> > >
> > > BuildConfig said:
> > >
> > > plugins {
> > >  compile ":codenarc:0.17"
> > >  .. }
> > >
> > >
> > > I had to see that http://m2repo.spockframework.org cannot be
> > DNS-resolved
> > > :-/  (where does Ivy / Grails / actually retrieve the information from
> > > saying that this artifact is hosted on spockframework.org?)
> > >
> > > After some researches I figured out that the name has been changed from
> > > "codenarc" to "CodeNarc" -
> > > see http://repo.grails.org/grails/webapp/search/artifact?4&q=codenarc
> > >
> > > As the artifact with version 0.17 (which seems to be the latest one) is
> > on
> > > repo1-cache and not plugins-releases-local, it cannot be downloaded...
> > >
> > > Any hint what to do?
> > >
> > > Thanks and kind regards
> > >  George
> > >
> > > --
> > > View this message in context:
> > http://grails.1312388.n4.nabble.com/CodeNarc-0-17-plugin-download-fails-but-why-tp4628889.html
> > > Sent from the Grails - user mailing list archive at Nabble.com.
> > >
> > > ---------------------------------------------------------------------
> > > To unsubscribe from this list, please visit:
> > >
> > >    http://xircles.codehaus.org/manage_email
> > >
> > >
> >
> >
> >
> > --
> > Graeme Rocher
> > Grails Project Lead
> > SpringSource - A Division of VMware
> > http://www.springsource.com
> >
> > ---------------------------------------------------------------------
> > To unsubscribe from this list, please visit:
> >
> >    http://xircles.codehaus.org/manage_email
> >
> >
> >
>
>
> --
> Thanks and regards,
> Ravi Teja
Reply | Threaded
Open this post in threaded view
|

Re: CodeNarc 0.17 plugin download fails - but why?

bond_
In reply to this post by Georg S.
Check the case sensitivity and try. Looks like you've used CodeNarc instead of codenarc

On Thu, May 24, 2012 at 1:19 PM, Georg S. <[hidden email]> wrote:
Hi Graeme,

thanks go to you :)
Unfortunately I still get the same error... I've cleaned the ivy-cache and
tried to clean the application itself.

This is the list of servers that have been accessed:

       ==== grailsHome: tried
         -- artifact org.grails.plugins#CodeNarc;0.17!CodeNarc.zip:
         /Users/georg/Projekte/shared/libs/grails-2.0.3/plugins/CodeNarc-0.17.zip
       ==== grailsCentral: tried

http://plugins.grails.org/grails-CodeNarc/tags/RELEASE_0.17/CodeNarc-0.17.pom
         -- artifact org.grails.plugins#CodeNarc;0.17!CodeNarc.zip:

http://plugins.grails.org/grails-CodeNarc/tags/RELEASE_0.17/grails-CodeNarc-0.17.zip
       ==== http://repo.grails.org/grails/plugins: tried

http://repo.grails.org/grails/plugins/org/grails/plugins/CodeNarc/0.17/CodeNarc-0.17.pom
         -- artifact org.grails.plugins#CodeNarc;0.17!CodeNarc.zip:

http://repo.grails.org/grails/plugins/org/grails/plugins/CodeNarc/0.17/CodeNarc-0.17.zip
       ==== http://repo.grails.org/grails/core: tried

http://repo.grails.org/grails/core/org/grails/plugins/CodeNarc/0.17/CodeNarc-0.17.pom
         -- artifact org.grails.plugins#CodeNarc;0.17!CodeNarc.zip:

http://repo.grails.org/grails/core/org/grails/plugins/CodeNarc/0.17/CodeNarc-0.17.zip
       ==== grailsCore: tried

http://svn.codehaus.org/grails/trunk/grails-plugins/grails-CodeNarc/tags/RELEASE_0.17/CodeNarc-0.17.pom
         -- artifact org.grails.plugins#CodeNarc;0.17!CodeNarc.zip:

http://svn.codehaus.org/grails/trunk/grails-plugins/grails-CodeNarc/tags/RELEASE_0.17/grails-CodeNarc-0.17.zip
       ==== mavenCentral: tried

http://repo1.maven.org/maven2/org/grails/plugins/CodeNarc/0.17/CodeNarc-0.17.pom
         -- artifact org.grails.plugins#CodeNarc;0.17!CodeNarc.zip:

http://repo1.maven.org/maven2/org/grails/plugins/CodeNarc/0.17/CodeNarc-0.17.zip
       ==== http://repository.codehaus.org: tried

http://repository.codehaus.org/org/grails/plugins/CodeNarc/0.17/CodeNarc-0.17.pom
         -- artifact org.grails.plugins#CodeNarc;0.17!CodeNarc.zip:

http://repository.codehaus.org/org/grails/plugins/CodeNarc/0.17/CodeNarc-0.17.zip
       ==== http://download.java.net/maven/2/: tried

http://download.java.net/maven/2/org/grails/plugins/CodeNarc/0.17/CodeNarc-0.17.pom
         -- artifact org.grails.plugins#CodeNarc;0.17!CodeNarc.zip:

http://download.java.net/maven/2/org/grails/plugins/CodeNarc/0.17/CodeNarc-0.17.zip
       ==== http://maven.jenkins-ci.org/content/repositories/releases/: tried

http://maven.jenkins-ci.org/content/repositories/releases/org/grails/plugins/CodeNarc/0.17/CodeNarc-0.17.pom
         -- artifact org.grails.plugins#CodeNarc;0.17!CodeNarc.zip:

http://maven.jenkins-ci.org/content/repositories/releases/org/grails/plugins/CodeNarc/0.17/CodeNarc-0.17.zip
       ==== http://download.csssprites.org/maven2: tried

http://download.csssprites.org/maven2/org/grails/plugins/CodeNarc/0.17/CodeNarc-0.17.pom
         -- artifact org.grails.plugins#CodeNarc;0.17!CodeNarc.zip:

http://download.csssprites.org/maven2/org/grails/plugins/CodeNarc/0.17/CodeNarc-0.17.zip
       ==== http://oss.sonatype.org/content/repositories/github-releases: tried

http://oss.sonatype.org/content/repositories/github-releases/org/grails/plugins/CodeNarc/0.17/CodeNarc-0.17.pom
         -- artifact org.grails.plugins#CodeNarc;0.17!CodeNarc.zip:

http://oss.sonatype.org/content/repositories/github-releases/org/grails/plugins/CodeNarc/0.17/CodeNarc-0.17.zip
       ==== localMavenResolver: tried

/Users/georg/.m2/repository/org/grails/plugins/CodeNarc/0.17/CodeNarc-0.17.pom
         -- artifact org.grails.plugins#CodeNarc;0.17!CodeNarc.zip:

/Users/georg/.m2/repository/org/grails/plugins/CodeNarc/0.17/CodeNarc-0.17.zip
       ==== localMavenResolver: tried

/Users/georg/.m2/repository/org/grails/plugins/CodeNarc/0.17/CodeNarc-0.17.pom
         -- artifact org.grails.plugins#CodeNarc;0.17!CodeNarc.zip:

/Users/georg/.m2/repository/org/grails/plugins/CodeNarc/0.17/CodeNarc-0.17.zip
       ==== http://m2repo.spockframework.org/ext/: tried

http://m2repo.spockframework.org/ext/org/grails/plugins/CodeNarc/0.17/CodeNarc-0.17.pom
         -- artifact org.grails.plugins#CodeNarc;0.17!CodeNarc.zip:

http://m2repo.spockframework.org/ext/org/grails/plugins/CodeNarc/0.17/CodeNarc-0.17.zip
       ==== http://m2repo.spockframework.org/snapshots/: tried

http://m2repo.spockframework.org/snapshots/org/grails/plugins/CodeNarc/0.17/CodeNarc-0.17.pom
         -- artifact org.grails.plugins#CodeNarc;0.17!CodeNarc.zip:

http://m2repo.spockframework.org/snapshots/org/grails/plugins/CodeNarc/0.17/CodeNarc-0.17.zip

               ::::::::::::::::::::::::::::::::::::::::::::::
               ::          UNRESOLVED DEPENDENCIES         ::
               ::::::::::::::::::::::::::::::::::::::::::::::
               :: org.grails.plugins#CodeNarc;0.17: not found
               ::::::::::::::::::::::::::::::::::::::::::::::

--
View this message in context: http://grails.1312388.n4.nabble.com/CodeNarc-0-17-plugin-download-fails-but-why-tp4628889p4628921.html
Sent from the Grails - user mailing list archive at Nabble.com.

---------------------------------------------------------------------
To unsubscribe from this list, please visit:

   http://xircles.codehaus.org/manage_email





--
Thanks and regards,
Ravi Teja

Reply | Threaded
Open this post in threaded view
|

Re: CodeNarc 0.17 plugin download fails - but why?

Georg S.
In reply to this post by burtbeckwith
sorry @Graeme,

it was my mistake -

I should have used the 'old' and correct writing

compile ":codenarc:0.17"

instead.
Issue resolved. Thanks again!