Compilation issue while upgrading from grail 2.2.2 to 2.5.1

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Compilation issue while upgrading from grail 2.2.2 to 2.5.1

Pandit Sharma

I am doing a migration from grail 2.2.2 to grail 2.5.1.While upgrading that i am facing compilation issue for

import org.codehaus.groovy.grails.commons.ApplicationHolder

class which is present inside

spring-security-core-1.2.7.3\src\groovy\org\codehaus\groovy\grails\plugins\springsecurity\ReflectionUtils.groovy

I am using spring-security-core 1.2.7.3 and spring security ldap 1.0.6 version inside my plugin dependency tag inside the buildConfig.groovy. I tried to update the version but i am not finding the right combination for both the jars. Could someone help me to find the correct version of both the jars which is compatible with 2.5.1 grail version.

--
You received this message because you are subscribed to the Google Groups "Grails Dev Discuss" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/grails-dev-discuss/fa021737-d642-4c10-a49d-d0810efc6134%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

Re: Compilation issue while upgrading from grail 2.2.2 to 2.5.1

Burt Beckwith-3
Answered at https://stackoverflow.com/questions/40286010/compilation-issue-while-upgrading-from-grails-2-2-2-to-2-5-1

On Thursday, October 27, 2016 at 9:39:23 AM UTC-4, Pandit Sharma wrote:


down vote<a href="http://stackoverflow.com/questions/40286010/compilation-issue-while-upgrading-from-grail-2-2-2-to-2-5-1#" title="Click to mark as favorite question (click again to undo)" style="margin-right:auto;margin-bottom:2px;margin-left:auto;font-size:1px;color:rgb(0,119,204);background-image:url(&quot;img/sprites.svg?v=8c1c8cba242e&quot;),none;background-repeat:no-repeat;overflow:hidden;display:block;width:40px;min-height:30px;background-position:0px -120px" target="_blank" rel="nofollow" onmousedown="this.href=&#39;http://www.google.com/url?q\x3dhttp%3A%2F%2Fstackoverflow.com%2Fquestions%2F40286010%2Fcompilation-issue-while-upgrading-from-grail-2-2-2-to-2-5-1%23\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNEb5ID84OCazn81xOO9x5gtcIgZnw&#39;;return true;" onclick="this.href=&#39;http://www.google.com/url?q\x3dhttp%3A%2F%2Fstackoverflow.com%2Fquestions%2F40286010%2Fcompilation-issue-while-upgrading-from-grail-2-2-2-to-2-5-1%23\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNEb5ID84OCazn81xOO9x5gtcIgZnw&#39;;return true;">favorite

I am doing a migration from grail 2.2.2 to grail 2.5.1.While upgrading that i am facing compilation issue for

import org.codehaus.groovy.grails.commons.ApplicationHolder

class which is present inside

spring-security-core-1.2.7.3\src\groovy\org\codehaus\groovy\grails\plugins\springsecurity\ReflectionUtils.groovy

I am using spring-security-core 1.2.7.3 and spring security ldap 1.0.6 version inside my plugin dependency tag inside the buildConfig.groovy. I tried to update the version but i am not finding the right combination for both the jars. Could someone help me to find the correct version of both the jars which is compatible with 2.5.1 grail version.

--
You received this message because you are subscribed to the Google Groups "Grails Dev Discuss" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/grails-dev-discuss/80937064-fe9b-4bce-8c35-d771c849d759%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.