Deployed WAR not working as expected

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

Deployed WAR not working as expected

orion_mjcl
Hi everybody. First of all I want to tell that this is my first WAR I ever deployed. Well, I'm using IntelliJ IDEA to develop my Grails apps. I used an option given by this IDE to generate my WAR so it took me just one click to do this. But when I deployed it on Jetty it seemed like no CSS or image file was added, even some files like an index.gsp from Spring Security Plugin that had to be shown after login was missing.

Why is this happening?

Please help me.

Thanks in advance.
Reply | Threaded
Open this post in threaded view
|

Re: Deployed WAR not working as expected

marcopas
I do not if its an IDE issue but i personally believe that it is
better to use the "grails war" command to create the war file ready
for deployment.

http://grails.org/doc/latest/ref/Command%20Line/war.html

2013/1/25 orion_mjcl <[hidden email]>:

> Hi everybody. First of all I want to tell that this is my first WAR I ever
> deployed. Well, I'm using IntelliJ IDEA to develop my Grails apps. I used an
> option given by this IDE to generate my WAR so it took me just one click to
> do this. But when I deployed it on Jetty it seemed like no CSS or image file
> was added, even some files like an index.gsp from Spring Security Plugin
> that had to be shown after login was missing.
>
> Why is this happening?
>
> Please help me.
>
> Thanks in advance.
>
>
>
> --
> View this message in context: http://grails.1312388.n4.nabble.com/Deployed-WAR-not-working-as-expected-tp4640625.html
> Sent from the Grails - user mailing list archive at Nabble.com.
>
> ---------------------------------------------------------------------
> To unsubscribe from this list, please visit:
>
>     http://xircles.codehaus.org/manage_email
>
>

---------------------------------------------------------------------
To unsubscribe from this list, please visit:

    http://xircles.codehaus.org/manage_email


Reply | Threaded
Open this post in threaded view
|

Re: Deployed WAR not working as expected

orion_mjcl
Thank you for your answer marcopas. Well, I tried with the "war" command but it didn't solve my problem. By the way, I'm using Grails 1.3.7. I think this problem is already know (check this link: http://jira.grails.org/browse/GRAILS-7608) but I can't find enough information to solve this problem.

What do you think? Have you ever had this problem?

Help me please.
Reply | Threaded
Open this post in threaded view
|

Re: Deployed WAR not working as expected

Brad Whitaker
Very unlikely to be a Grails bug. To create a WAR using IntelliJ you need to edit "Run Configurations". (Run -> Edit Configurations...). If you have successfully run this app within IntelliJ, when you open this dialog you will see one existing configuration. You should copy this configuration (by selecting the configuration, then clicking the icon that looks like stacked sheets of paper). Change the command line from "run-app" to "war" and rename the config to "war". Now the run button will be a drop down with a choice of existing configurations.
Reply | Threaded
Open this post in threaded view
|

Re: Deployed WAR not working as expected

orion_mjcl
Thank you Brad. Well, I did what you said and I'm thinking, just like you, that is not a grails bug. I've just remembered the first time I ran my app and I had almost the same problem and I think it is related to UI Performance plugin use (ui-performance-1.2.2). Many image files can't be loaded and CSS files too. Even some gsp files that belong to plugins like Spring Security UI can't be loaded.

Can this UI Performance plugin be the main reason for my problem?

Regards.