Error executing tag <r:require>: No module found with name [NAME]

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

Error executing tag <r:require>: No module found with name [NAME]

Bocar Alpha Ba
Hii,
When i try to run my project who's using a specific layout below for displaying the content i got this error:



org
.codehaus.groovy.grails.web.mapping.exceptions.UrlMappingException: Error mapping onto view [/index]: Error applying layout : main
 at java
.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145)
 at java
.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)
 at java
.lang.Thread.run(Thread.java:745)
Caused by: org.codehaus.groovy.grails.web.pages.exceptions.GroovyPagesException: Error applying layout : main
 
... 3 more
Caused by: org.codehaus.groovy.grails.web.pages.exceptions.GroovyPagesException: Error processing GroovyPageView: Error executing tag <r:require>: No module found with name [Rest-api-doc-example]
 
... 3 more
Caused by: org.codehaus.groovy.grails.web.taglib.exceptions.GrailsTagException: Error executing tag <r:require>: No module found with name [Rest-api-doc-example]
 at C__Users_boba_git_Rest_api_doc_example_grails_app_views_layouts_main_gsp$_run_closure1
.doCall(main.gsp:15)
 at C__Users_boba_git_Rest_api_doc_example_grails_app_views_layouts_main_gsp
.run(main.gsp:19)
 
... 3 more
Caused by: java.lang.IllegalArgumentException: No module found with name [Rest-api-doc-example]
 at org
.grails.plugin.resource.ResourceProcessor.getAllModuleNamesRequired(ResourceProcessor.groovy:1188)
 at org
.grails.plugin.resource.ResourceProcessor.addModuleDispositionsToRequest(ResourceProcessor.groovy:1221)
 at org
.grails.plugin.resource.ResourceTagLib.declareModuleRequiredByPage(ResourceTagLib.groovy:125)
 at org
.grails.plugin.resource.ResourceTagLib$_closure5_closure18.doCall(ResourceTagLib.groovy:310)
 at org
.grails.plugin.resource.ResourceTagLib$_closure5.doCall(ResourceTagLib.groovy:306)

Below my layout located in /views/layout/main.gsp

<!DOCTYPE html>
<!--[if lt IE 7 ]> <html lang="en" class="no-js ie6"> <![endif]-->
<!--[if IE 7 ]>    <html lang="en" class="no-js ie7"> <![endif]-->
<!--[if IE 8 ]>    <html lang="en" class="no-js ie8"> <![endif]-->
<!--[if IE 9 ]>    <html lang="en" class="no-js ie9"> <![endif]-->
<!--[if (gt IE 9)|!(IE)]><!--> <html lang="en" class="no-js"><!--<![endif]-->
 
<head>
 
<meta http-equiv="Content-Type" content="text/html; charset=UTF-8">
 
<meta http-equiv="X-UA-Compatible" content="IE=edge,chrome=1">
 
<title><g:layoutTitle default="Grails"/></title>
 
<meta name="viewport" content="width=device-width, initial-scale=1.0">
 
<link rel="shortcut icon" href="${resource(dir: 'images', file: 'favicon.ico')}" type="image/x-icon">
 
<link rel="apple-touch-icon" href="${resource(dir: 'images', file: 'apple-touch-icon.png')}">
 
<link rel="apple-touch-icon" sizes="114x114" href="${resource(dir: 'images', file: 'apple-touch-icon-retina.png')}">
 
<r:require modules="Rest-api-doc-example"/>
 
<g:layoutHead/>
 
<g:javascript library="application"/>
 
<r:layoutResources />
 
</head>
 
<body>
 
<div id="grailsLogo" role="banner"><a href="http://grails.org"><img src="${resource(dir: 'images', file: 'grails_logo.png')}" alt="Grails"/></a></div>
 
<g:layoutBody/>
 
<div class="footer" role="contentinfo"></div>
 
<div id="spinner" class="spinner" style="display:none;"><g:message code="spinner.alt" default="Loading&hellip;"/></div>
 
<r:layoutResources />
 
</body>
</html>

I'm using plugin resources:1.2.13, 

Thanks in advance for helping me to fix that..

--
You received this message because you are subscribed to the Google Groups "Grails Dev Discuss" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/grails-dev-discuss/4107e5bc-fdd8-4f34-b857-2423d1a4b98d%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.