Error when attempting install of Grails Support in Eclipse

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

Error when attempting install of Grails Support in Eclipse

Al Brinin
Greetings,

I have installed Eclipse 4.3.2 (Kepler) and STS/GGTS 3.5.0 in Eclipse. I have successfully used the Spring Dashboard to install Grails 2.3.7. When I attempt to install the Grails Support software (which I need to develop Grails in Eclipse), I get the following error:

Grails IDE 3.5.0.201404011443-RELEASE (org.grails.ide.eclipse.feature.group 3.5.0.201404011443-RELEASE)
Missing requirement: SpringSource Tool Suite Grails Editor Support (UI) 3.5.0.201404011443-RELEASE (org.grails.ide.eclipse.editor.gsp 3.5.0.201404011443-RELEASE) requires 'bundle org.eclipse.wst.html.core 0.0.0' but it could not be found.

What is the fix in order to provide the missing package(s).

Thanks in advance.
Reply | Threaded
Open this post in threaded view
|

Re: Error when attempting install of Grails Support in Eclipse

burtbeckwith
GGTS comes with both the Groovy-Eclipse plugin and Grails support pre-installed. That's the whole point of the "Groovy Grails Tool Suite". From what you said though it looks like you installed a vanilla Eclipse first and then added GGTS to it - is that correct? All you need to do is download and install GGTS from http://spring.io/tools/ggts/all

You can then install a Grails distro within GGTS, but I prefer to do that separately, either manually or via GVM. It's simple to register a new Grails install from Window | Preferences | Groovy | Grails and later associate different apps/plugins with different versions of Grails.

Burt

Al Brinin wrote
Greetings,

I have installed Eclipse 4.3.2 (Kepler) and STS/GGTS 3.5.0 in Eclipse. I have successfully used the Spring Dashboard to install Grails 2.3.7. When I attempt to install the Grails Support software (which I need to develop Grails in Eclipse), I get the following error:

Grails IDE 3.5.0.201404011443-RELEASE (org.grails.ide.eclipse.feature.group 3.5.0.201404011443-RELEASE)
Missing requirement: SpringSource Tool Suite Grails Editor Support (UI) 3.5.0.201404011443-RELEASE (org.grails.ide.eclipse.editor.gsp 3.5.0.201404011443-RELEASE) requires 'bundle org.eclipse.wst.html.core 0.0.0' but it could not be found.

What is the fix in order to provide the missing package(s).

Thanks in advance.
Reply | Threaded
Open this post in threaded view
|

Re: Error when attempting install of Grails Support in Eclipse

Kris De Volder
In reply to this post by Al Brinin
You can try adding this update site: http://download.eclipse.org/releases/kepler/
To the list of 'Available Update Sites'.
Then try installing again.

This is probably a problem with the update site embedded in the dashboard entry. I will look into it and get it fixed.

The problem is likely because you used a 'smaller' eclipse distribution. The dependency you are missing would exist in a 'Eclipse for JEE developers' but not in a 'Eclipse for Java Developers' or 'Eclipse Standard'.
Reply | Threaded
Open this post in threaded view
|

Re: Error when attempting install of Grails Support in Eclipse

Al Brinin
In reply to this post by burtbeckwith
Yes.,i installed Eclipse 4.3.2 first then added GGTS from the Market Place, then from the Dashboard installed Grails.,,but it does not have the support in place to create Grails projects in Eclipse, so I thought I had to install Grails Support from the Dashboard as well. That's what the Grails Wiki was telling to do.,,

I'll look at the ggts/all link you referenced..

On Apr 4, 2014, at 1:53 PM, "burtbeckwith [via Grails]" <[hidden email]> wrote:

GGTS comes with both the Groovy-Eclipse plugin and Grails support pre-installed. That's the whole point of the "Groovy Grails Tool Suite". From what you said though it looks like you installed a vanilla Eclipse first and then added GGTS to it - is that correct? All you need to do is download and install GGTS from http://spring.io/tools/ggts/all

You can then install a Grails distro within GGTS, but I prefer to do that separately, either manually or via GVM. It's simple to register a new Grails install from Window | Preferences | Groovy | Grails and later associate different apps/plugins with different versions of Grails.

Burt

Al Brinin wrote
Greetings,

I have installed Eclipse 4.3.2 (Kepler) and STS/GGTS 3.5.0 in Eclipse. I have successfully used the Spring Dashboard to install Grails 2.3.7. When I attempt to install the Grails Support software (which I need to develop Grails in Eclipse), I get the following error:

Grails IDE 3.5.0.201404011443-RELEASE (org.grails.ide.eclipse.feature.group 3.5.0.201404011443-RELEASE)
Missing requirement: SpringSource Tool Suite Grails Editor Support (UI) 3.5.0.201404011443-RELEASE (org.grails.ide.eclipse.editor.gsp 3.5.0.201404011443-RELEASE) requires 'bundle org.eclipse.wst.html.core 0.0.0' but it could not be found.

What is the fix in order to provide the missing package(s).

Thanks in advance.



If you reply to this email, your message will be added to the discussion below:
http://grails.1312388.n4.nabble.com/Error-when-attempting-install-of-Grails-Support-in-Eclipse-tp4655742p4655743.html
To unsubscribe from Error when attempting install of Grails Support in Eclipse, click here.
NAML
Reply | Threaded
Open this post in threaded view
|

Re: Error when attempting install of Grails Support in Eclipse

Al Brinin
In reply to this post by Kris De Volder
Yes I used Standard, I'll look at J2EE version

thanks

On Apr 4, 2014, at 4:03 PM, "Kris De Volder [via Grails]"<[hidden email]> wrote:

You can try adding this update site: http://download.eclipse.org/releases/kepler/
To the list of 'Available Update Sites'.
Then try installing again.

This is probably a problem with the update site embedded in the dashboard entry. I will look into it and get it fixed.

The problem is likely because you used a 'smaller' eclipse distribution. The dependency you are missing would exist in a 'Eclipse for JEE developers' but not in a 'Eclipse for Java Developers' or 'Eclipse Standard'.


If you reply to this email, your message will be added to the discussion below:
http://grails.1312388.n4.nabble.com/Error-when-attempting-install-of-Grails-Support-in-Eclipse-tp4655742p4655746.html
To unsubscribe from Error when attempting install of Grails Support in Eclipse, click here.
NAML