FW: can't build grails war with "mvn install"

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

FW: can't build grails war with "mvn install"

Daryoush Mehrtash-3

 

 

I am running with  Grails 1.1.1 and maven grails plugin 1.1-SNAPSHOT.     To build the project “mvn grails:war” works fine.  But when I try to do “mvn install” it fails with the following message:

 

[INFO] ------------------------------------------------------------------------

[ERROR] BUILD ERROR

[INFO] ------------------------------------------------------------------------

[INFO] Error assembling WAR: webxml attribute is required (or pre-existing WEB-INF/web.xml if executing in update mode

 

I need to do my build “mvn install” since the project is build with “mvn install” from the root (along with other java modules under my parent node).

 

Is there a way to get “mvn install” to work?   If not, is there a way to map install to “grails:war” in my grails project?

 

Thanks,


Daryoush

Reply | Threaded
Open this post in threaded view
|

Re: FW: can't build grails war with "mvn install"

Sebastien ARBOGAST
I have exactly the same problem now with a Grails 1.3.2 project. Any idea anyone?

Sébastien Arbogast



2009/6/18 Daryoush Mehrtash <[hidden email]>

 

 

I am running with  Grails 1.1.1 and maven grails plugin 1.1-SNAPSHOT.     To build the project “mvn grails:war” works fine.  But when I try to do “mvn install” it fails with the following message:

 

[INFO] ------------------------------------------------------------------------

[ERROR] BUILD ERROR

[INFO] ------------------------------------------------------------------------

[INFO] Error assembling WAR: webxml attribute is required (or pre-existing WEB-INF/web.xml if executing in update mode

 

I need to do my build “mvn install” since the project is build with “mvn install” from the root (along with other java modules under my parent node).

 

Is there a way to get “mvn install” to work?   If not, is there a way to map install to “grails:war” in my grails project?

 

Thanks,


Daryoush


Reply | Threaded
Open this post in threaded view
|

Re: FW: can't build grails war with "mvn install"

Sebastien ARBOGAST
For those who are looking for a solution to this problem, all you have to do is create an empty web.xml under src/main/webapp/WEB-INF and it should work.

Sébastien Arbogast



2010/6/22 Sebastien ARBOGAST <[hidden email]>
I have exactly the same problem now with a Grails 1.3.2 project. Any idea anyone?

Sébastien Arbogast



2009/6/18 Daryoush Mehrtash <[hidden email]>

 

 

I am running with  Grails 1.1.1 and maven grails plugin 1.1-SNAPSHOT.     To build the project “mvn grails:war” works fine.  But when I try to do “mvn install” it fails with the following message:

 

[INFO] ------------------------------------------------------------------------

[ERROR] BUILD ERROR

[INFO] ------------------------------------------------------------------------

[INFO] Error assembling WAR: webxml attribute is required (or pre-existing WEB-INF/web.xml if executing in update mode

 

I need to do my build “mvn install” since the project is build with “mvn install” from the root (along with other java modules under my parent node).

 

Is there a way to get “mvn install” to work?   If not, is there a way to map install to “grails:war” in my grails project?

 

Thanks,


Daryoush



Reply | Threaded
Open this post in threaded view
|

Re: FW: can't build grails war with "mvn install"

chelder86
Thank you. It worked perfectly