Grails 0.6 RC1 available

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
48 messages Options
123
Reply | Threaded
Open this post in threaded view
|

Grails 0.6 RC1 available

graemer
Dear Grails users

We have made availabe Grails 0.6 RC1 to download at http://grails.org/Download

This is the oppurtunity for the user community to test their apps and
raise issues which can then be considered for 0.6 final

We plan to make 0.6 final available towards the end of next week,
which will come with a bigger announcement as per usual. We have some
interum release notes available here:

http://grails.org/0.6+Release+Notes

These are subject to change over the next week.

Thanks for your help on this

Cheers

--
Graeme Rocher
Grails Project Lead
http://grails.org

---------------------------------------------------------------------
To unsubscribe from this list please visit:

    http://xircles.codehaus.org/manage_email

Reply | Threaded
Open this post in threaded view
|

Re: Grails 0.6 RC1 available

Marcel Overdijk
Perfect!

Does this mean

- Implement support for JSP custom tag libraries in GSP  and
- Refactor scaffolding to make it more pluggable and extensible

will be moved to 0.7?

(we might update the roadmap then)


Cheers,
Marcel


graemer wrote
Dear Grails users

We have made availabe Grails 0.6 RC1 to download at http://grails.org/Download

This is the oppurtunity for the user community to test their apps and
raise issues which can then be considered for 0.6 final

We plan to make 0.6 final available towards the end of next week,
which will come with a bigger announcement as per usual. We have some
interum release notes available here:

http://grails.org/0.6+Release+Notes

These are subject to change over the next week.

Thanks for your help on this

Cheers

--
Graeme Rocher
Grails Project Lead
http://grails.org

---------------------------------------------------------------------
To unsubscribe from this list please visit:

    http://xircles.codehaus.org/manage_email
Reply | Threaded
Open this post in threaded view
|

Re: Grails 0.6 RC1 available

graemer
I have not decided whether either of those features are still going to
make it into 1.0 yet

I would prefer to release a stable 1.0 without those features than not
release anything in October

Cheers

On 8/22/07, Marcel Overdijk <[hidden email]> wrote:

>
> Perfect!
>
> Does this mean
>
> - Implement support for JSP custom tag libraries in GSP  and
> - Refactor scaffolding to make it more pluggable and extensible
>
> will be moved to 0.7?
>
> (we might update the roadmap then)
>
>
> Cheers,
> Marcel
>
>
>
> graemer wrote:
> >
> > Dear Grails users
> >
> > We have made availabe Grails 0.6 RC1 to download at
> > http://grails.org/Download
> >
> > This is the oppurtunity for the user community to test their apps and
> > raise issues which can then be considered for 0.6 final
> >
> > We plan to make 0.6 final available towards the end of next week,
> > which will come with a bigger announcement as per usual. We have some
> > interum release notes available here:
> >
> > http://grails.org/0.6+Release+Notes
> >
> > These are subject to change over the next week.
> >
> > Thanks for your help on this
> >
> > Cheers
> >
> > --
> > Graeme Rocher
> > Grails Project Lead
> > http://grails.org
> >
> > ---------------------------------------------------------------------
> > To unsubscribe from this list please visit:
> >
> >     http://xircles.codehaus.org/manage_email
> >
> >
> >
>
> --
> View this message in context: http://www.nabble.com/Grails-0.6-RC1-available-tf4310955.html#a12272783
> Sent from the grails - user mailing list archive at Nabble.com.
>
>
> ---------------------------------------------------------------------
> To unsubscribe from this list please visit:
>
>     http://xircles.codehaus.org/manage_email
>
>


--
Graeme Rocher
Grails Project Lead
http://grails.org

---------------------------------------------------------------------
To unsubscribe from this list please visit:

    http://xircles.codehaus.org/manage_email

Reply | Threaded
Open this post in threaded view
|

Re: Grails 0.6 RC1 available

elvanor
Hello,

Just updated to 0.6-RC1 to test things I wrote about this morning.

I now have the following error when starting grails:

Error creating bean with name 'sessionFactory': Invocation of init
method failed;
Caused by: org.hibernate.MappingException: An AnnotationConfiguration
instance is required to use <mapping class="Section"/>

I did not change yet anything except running grails upgrade. Any help?

Btw, what is the Groovy version used in 0.6 vs 0.5.6 ? Is groovy-1.1-beta2 used?

Jean-Noël

On 8/22/07, Graeme Rocher <[hidden email]> wrote:

> I have not decided whether either of those features are still going to
> make it into 1.0 yet
>
> I would prefer to release a stable 1.0 without those features than not
> release anything in October
>
> Cheers
>
> On 8/22/07, Marcel Overdijk <[hidden email]> wrote:
> >
> > Perfect!
> >
> > Does this mean
> >
> > - Implement support for JSP custom tag libraries in GSP  and
> > - Refactor scaffolding to make it more pluggable and extensible
> >
> > will be moved to 0.7?
> >
> > (we might update the roadmap then)
> >
> >
> > Cheers,
> > Marcel
> >
> >
> >
> > graemer wrote:
> > >
> > > Dear Grails users
> > >
> > > We have made availabe Grails 0.6 RC1 to download at
> > > http://grails.org/Download
> > >
> > > This is the oppurtunity for the user community to test their apps and
> > > raise issues which can then be considered for 0.6 final
> > >
> > > We plan to make 0.6 final available towards the end of next week,
> > > which will come with a bigger announcement as per usual. We have some
> > > interum release notes available here:
> > >
> > > http://grails.org/0.6+Release+Notes
> > >
> > > These are subject to change over the next week.
> > >
> > > Thanks for your help on this
> > >
> > > Cheers
> > >
> > > --
> > > Graeme Rocher
> > > Grails Project Lead
> > > http://grails.org
> > >
> > > ---------------------------------------------------------------------
> > > To unsubscribe from this list please visit:
> > >
> > >     http://xircles.codehaus.org/manage_email
> > >
> > >
> > >
> >
> > --
> > View this message in context: http://www.nabble.com/Grails-0.6-RC1-available-tf4310955.html#a12272783
> > Sent from the grails - user mailing list archive at Nabble.com.
> >
> >
> > ---------------------------------------------------------------------
> > To unsubscribe from this list please visit:
> >
> >     http://xircles.codehaus.org/manage_email
> >
> >
>
>
> --
> Graeme Rocher
> Grails Project Lead
> http://grails.org
>
> ---------------------------------------------------------------------
> To unsubscribe from this list please visit:
>
>     http://xircles.codehaus.org/manage_email
>
>
Reply | Threaded
Open this post in threaded view
|

Re: Grails 0.6 RC1 available

graemer
The DataSource format has changed for 0.6, you need modify
grails-app/conf/DataSource.groovy to supply a the
GrailsAnnotationConfiguration instance. See here for example:

http://svn.grails.codehaus.org/browse/grails/trunk/grails-samples/recipes/grails-app/conf/DataSource.groovy?r=5114

For Groovy we are using a recently built version of the upcoming beta 3

Cheers

On 8/22/07, Jean-Noël Rivasseau <[hidden email]> wrote:

> Hello,
>
> Just updated to 0.6-RC1 to test things I wrote about this morning.
>
> I now have the following error when starting grails:
>
> Error creating bean with name 'sessionFactory': Invocation of init
> method failed;
> Caused by: org.hibernate.MappingException: An AnnotationConfiguration
> instance is required to use <mapping class="Section"/>
>
> I did not change yet anything except running grails upgrade. Any help?
>
> Btw, what is the Groovy version used in 0.6 vs 0.5.6 ? Is groovy-1.1-beta2 used?
>
> Jean-Noël
>
> On 8/22/07, Graeme Rocher <[hidden email]> wrote:
> > I have not decided whether either of those features are still going to
> > make it into 1.0 yet
> >
> > I would prefer to release a stable 1.0 without those features than not
> > release anything in October
> >
> > Cheers
> >
> > On 8/22/07, Marcel Overdijk <[hidden email]> wrote:
> > >
> > > Perfect!
> > >
> > > Does this mean
> > >
> > > - Implement support for JSP custom tag libraries in GSP  and
> > > - Refactor scaffolding to make it more pluggable and extensible
> > >
> > > will be moved to 0.7?
> > >
> > > (we might update the roadmap then)
> > >
> > >
> > > Cheers,
> > > Marcel
> > >
> > >
> > >
> > > graemer wrote:
> > > >
> > > > Dear Grails users
> > > >
> > > > We have made availabe Grails 0.6 RC1 to download at
> > > > http://grails.org/Download
> > > >
> > > > This is the oppurtunity for the user community to test their apps and
> > > > raise issues which can then be considered for 0.6 final
> > > >
> > > > We plan to make 0.6 final available towards the end of next week,
> > > > which will come with a bigger announcement as per usual. We have some
> > > > interum release notes available here:
> > > >
> > > > http://grails.org/0.6+Release+Notes
> > > >
> > > > These are subject to change over the next week.
> > > >
> > > > Thanks for your help on this
> > > >
> > > > Cheers
> > > >
> > > > --
> > > > Graeme Rocher
> > > > Grails Project Lead
> > > > http://grails.org
> > > >
> > > > ---------------------------------------------------------------------
> > > > To unsubscribe from this list please visit:
> > > >
> > > >     http://xircles.codehaus.org/manage_email
> > > >
> > > >
> > > >
> > >
> > > --
> > > View this message in context: http://www.nabble.com/Grails-0.6-RC1-available-tf4310955.html#a12272783
> > > Sent from the grails - user mailing list archive at Nabble.com.
> > >
> > >
> > > ---------------------------------------------------------------------
> > > To unsubscribe from this list please visit:
> > >
> > >     http://xircles.codehaus.org/manage_email
> > >
> > >
> >
> >
> > --
> > Graeme Rocher
> > Grails Project Lead
> > http://grails.org
> >
> > ---------------------------------------------------------------------
> > To unsubscribe from this list please visit:
> >
> >     http://xircles.codehaus.org/manage_email
> >
> >
>


--
Graeme Rocher
Grails Project Lead
http://grails.org

---------------------------------------------------------------------
To unsubscribe from this list please visit:

    http://xircles.codehaus.org/manage_email

Reply | Threaded
Open this post in threaded view
|

Re: Grails 0.6 RC1 available

Marcell Manfrin Barbacena
Is GRAILS-1452 going to make 0.6?

[]s

On 8/22/07, Graeme Rocher <[hidden email]> wrote:

> The DataSource format has changed for 0.6, you need modify
> grails-app/conf/DataSource.groovy to supply a the
> GrailsAnnotationConfiguration instance. See here for example:
>
> http://svn.grails.codehaus.org/browse/grails/trunk/grails-samples/recipes/grails-app/conf/DataSource.groovy?r=5114
>
> For Groovy we are using a recently built version of the upcoming beta 3
>
> Cheers
>
> On 8/22/07, Jean-Noël Rivasseau <[hidden email]> wrote:
> > Hello,
> >
> > Just updated to 0.6-RC1 to test things I wrote about this morning.
> >
> > I now have the following error when starting grails:
> >
> > Error creating bean with name 'sessionFactory': Invocation of init
> > method failed;
> > Caused by: org.hibernate.MappingException: An AnnotationConfiguration
> > instance is required to use <mapping class="Section"/>
> >
> > I did not change yet anything except running grails upgrade. Any help?
> >
> > Btw, what is the Groovy version used in 0.6 vs 0.5.6 ? Is groovy-1.1-beta2 used?
> >
> > Jean-Noël
> >
> > On 8/22/07, Graeme Rocher <[hidden email]> wrote:
> > > I have not decided whether either of those features are still going to
> > > make it into 1.0 yet
> > >
> > > I would prefer to release a stable 1.0 without those features than not
> > > release anything in October
> > >
> > > Cheers
> > >
> > > On 8/22/07, Marcel Overdijk <[hidden email]> wrote:
> > > >
> > > > Perfect!
> > > >
> > > > Does this mean
> > > >
> > > > - Implement support for JSP custom tag libraries in GSP  and
> > > > - Refactor scaffolding to make it more pluggable and extensible
> > > >
> > > > will be moved to 0.7?
> > > >
> > > > (we might update the roadmap then)
> > > >
> > > >
> > > > Cheers,
> > > > Marcel
> > > >
> > > >
> > > >
> > > > graemer wrote:
> > > > >
> > > > > Dear Grails users
> > > > >
> > > > > We have made availabe Grails 0.6 RC1 to download at
> > > > > http://grails.org/Download
> > > > >
> > > > > This is the oppurtunity for the user community to test their apps and
> > > > > raise issues which can then be considered for 0.6 final
> > > > >
> > > > > We plan to make 0.6 final available towards the end of next week,
> > > > > which will come with a bigger announcement as per usual. We have some
> > > > > interum release notes available here:
> > > > >
> > > > > http://grails.org/0.6+Release+Notes
> > > > >
> > > > > These are subject to change over the next week.
> > > > >
> > > > > Thanks for your help on this
> > > > >
> > > > > Cheers
> > > > >
> > > > > --
> > > > > Graeme Rocher
> > > > > Grails Project Lead
> > > > > http://grails.org
> > > > >
> > > > > ---------------------------------------------------------------------
> > > > > To unsubscribe from this list please visit:
> > > > >
> > > > >     http://xircles.codehaus.org/manage_email
> > > > >
> > > > >
> > > > >
> > > >
> > > > --
> > > > View this message in context: http://www.nabble.com/Grails-0.6-RC1-available-tf4310955.html#a12272783
> > > > Sent from the grails - user mailing list archive at Nabble.com.
> > > >
> > > >
> > > > ---------------------------------------------------------------------
> > > > To unsubscribe from this list please visit:
> > > >
> > > >     http://xircles.codehaus.org/manage_email
> > > >
> > > >
> > >
> > >
> > > --
> > > Graeme Rocher
> > > Grails Project Lead
> > > http://grails.org
> > >
> > > ---------------------------------------------------------------------
> > > To unsubscribe from this list please visit:
> > >
> > >     http://xircles.codehaus.org/manage_email
> > >
> > >
> >
>
>
> --
> Graeme Rocher
> Grails Project Lead
> http://grails.org
>
> ---------------------------------------------------------------------
> To unsubscribe from this list please visit:
>
>     http://xircles.codehaus.org/manage_email
>
>


--
"Nobody knows who i really am
 I never felt this empty before
 And if I never need someone to come along
 Who's gonna comfort me and keep me strong?"
--
Marcell Manfrin Barbacena
[hidden email]
MSN Messenger: [hidden email]
ICQ UIN: 63671762
Skype: callto://marcell84bruk
+55 (83) 8808-8555 (Oi)
+55 (62) 8172-5708 (Tim)

---------------------------------------------------------------------
To unsubscribe from this list please visit:

    http://xircles.codehaus.org/manage_email

Reply | Threaded
Open this post in threaded view
|

Re: Grails 0.6 RC1 available

graemer
Yes

Cheers

On 8/22/07, Marcell Manfrin Barbacena <[hidden email]> wrote:

> Is GRAILS-1452 going to make 0.6?
>
> []s
>
> On 8/22/07, Graeme Rocher <[hidden email]> wrote:
> > The DataSource format has changed for 0.6, you need modify
> > grails-app/conf/DataSource.groovy to supply a the
> > GrailsAnnotationConfiguration instance. See here for example:
> >
> > http://svn.grails.codehaus.org/browse/grails/trunk/grails-samples/recipes/grails-app/conf/DataSource.groovy?r=5114
> >
> > For Groovy we are using a recently built version of the upcoming beta 3
> >
> > Cheers
> >
> > On 8/22/07, Jean-Noël Rivasseau <[hidden email]> wrote:
> > > Hello,
> > >
> > > Just updated to 0.6-RC1 to test things I wrote about this morning.
> > >
> > > I now have the following error when starting grails:
> > >
> > > Error creating bean with name 'sessionFactory': Invocation of init
> > > method failed;
> > > Caused by: org.hibernate.MappingException: An AnnotationConfiguration
> > > instance is required to use <mapping class="Section"/>
> > >
> > > I did not change yet anything except running grails upgrade. Any help?
> > >
> > > Btw, what is the Groovy version used in 0.6 vs 0.5.6 ? Is groovy-1.1-beta2 used?
> > >
> > > Jean-Noël
> > >
> > > On 8/22/07, Graeme Rocher <[hidden email]> wrote:
> > > > I have not decided whether either of those features are still going to
> > > > make it into 1.0 yet
> > > >
> > > > I would prefer to release a stable 1.0 without those features than not
> > > > release anything in October
> > > >
> > > > Cheers
> > > >
> > > > On 8/22/07, Marcel Overdijk <[hidden email]> wrote:
> > > > >
> > > > > Perfect!
> > > > >
> > > > > Does this mean
> > > > >
> > > > > - Implement support for JSP custom tag libraries in GSP  and
> > > > > - Refactor scaffolding to make it more pluggable and extensible
> > > > >
> > > > > will be moved to 0.7?
> > > > >
> > > > > (we might update the roadmap then)
> > > > >
> > > > >
> > > > > Cheers,
> > > > > Marcel
> > > > >
> > > > >
> > > > >
> > > > > graemer wrote:
> > > > > >
> > > > > > Dear Grails users
> > > > > >
> > > > > > We have made availabe Grails 0.6 RC1 to download at
> > > > > > http://grails.org/Download
> > > > > >
> > > > > > This is the oppurtunity for the user community to test their apps and
> > > > > > raise issues which can then be considered for 0.6 final
> > > > > >
> > > > > > We plan to make 0.6 final available towards the end of next week,
> > > > > > which will come with a bigger announcement as per usual. We have some
> > > > > > interum release notes available here:
> > > > > >
> > > > > > http://grails.org/0.6+Release+Notes
> > > > > >
> > > > > > These are subject to change over the next week.
> > > > > >
> > > > > > Thanks for your help on this
> > > > > >
> > > > > > Cheers
> > > > > >
> > > > > > --
> > > > > > Graeme Rocher
> > > > > > Grails Project Lead
> > > > > > http://grails.org
> > > > > >
> > > > > > ---------------------------------------------------------------------
> > > > > > To unsubscribe from this list please visit:
> > > > > >
> > > > > >     http://xircles.codehaus.org/manage_email
> > > > > >
> > > > > >
> > > > > >
> > > > >
> > > > > --
> > > > > View this message in context: http://www.nabble.com/Grails-0.6-RC1-available-tf4310955.html#a12272783
> > > > > Sent from the grails - user mailing list archive at Nabble.com.
> > > > >
> > > > >
> > > > > ---------------------------------------------------------------------
> > > > > To unsubscribe from this list please visit:
> > > > >
> > > > >     http://xircles.codehaus.org/manage_email
> > > > >
> > > > >
> > > >
> > > >
> > > > --
> > > > Graeme Rocher
> > > > Grails Project Lead
> > > > http://grails.org
> > > >
> > > > ---------------------------------------------------------------------
> > > > To unsubscribe from this list please visit:
> > > >
> > > >     http://xircles.codehaus.org/manage_email
> > > >
> > > >
> > >
> >
> >
> > --
> > Graeme Rocher
> > Grails Project Lead
> > http://grails.org
> >
> > ---------------------------------------------------------------------
> > To unsubscribe from this list please visit:
> >
> >     http://xircles.codehaus.org/manage_email
> >
> >
>
>
> --
> "Nobody knows who i really am
>  I never felt this empty before
>  And if I never need someone to come along
>  Who's gonna comfort me and keep me strong?"
> --
> Marcell Manfrin Barbacena
> [hidden email]
> MSN Messenger: [hidden email]
> ICQ UIN: 63671762
> Skype: callto://marcell84bruk
> +55 (83) 8808-8555 (Oi)
> +55 (62) 8172-5708 (Tim)
>
> ---------------------------------------------------------------------
> To unsubscribe from this list please visit:
>
>     http://xircles.codehaus.org/manage_email
>
>


--
Graeme Rocher
Grails Project Lead
http://grails.org

---------------------------------------------------------------------
To unsubscribe from this list please visit:

    http://xircles.codehaus.org/manage_email

Reply | Threaded
Open this post in threaded view
|

Re: Grails 0.6 RC1 available

graemer
Oh no sorry, i t hought you meant 1.0. No it won't be in 0.6, it will
be in the next release

Cheers

On 8/22/07, Graeme Rocher <[hidden email]> wrote:

> Yes
>
> Cheers
>
> On 8/22/07, Marcell Manfrin Barbacena <[hidden email]> wrote:
> > Is GRAILS-1452 going to make 0.6?
> >
> > []s
> >
> > On 8/22/07, Graeme Rocher <[hidden email]> wrote:
> > > The DataSource format has changed for 0.6, you need modify
> > > grails-app/conf/DataSource.groovy to supply a the
> > > GrailsAnnotationConfiguration instance. See here for example:
> > >
> > > http://svn.grails.codehaus.org/browse/grails/trunk/grails-samples/recipes/grails-app/conf/DataSource.groovy?r=5114
> > >
> > > For Groovy we are using a recently built version of the upcoming beta 3
> > >
> > > Cheers
> > >
> > > On 8/22/07, Jean-Noël Rivasseau <[hidden email]> wrote:
> > > > Hello,
> > > >
> > > > Just updated to 0.6-RC1 to test things I wrote about this morning.
> > > >
> > > > I now have the following error when starting grails:
> > > >
> > > > Error creating bean with name 'sessionFactory': Invocation of init
> > > > method failed;
> > > > Caused by: org.hibernate.MappingException: An AnnotationConfiguration
> > > > instance is required to use <mapping class="Section"/>
> > > >
> > > > I did not change yet anything except running grails upgrade. Any help?
> > > >
> > > > Btw, what is the Groovy version used in 0.6 vs 0.5.6 ? Is groovy-1.1-beta2 used?
> > > >
> > > > Jean-Noël
> > > >
> > > > On 8/22/07, Graeme Rocher <[hidden email]> wrote:
> > > > > I have not decided whether either of those features are still going to
> > > > > make it into 1.0 yet
> > > > >
> > > > > I would prefer to release a stable 1.0 without those features than not
> > > > > release anything in October
> > > > >
> > > > > Cheers
> > > > >
> > > > > On 8/22/07, Marcel Overdijk <[hidden email]> wrote:
> > > > > >
> > > > > > Perfect!
> > > > > >
> > > > > > Does this mean
> > > > > >
> > > > > > - Implement support for JSP custom tag libraries in GSP  and
> > > > > > - Refactor scaffolding to make it more pluggable and extensible
> > > > > >
> > > > > > will be moved to 0.7?
> > > > > >
> > > > > > (we might update the roadmap then)
> > > > > >
> > > > > >
> > > > > > Cheers,
> > > > > > Marcel
> > > > > >
> > > > > >
> > > > > >
> > > > > > graemer wrote:
> > > > > > >
> > > > > > > Dear Grails users
> > > > > > >
> > > > > > > We have made availabe Grails 0.6 RC1 to download at
> > > > > > > http://grails.org/Download
> > > > > > >
> > > > > > > This is the oppurtunity for the user community to test their apps and
> > > > > > > raise issues which can then be considered for 0.6 final
> > > > > > >
> > > > > > > We plan to make 0.6 final available towards the end of next week,
> > > > > > > which will come with a bigger announcement as per usual. We have some
> > > > > > > interum release notes available here:
> > > > > > >
> > > > > > > http://grails.org/0.6+Release+Notes
> > > > > > >
> > > > > > > These are subject to change over the next week.
> > > > > > >
> > > > > > > Thanks for your help on this
> > > > > > >
> > > > > > > Cheers
> > > > > > >
> > > > > > > --
> > > > > > > Graeme Rocher
> > > > > > > Grails Project Lead
> > > > > > > http://grails.org
> > > > > > >
> > > > > > > ---------------------------------------------------------------------
> > > > > > > To unsubscribe from this list please visit:
> > > > > > >
> > > > > > >     http://xircles.codehaus.org/manage_email
> > > > > > >
> > > > > > >
> > > > > > >
> > > > > >
> > > > > > --
> > > > > > View this message in context: http://www.nabble.com/Grails-0.6-RC1-available-tf4310955.html#a12272783
> > > > > > Sent from the grails - user mailing list archive at Nabble.com.
> > > > > >
> > > > > >
> > > > > > ---------------------------------------------------------------------
> > > > > > To unsubscribe from this list please visit:
> > > > > >
> > > > > >     http://xircles.codehaus.org/manage_email
> > > > > >
> > > > > >
> > > > >
> > > > >
> > > > > --
> > > > > Graeme Rocher
> > > > > Grails Project Lead
> > > > > http://grails.org
> > > > >
> > > > > ---------------------------------------------------------------------
> > > > > To unsubscribe from this list please visit:
> > > > >
> > > > >     http://xircles.codehaus.org/manage_email
> > > > >
> > > > >
> > > >
> > >
> > >
> > > --
> > > Graeme Rocher
> > > Grails Project Lead
> > > http://grails.org
> > >
> > > ---------------------------------------------------------------------
> > > To unsubscribe from this list please visit:
> > >
> > >     http://xircles.codehaus.org/manage_email
> > >
> > >
> >
> >
> > --
> > "Nobody knows who i really am
> >  I never felt this empty before
> >  And if I never need someone to come along
> >  Who's gonna comfort me and keep me strong?"
> > --
> > Marcell Manfrin Barbacena
> > [hidden email]
> > MSN Messenger: [hidden email]
> > ICQ UIN: 63671762
> > Skype: callto://marcell84bruk
> > +55 (83) 8808-8555 (Oi)
> > +55 (62) 8172-5708 (Tim)
> >
> > ---------------------------------------------------------------------
> > To unsubscribe from this list please visit:
> >
> >     http://xircles.codehaus.org/manage_email
> >
> >
>
>
> --
> Graeme Rocher
> Grails Project Lead
> http://grails.org
>


--
Graeme Rocher
Grails Project Lead
http://grails.org

---------------------------------------------------------------------
To unsubscribe from this list please visit:

    http://xircles.codehaus.org/manage_email

Reply | Threaded
Open this post in threaded view
|

Re: Grails 0.6 RC1 available

Marcell Manfrin Barbacena
Ok. Ty

[]s

On 8/22/07, Graeme Rocher <[hidden email]> wrote:

> Oh no sorry, i t hought you meant 1.0. No it won't be in 0.6, it will
> be in the next release
>
> Cheers
>
> On 8/22/07, Graeme Rocher <[hidden email]> wrote:
> > Yes
> >
> > Cheers
> >
> > On 8/22/07, Marcell Manfrin Barbacena <[hidden email]> wrote:
> > > Is GRAILS-1452 going to make 0.6?
> > >
> > > []s
> > >
> > > On 8/22/07, Graeme Rocher <[hidden email]> wrote:
> > > > The DataSource format has changed for 0.6, you need modify
> > > > grails-app/conf/DataSource.groovy to supply a the
> > > > GrailsAnnotationConfiguration instance. See here for example:
> > > >
> > > > http://svn.grails.codehaus.org/browse/grails/trunk/grails-samples/recipes/grails-app/conf/DataSource.groovy?r=5114
> > > >
> > > > For Groovy we are using a recently built version of the upcoming beta 3
> > > >
> > > > Cheers
> > > >
> > > > On 8/22/07, Jean-Noël Rivasseau <[hidden email]> wrote:
> > > > > Hello,
> > > > >
> > > > > Just updated to 0.6-RC1 to test things I wrote about this morning.
> > > > >
> > > > > I now have the following error when starting grails:
> > > > >
> > > > > Error creating bean with name 'sessionFactory': Invocation of init
> > > > > method failed;
> > > > > Caused by: org.hibernate.MappingException: An AnnotationConfiguration
> > > > > instance is required to use <mapping class="Section"/>
> > > > >
> > > > > I did not change yet anything except running grails upgrade. Any help?
> > > > >
> > > > > Btw, what is the Groovy version used in 0.6 vs 0.5.6 ? Is groovy-1.1-beta2 used?
> > > > >
> > > > > Jean-Noël
> > > > >
> > > > > On 8/22/07, Graeme Rocher <[hidden email]> wrote:
> > > > > > I have not decided whether either of those features are still going to
> > > > > > make it into 1.0 yet
> > > > > >
> > > > > > I would prefer to release a stable 1.0 without those features than not
> > > > > > release anything in October
> > > > > >
> > > > > > Cheers
> > > > > >
> > > > > > On 8/22/07, Marcel Overdijk <[hidden email]> wrote:
> > > > > > >
> > > > > > > Perfect!
> > > > > > >
> > > > > > > Does this mean
> > > > > > >
> > > > > > > - Implement support for JSP custom tag libraries in GSP  and
> > > > > > > - Refactor scaffolding to make it more pluggable and extensible
> > > > > > >
> > > > > > > will be moved to 0.7?
> > > > > > >
> > > > > > > (we might update the roadmap then)
> > > > > > >
> > > > > > >
> > > > > > > Cheers,
> > > > > > > Marcel
> > > > > > >
> > > > > > >
> > > > > > >
> > > > > > > graemer wrote:
> > > > > > > >
> > > > > > > > Dear Grails users
> > > > > > > >
> > > > > > > > We have made availabe Grails 0.6 RC1 to download at
> > > > > > > > http://grails.org/Download
> > > > > > > >
> > > > > > > > This is the oppurtunity for the user community to test their apps and
> > > > > > > > raise issues which can then be considered for 0.6 final
> > > > > > > >
> > > > > > > > We plan to make 0.6 final available towards the end of next week,
> > > > > > > > which will come with a bigger announcement as per usual. We have some
> > > > > > > > interum release notes available here:
> > > > > > > >
> > > > > > > > http://grails.org/0.6+Release+Notes
> > > > > > > >
> > > > > > > > These are subject to change over the next week.
> > > > > > > >
> > > > > > > > Thanks for your help on this
> > > > > > > >
> > > > > > > > Cheers
> > > > > > > >
> > > > > > > > --
> > > > > > > > Graeme Rocher
> > > > > > > > Grails Project Lead
> > > > > > > > http://grails.org
> > > > > > > >
> > > > > > > > ---------------------------------------------------------------------
> > > > > > > > To unsubscribe from this list please visit:
> > > > > > > >
> > > > > > > >     http://xircles.codehaus.org/manage_email
> > > > > > > >
> > > > > > > >
> > > > > > > >
> > > > > > >
> > > > > > > --
> > > > > > > View this message in context: http://www.nabble.com/Grails-0.6-RC1-available-tf4310955.html#a12272783
> > > > > > > Sent from the grails - user mailing list archive at Nabble.com.
> > > > > > >
> > > > > > >
> > > > > > > ---------------------------------------------------------------------
> > > > > > > To unsubscribe from this list please visit:
> > > > > > >
> > > > > > >     http://xircles.codehaus.org/manage_email
> > > > > > >
> > > > > > >
> > > > > >
> > > > > >
> > > > > > --
> > > > > > Graeme Rocher
> > > > > > Grails Project Lead
> > > > > > http://grails.org
> > > > > >
> > > > > > ---------------------------------------------------------------------
> > > > > > To unsubscribe from this list please visit:
> > > > > >
> > > > > >     http://xircles.codehaus.org/manage_email
> > > > > >
> > > > > >
> > > > >
> > > >
> > > >
> > > > --
> > > > Graeme Rocher
> > > > Grails Project Lead
> > > > http://grails.org
> > > >
> > > > ---------------------------------------------------------------------
> > > > To unsubscribe from this list please visit:
> > > >
> > > >     http://xircles.codehaus.org/manage_email
> > > >
> > > >
> > >
> > >
> > > --
> > > "Nobody knows who i really am
> > >  I never felt this empty before
> > >  And if I never need someone to come along
> > >  Who's gonna comfort me and keep me strong?"
> > > --
> > > Marcell Manfrin Barbacena
> > > [hidden email]
> > > MSN Messenger: [hidden email]
> > > ICQ UIN: 63671762
> > > Skype: callto://marcell84bruk
> > > +55 (83) 8808-8555 (Oi)
> > > +55 (62) 8172-5708 (Tim)
> > >
> > > ---------------------------------------------------------------------
> > > To unsubscribe from this list please visit:
> > >
> > >     http://xircles.codehaus.org/manage_email
> > >
> > >
> >
> >
> > --
> > Graeme Rocher
> > Grails Project Lead
> > http://grails.org
> >
>
>
> --
> Graeme Rocher
> Grails Project Lead
> http://grails.org
>
> ---------------------------------------------------------------------
> To unsubscribe from this list please visit:
>
>     http://xircles.codehaus.org/manage_email
>
>


--
"Nobody knows who i really am
 I never felt this empty before
 And if I never need someone to come along
 Who's gonna comfort me and keep me strong?"
--
Marcell Manfrin Barbacena
[hidden email]
MSN Messenger: [hidden email]
ICQ UIN: 63671762
Skype: callto://marcell84bruk
+55 (83) 8808-8555 (Oi)
+55 (62) 8172-5708 (Tim)

---------------------------------------------------------------------
To unsubscribe from this list please visit:

    http://xircles.codehaus.org/manage_email

Reply | Threaded
Open this post in threaded view
|

Re: Grails 0.6 RC1 available

elvanor
In reply to this post by graemer
Hi and thanks for the help. Is there an upgrade guide available?

First I assumed you must delete the old files
DevelopmentDataSource.groovy, etc as it seemed that now everything is
in DataSource.groovy. But I am not certain. It seems to work ok now
though. Will investigate now the stuff I wanted wrt annotations.

In 0.5.6 what was the Groovy version used?

Jean-Noël


PS: if I did not delete the previous DevelopmentDataSource.groovy
file, I ran into strange errors, the server would start but would keep
reloading itslef (presumably thinking a source file changed, so
attempted to autoreload).






On 8/22/07, Graeme Rocher <[hidden email]> wrote:

> The DataSource format has changed for 0.6, you need modify
> grails-app/conf/DataSource.groovy to supply a the
> GrailsAnnotationConfiguration instance. See here for example:
>
> http://svn.grails.codehaus.org/browse/grails/trunk/grails-samples/recipes/grails-app/conf/DataSource.groovy?r=5114
>
> For Groovy we are using a recently built version of the upcoming beta 3
>
> Cheers
>
> On 8/22/07, Jean-Noël Rivasseau <[hidden email]> wrote:
> > Hello,
> >
> > Just updated to 0.6-RC1 to test things I wrote about this morning.
> >
> > I now have the following error when starting grails:
> >
> > Error creating bean with name 'sessionFactory': Invocation of init
> > method failed;
> > Caused by: org.hibernate.MappingException: An AnnotationConfiguration
> > instance is required to use <mapping class="Section"/>
> >
> > I did not change yet anything except running grails upgrade. Any help?
> >
> > Btw, what is the Groovy version used in 0.6 vs 0.5.6 ? Is groovy-1.1-beta2 used?
> >
> > Jean-Noël
> >
> > On 8/22/07, Graeme Rocher <[hidden email]> wrote:
> > > I have not decided whether either of those features are still going to
> > > make it into 1.0 yet
> > >
> > > I would prefer to release a stable 1.0 without those features than not
> > > release anything in October
> > >
> > > Cheers
> > >
> > > On 8/22/07, Marcel Overdijk <[hidden email]> wrote:
> > > >
> > > > Perfect!
> > > >
> > > > Does this mean
> > > >
> > > > - Implement support for JSP custom tag libraries in GSP  and
> > > > - Refactor scaffolding to make it more pluggable and extensible
> > > >
> > > > will be moved to 0.7?
> > > >
> > > > (we might update the roadmap then)
> > > >
> > > >
> > > > Cheers,
> > > > Marcel
> > > >
> > > >
> > > >
> > > > graemer wrote:
> > > > >
> > > > > Dear Grails users
> > > > >
> > > > > We have made availabe Grails 0.6 RC1 to download at
> > > > > http://grails.org/Download
> > > > >
> > > > > This is the oppurtunity for the user community to test their apps and
> > > > > raise issues which can then be considered for 0.6 final
> > > > >
> > > > > We plan to make 0.6 final available towards the end of next week,
> > > > > which will come with a bigger announcement as per usual. We have some
> > > > > interum release notes available here:
> > > > >
> > > > > http://grails.org/0.6+Release+Notes
> > > > >
> > > > > These are subject to change over the next week.
> > > > >
> > > > > Thanks for your help on this
> > > > >
> > > > > Cheers
> > > > >
> > > > > --
> > > > > Graeme Rocher
> > > > > Grails Project Lead
> > > > > http://grails.org
> > > > >
> > > > > ---------------------------------------------------------------------
> > > > > To unsubscribe from this list please visit:
> > > > >
> > > > >     http://xircles.codehaus.org/manage_email
> > > > >
> > > > >
> > > > >
> > > >
> > > > --
> > > > View this message in context: http://www.nabble.com/Grails-0.6-RC1-available-tf4310955.html#a12272783
> > > > Sent from the grails - user mailing list archive at Nabble.com.
> > > >
> > > >
> > > > ---------------------------------------------------------------------
> > > > To unsubscribe from this list please visit:
> > > >
> > > >     http://xircles.codehaus.org/manage_email
> > > >
> > > >
> > >
> > >
> > > --
> > > Graeme Rocher
> > > Grails Project Lead
> > > http://grails.org
> > >
> > > ---------------------------------------------------------------------
> > > To unsubscribe from this list please visit:
> > >
> > >     http://xircles.codehaus.org/manage_email
> > >
> > >
> >
>
>
> --
> Graeme Rocher
> Grails Project Lead
> http://grails.org
>
> ---------------------------------------------------------------------
> To unsubscribe from this list please visit:
>
>     http://xircles.codehaus.org/manage_email
>
>
Reply | Threaded
Open this post in threaded view
|

Re: Grails 0.6 RC1 available

Marcos Silva Pereira
In reply to this post by graemer
Wonderful news. :-D

I have made an announcement here:
http://www.javafree.org/news/view.jf?idNew=3634

Kind Regards

On 8/22/07, Graeme Rocher <[hidden email]> wrote:
Dear Grails users

We have made availabe Grails 0.6 RC1 to download at http://grails.org/Download

This is the oppurtunity for the user community to test their apps and
raise issues which can then be considered for 0.6 final

We plan to make 0.6 final available towards the end of next week,
which will come with a bigger announcement as per usual. We have some
interum release notes available here:

http://grails.org/0.6+Release+Notes

These are subject to change over the next week.

Thanks for your help on this

Cheers

--
Graeme Rocher
Grails Project Lead
http://grails.org

---------------------------------------------------------------------
To unsubscribe from this list please visit:

     http://xircles.codehaus.org/manage_email




--
Marcos Silva Pereira
http://marcospereira.wordpress.com
"You only live once.", James Brown
Reply | Threaded
Open this post in threaded view
|

Re: Grails 0.6 RC1 available

elvanor
I am confused about some of the behavior I am seeing currently. First,
I was able to move my groovy class with Hibernate annotations from
src/groovy back to grails-app/domain, and the Hibernate errors are
gone. However the annotations don't seem to have any effect
currently?...

What's even stranger is that I kept an old class in src/groovy,
annotated. When dropping the tables, Grails will recreate them but if
I change the annotations (to change the name of the table for example)
Grails keep recreating the old ones!! Is there a Hibernate
configuration cache somewhere I should delete? What's happening?

Jean-Noël

PS: I already deleted the compiled .class files in ~/.grails. Did not help.

On 8/22/07, Marcos Silva Pereira <[hidden email]> wrote:

> Wonderful news. :-D
>
> I have made an announcement here:
> http://www.javafree.org/news/view.jf?idNew=3634
>
> Kind Regards
>
>  On 8/22/07, Graeme Rocher <[hidden email]> wrote:
> > Dear Grails users
> >
> > We have made availabe Grails 0.6 RC1 to download at
> http://grails.org/Download
> >
> > This is the oppurtunity for the user community to test their apps and
> > raise issues which can then be considered for 0.6 final
> >
> > We plan to make 0.6 final available towards the end of next week,
> > which will come with a bigger announcement as per usual. We have some
> > interum release notes available here:
> >
> > http://grails.org/0.6+Release+Notes
> >
> > These are subject to change over the next week.
> >
> > Thanks for your help on this
> >
> > Cheers
> >
> > --
> > Graeme Rocher
> > Grails Project Lead
> > http://grails.org
> >
> >
> ---------------------------------------------------------------------
> > To unsubscribe from this list please visit:
> >
> >      http://xircles.codehaus.org/manage_email
> >
> >
>
>
>
> --
> Marcos Silva Pereira
> http://marcospereira.wordpress.com
> "You only live once.", James Brown
Reply | Threaded
Open this post in threaded view
|

Re: Grails 0.6 RC1 available

elvanor
Found the problem - it seemed some Groovy compiled file was in
web-app/WEB-INF/classes, and the new Grails 0.6 does not like that (it
seems it put everything in ~/.grails/ ).

On 8/22/07, Jean-Noël Rivasseau <[hidden email]> wrote:

> I am confused about some of the behavior I am seeing currently. First,
> I was able to move my groovy class with Hibernate annotations from
> src/groovy back to grails-app/domain, and the Hibernate errors are
> gone. However the annotations don't seem to have any effect
> currently?...
>
> What's even stranger is that I kept an old class in src/groovy,
> annotated. When dropping the tables, Grails will recreate them but if
> I change the annotations (to change the name of the table for example)
> Grails keep recreating the old ones!! Is there a Hibernate
> configuration cache somewhere I should delete? What's happening?
>
> Jean-Noël
>
> PS: I already deleted the compiled .class files in ~/.grails. Did not help.
>
> On 8/22/07, Marcos Silva Pereira <[hidden email]> wrote:
> > Wonderful news. :-D
> >
> > I have made an announcement here:
> > http://www.javafree.org/news/view.jf?idNew=3634
> >
> > Kind Regards
> >
> >  On 8/22/07, Graeme Rocher <[hidden email]> wrote:
> > > Dear Grails users
> > >
> > > We have made availabe Grails 0.6 RC1 to download at
> > http://grails.org/Download
> > >
> > > This is the oppurtunity for the user community to test their apps and
> > > raise issues which can then be considered for 0.6 final
> > >
> > > We plan to make 0.6 final available towards the end of next week,
> > > which will come with a bigger announcement as per usual. We have some
> > > interum release notes available here:
> > >
> > > http://grails.org/0.6+Release+Notes
> > >
> > > These are subject to change over the next week.
> > >
> > > Thanks for your help on this
> > >
> > > Cheers
> > >
> > > --
> > > Graeme Rocher
> > > Grails Project Lead
> > > http://grails.org
> > >
> > >
> > ---------------------------------------------------------------------
> > > To unsubscribe from this list please visit:
> > >
> > >      http://xircles.codehaus.org/manage_email
> > >
> > >
> >
> >
> >
> > --
> > Marcos Silva Pereira
> > http://marcospereira.wordpress.com
> > "You only live once.", James Brown
>
Reply | Threaded
Open this post in threaded view
|

Grails 0.6 question: Acegi/Spring initialisation?

hamishagain@dcs.shef.ac.uk
Hi,

I'm converting an app to 0.6; most things work fine :-)


One problem: when trying to initialise Acegi I get the following:

ERROR org.springframework.web.context.ContextLoader Context initialization failed
org.springframework.beans.factory.BeanCreationException: Error creating bean
with name 'userDetailsService': Error setting property values; nested
exception is org.springframework.beans.PropertyBatchUpdateException; nested
PropertyAccessExceptions (5) are:
PropertyAccessException 1: org.springframework.beans.TypeMismatchException:
Failed to convert property value of type [grails.spring.BeanBuilder] to
required type [java.lang.String] for property 'userName'


Is there some change to the way Spring works in 0.6, or...?


The code is in the plugin doWithSpring closure and looks like this:

/** daoAuthenticationProvider */
daoAuthenticationProvider(org.acegisecurity.providers.dao.DaoAuthenticationProvider)
{
   userDetailsService=ref("userDetailsService")
   passwordEncoder=ref("passwordEncoder")
   userCache=ref("userCache")
}


Thanks,
--
Hamish
http://www.dcs.shef.ac.uk/~hamish/

---------------------------------------------------------------------
To unsubscribe from this list please visit:

    http://xircles.codehaus.org/manage_email

Reply | Threaded
Open this post in threaded view
|

Re: Grails 0.6 question: Acegi/Spring initialisation?

graemer
Hmm what is the exact line that is causing the problem. I think your
error relates to a bean called "userDetailsService" and its "userName"
property

This seams a different part of the code
Cheers

On 8/22/07, Hamish Cunningham <[hidden email]> wrote:

> Hi,
>
> I'm converting an app to 0.6; most things work fine :-)
>
>
> One problem: when trying to initialise Acegi I get the following:
>
> ERROR org.springframework.web.context.ContextLoader Context initialization failed
> org.springframework.beans.factory.BeanCreationException: Error creating bean
> with name 'userDetailsService': Error setting property values; nested
> exception is org.springframework.beans.PropertyBatchUpdateException; nested
> PropertyAccessExceptions (5) are:
> PropertyAccessException 1: org.springframework.beans.TypeMismatchException:
> Failed to convert property value of type [grails.spring.BeanBuilder] to
> required type [java.lang.String] for property 'userName'
>
>
> Is there some change to the way Spring works in 0.6, or...?
>
>
> The code is in the plugin doWithSpring closure and looks like this:
>
> /** daoAuthenticationProvider */
> daoAuthenticationProvider(org.acegisecurity.providers.dao.DaoAuthenticationProvider)
> {
>    userDetailsService=ref("userDetailsService")
>    passwordEncoder=ref("passwordEncoder")
>    userCache=ref("userCache")
> }
>
>
> Thanks,
> --
> Hamish
> http://www.dcs.shef.ac.uk/~hamish/
>
> ---------------------------------------------------------------------
> To unsubscribe from this list please visit:
>
>     http://xircles.codehaus.org/manage_email
>
>


--
Graeme Rocher
Grails Project Lead
http://grails.org

---------------------------------------------------------------------
To unsubscribe from this list please visit:

    http://xircles.codehaus.org/manage_email

Reply | Threaded
Open this post in threaded view
|

Re: Grails 0.6 question: Acegi/Spring initialisation?

Andreas Schmitt
I also experienced that issue and solved it tweaking AcegiGrailsPlugin. The problem was a method in AcegiGrailsPlugin.groovy that confused
the spring builder. I replaced it with a closure.

Cheers

Andreas

2007/8/22, Graeme Rocher <[hidden email]>:
Hmm what is the exact line that is causing the problem. I think your
error relates to a bean called "userDetailsService" and its "userName"
property

This seams a different part of the code
Cheers

On 8/22/07, Hamish Cunningham <[hidden email]> wrote:

> Hi,
>
> I'm converting an app to 0.6; most things work fine :-)
>
>
> One problem: when trying to initialise Acegi I get the following:
>
> ERROR org.springframework.web.context.ContextLoader Context initialization failed
> org.springframework.beans.factory.BeanCreationException : Error creating bean
> with name 'userDetailsService': Error setting property values; nested
> exception is org.springframework.beans.PropertyBatchUpdateException; nested
> PropertyAccessExceptions (5) are:
> PropertyAccessException 1: org.springframework.beans.TypeMismatchException:
> Failed to convert property value of type [grails.spring.BeanBuilder] to
> required type [java.lang.String] for property 'userName'
>
>
> Is there some change to the way Spring works in 0.6, or...?
>
>
> The code is in the plugin doWithSpring closure and looks like this:
>
> /** daoAuthenticationProvider */
> daoAuthenticationProvider(org.acegisecurity.providers.dao.DaoAuthenticationProvider)
> {
>    userDetailsService=ref("userDetailsService")
>    passwordEncoder=ref("passwordEncoder")
>    userCache=ref("userCache")
> }
>
>
> Thanks,
> --
> Hamish
> http://www.dcs.shef.ac.uk/~hamish/
>
> ---------------------------------------------------------------------
> To unsubscribe from this list please visit:
>
>     http://xircles.codehaus.org/manage_email
>
>


--
Graeme Rocher
Grails Project Lead
http://grails.org

---------------------------------------------------------------------
To unsubscribe from this list please visit:

     http://xircles.codehaus.org/manage_email



---------------------------------------------------------------------
To unsubscribe from this list please visit:

    http://xircles.codehaus.org/manage_email

AcegiGrailsPlugin.groovy (12K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Grails 0.6 question: Acegi/Spring initialisation?

pledbrook
In reply to this post by hamishagain@dcs.shef.ac.uk
> /** daoAuthenticationProvider */
> daoAuthenticationProvider(org.acegisecurity.providers.dao.DaoAuthenticationProvider)
> {
>    userDetailsService=ref("userDetailsService")
>    passwordEncoder=ref("passwordEncoder")
>    userCache=ref("userCache")
> }

Can you show us the bean definition for 'userDetailsService'? That's
almost certainly where the problem is, since something is trying to
set the 'userName' property to a BeanBuilder rather than a string.

Cheers,

Peter

---------------------------------------------------------------------
To unsubscribe from this list please visit:

    http://xircles.codehaus.org/manage_email

Reply | Threaded
Open this post in threaded view
|

Re: Grails 0.6 question: Acegi/Spring initialisation?

graemer
In reply to this post by hamishagain@dcs.shef.ac.uk
Hmm what is the exact line that is causing the problem. I think your
error relates to a bean called "userDetailsService" and its "userName"
property

This seams a different part of the code
Cheers

On 8/22/07, Hamish Cunningham <[hidden email]> wrote:

> Hi,
>
> I'm converting an app to 0.6; most things work fine :-)
>
>
> One problem: when trying to initialise Acegi I get the following:
>
> ERROR org.springframework.web.context.ContextLoader Context initialization failed
> org.springframework.beans.factory.BeanCreationException: Error creating bean
> with name 'userDetailsService': Error setting property values; nested
> exception is org.springframework.beans.PropertyBatchUpdateException; nested
> PropertyAccessExceptions (5) are:
> PropertyAccessException 1: org.springframework.beans.TypeMismatchException:
> Failed to convert property value of type [grails.spring.BeanBuilder] to
> required type [java.lang.String] for property 'userName'
>
>
> Is there some change to the way Spring works in 0.6, or...?
>
>
> The code is in the plugin doWithSpring closure and looks like this:
>
> /** daoAuthenticationProvider */
> daoAuthenticationProvider(org.acegisecurity.providers.dao.DaoAuthenticationProvider)
> {
>    userDetailsService=ref("userDetailsService")
>    passwordEncoder=ref("passwordEncoder")
>    userCache=ref("userCache")
> }
>
>
> Thanks,
> --
> Hamish
> http://www.dcs.shef.ac.uk/~hamish/
>
> ---------------------------------------------------------------------
> To unsubscribe from this list please visit:
>
>     http://xircles.codehaus.org/manage_email
>
>


--
Graeme Rocher
Grails Project Lead
http://grails.org

---------------------------------------------------------------------
To unsubscribe from this list please visit:

    http://xircles.codehaus.org/manage_email

Reply | Threaded
Open this post in threaded view
|

Re: Grails 0.6 question: Acegi/Spring initialisation?

data
In reply to this post by hamishagain@dcs.shef.ac.uk
See my other post with the attached file, that should solve your problem.

Andreas

hcunningham wrote
Hi,

I'm converting an app to 0.6; most things work fine :-)


One problem: when trying to initialise Acegi I get the following:

ERROR org.springframework.web.context.ContextLoader Context initialization failed
org.springframework.beans.factory.BeanCreationException: Error creating bean
with name 'userDetailsService': Error setting property values; nested
exception is org.springframework.beans.PropertyBatchUpdateException; nested
PropertyAccessExceptions (5) are:
PropertyAccessException 1: org.springframework.beans.TypeMismatchException:
Failed to convert property value of type [grails.spring.BeanBuilder] to
required type [java.lang.String] for property 'userName'


Is there some change to the way Spring works in 0.6, or...?


The code is in the plugin doWithSpring closure and looks like this:

/** daoAuthenticationProvider */
daoAuthenticationProvider(org.acegisecurity.providers.dao.DaoAuthenticationProvider)
{
   userDetailsService=ref("userDetailsService")
   passwordEncoder=ref("passwordEncoder")
   userCache=ref("userCache")
}


Thanks,
--
Hamish
http://www.dcs.shef.ac.uk/~hamish/

---------------------------------------------------------------------
To unsubscribe from this list please visit:

    http://xircles.codehaus.org/manage_email
Reply | Threaded
Open this post in threaded view
|

Re: Grails 0.6 RC1 available

Randall R Schulz
In reply to this post by graemer
On Wednesday 22 August 2007 04:08, Graeme Rocher wrote:
> Dear Grails users
>
> We have made availabe Grails 0.6 RC1 to download at
> http://grails.org/Download
>
> This is the oppurtunity for the user community to test their apps and
> raise issues which can then be considered for 0.6 final

I asked on the JetBrains Plug-Ins forum when we could expect a new
JetGroovy release that supports Grails 0.6, but no one answered.

Does anybody here know?


> We plan to make 0.6 final available towards the end of next week,
> ...
>
> http://grails.org/0.6+Release+Notes
>
> These are subject to change over the next week.

Will builds subsequent to RC1 (or, I suppose, between RC1 and RC2 or
final) appear as SNAPSHOTs at the usual snapshot URL?


> Thanks for your help on this
>
> Cheers


Randall Schulz

---------------------------------------------------------------------
To unsubscribe from this list please visit:

    http://xircles.codehaus.org/manage_email

123