Grails 2.3.0.RC1 and IntelliJ IDEA: "IDEA hook: Grails not found!"

classic Classic list List threaded Threaded
8 messages Options
Reply | Threaded
Open this post in threaded view
|

Grails 2.3.0.RC1 and IntelliJ IDEA: "IDEA hook: Grails not found!"

Sean Gilligan-2
I just created a new project with Grails 2.3.0.RC1 and create-app.
I'm also using GVM and added ~/.gvm/grails/2.3.0.RC1 as the library setting.

When I open it in IntelliJ IDEA 12 Ultimate (following instructions in
Grails User Guide) I get the following error message:

/Library/Java/JavaVirtualMachines/jdk1.7.0_17.jdk/Contents/Home/bin/java
-Dgrails.home=/Users/sean/.gvm/grails/2.3.0.RC1
-Dbase.dir=/Users/sean/iui/iui-seed-grails
-Dtools.jar=/Library/Java/JavaVirtualMachines/jdk1.7.0_17.jdk/Contents/Home/lib/tools.jar
-Dgroovy.starter.conf=/Users/sean/.gvm/grails/2.3.0.RC1/conf/groovy-starter.conf
-Xmx768M -Xms768M -XX:MaxPermSize=256m -XX:PermSize=256m
"-javaagent:/Applications/IntelliJ IDEA
12.app/plugins/Grails/lib/grails-rt.jar" -Dprint.grails.settings=true
-Dfile.encoding=UTF-8 -classpath
/Users/sean/.gvm/grails/2.3.0.RC1/lib/org.codehaus.groovy/groovy-all/jars/groovy-all-2.1.6.jar:/Users/sean/.gvm/grails/2.3.0.RC1/dist/grails-bootstrap-2.3.0.RC1-javadoc.jar
org.codehaus.groovy.grails.cli.support.GrailsStarter --main
org.codehaus.groovy.grails.cli.GrailsScriptRunner --conf
/Users/sean/.gvm/grails/2.3.0.RC1/conf/groovy-starter.conf helpError:
Could not find or load main class
org.codehaus.groovy.grails.cli.support.GrailsStarter
java.lang.NullPointerException
     at org.jetbrains.groovy.grails.rt.Agent$2.run(Agent.java:135)

     at java.lang.Thread.run(Thread.java:722)
IDEA hook: Grails not found!



Any ideas?  (Maybe I should pursue a JetBrains channel for this
question, but since I'm using released IDEA and pre-release Grails, I
thought I'd ask here first.)


Thanks,

Sean


---------------------------------------------------------------------
To unsubscribe from this list, please visit:

    http://xircles.codehaus.org/manage_email


Reply | Threaded
Open this post in threaded view
|

Re: Grails 2.3.0.RC1 and IntelliJ IDEA: "IDEA hook: Grails not found!"

Roberto Guerra
I get the same error.


On Mon, Aug 5, 2013 at 3:03 PM, Sean Gilligan <[hidden email]> wrote:
I just created a new project with Grails 2.3.0.RC1 and create-app.
I'm also using GVM and added ~/.gvm/grails/2.3.0.RC1 as the library setting.

When I open it in IntelliJ IDEA 12 Ultimate (following instructions in Grails User Guide) I get the following error message:

/Library/Java/JavaVirtualMachines/jdk1.7.0_17.jdk/Contents/Home/bin/java -Dgrails.home=/Users/sean/.gvm/grails/2.3.0.RC1 -Dbase.dir=/Users/sean/iui/iui-seed-grails -Dtools.jar=/Library/Java/JavaVirtualMachines/jdk1.7.0_17.jdk/Contents/Home/lib/tools.jar -Dgroovy.starter.conf=/Users/sean/.gvm/grails/2.3.0.RC1/conf/groovy-starter.conf -Xmx768M -Xms768M -XX:MaxPermSize=256m -XX:PermSize=256m "-javaagent:/Applications/IntelliJ IDEA 12.app/plugins/Grails/lib/grails-rt.jar" -Dprint.grails.settings=true -Dfile.encoding=UTF-8 -classpath /Users/sean/.gvm/grails/2.3.0.RC1/lib/org.codehaus.groovy/groovy-all/jars/groovy-all-2.1.6.jar:/Users/sean/.gvm/grails/2.3.0.RC1/dist/grails-bootstrap-2.3.0.RC1-javadoc.jar org.codehaus.groovy.grails.cli.support.GrailsStarter --main org.codehaus.groovy.grails.cli.GrailsScriptRunner --conf /Users/sean/.gvm/grails/2.3.0.RC1/conf/groovy-starter.conf helpError: Could not find or load main class org.codehaus.groovy.grails.cli.support.GrailsStarter
java.lang.NullPointerException
    at org.jetbrains.groovy.grails.rt.Agent$2.run(Agent.java:135)

    at java.lang.Thread.run(Thread.java:722)
IDEA hook: Grails not found!



Any ideas?  (Maybe I should pursue a JetBrains channel for this question, but since I'm using released IDEA and pre-release Grails, I thought I'd ask here first.)


Thanks,

Sean


---------------------------------------------------------------------
To unsubscribe from this list, please visit:

   http://xircles.codehaus.org/manage_email





--
Color me impractical but I’d rather be able to look at myself in the mirror than be rich.
-Evan Light
Reply | Threaded
Open this post in threaded view
|

Re: Grails 2.3.0.RC1 and IntelliJ IDEA: "IDEA hook: Grails not found!"

graham
In reply to this post by Sean Gilligan-2
The problem arises with all 2.3 versions I believe (I've tried M2 and RC1).

I find that the method given in http://stackoverflow.com/questions/16919676/grails-2-3-0-m1-fails-to-start-in-intellij-idea-130-754 does work, i.e.

'As workaround you can remove all "grails-*-2.3.0.M1-sources.jar" and "grails-*-2.3.0.M1-javadocs.jar" from $GRAILS_HOME/dist'

(actually it should say 'javadoc.jar')

I did ask in the IDEA forum and was told it is fixed in the v 13 EAP but I haven't actually tried that (http://devnet.jetbrains.com/thread/447179?tstart=0)

graham
Reply | Threaded
Open this post in threaded view
|

RE: Grails 2.3.0.RC1 and IntelliJ IDEA: "IDEA hook: Grails not found!"

Bob Brown
In reply to this post by Roberto Guerra
Just to chip in FYI, IntelliJ 130.1365 seems fine.

So there is a potential way forward, if you are able to take it.

BOB

> -----Original Message-----
> From: Roberto Guerra [mailto:[hidden email]]
> Sent: Tuesday, 6 August 2013 7:57 AM
> To: [hidden email]
> Subject: Re: [grails-user] Grails 2.3.0.RC1 and IntelliJ IDEA: "IDEA hook:
Grails

> not found!"
>
> I get the same error.
>
>
> On Mon, Aug 5, 2013 at 3:03 PM, Sean Gilligan <[hidden email]>
> wrote:
>
>
> I just created a new project with Grails 2.3.0.RC1 and create-app.
> I'm also using GVM and added ~/.gvm/grails/2.3.0.RC1 as the library
> setting.
>
> When I open it in IntelliJ IDEA 12 Ultimate (following instructions
in

> Grails User Guide) I get the following error message:
>
> /Library/Java/JavaVirtualMachines/jdk1.7.0_17.jdk/Contents/Home/
> bin/java -Dgrails.home=/Users/sean/.gvm/grails/2.3.0.RC1 -
> Dbase.dir=/Users/sean/iui/iui-seed-grails -
> Dtools.jar=/Library/Java/JavaVirtualMachines/jdk1.7.0_17.jdk/Contents/Ho
> me/lib/tools.jar -
> Dgroovy.starter.conf=/Users/sean/.gvm/grails/2.3.0.RC1/conf/groovy-
> starter.conf -Xmx768M -Xms768M -XX:MaxPermSize=256m -
> XX:PermSize=256m "-javaagent:/Applications/IntelliJ IDEA
> 12.app/plugins/Grails/lib/grails-rt.jar" -Dprint.grails.settings=true -
> Dfile.encoding=UTF-8 -classpath
> /Users/sean/.gvm/grails/2.3.0.RC1/lib/org.codehaus.groovy/groovy-
>
all/jars/groovy-all-2.1.6.jar:/Users/sean/.gvm/grails/2.3.0.RC1/dist/grails-
> bootstrap-2.3.0.RC1-javadoc.jar
> org.codehaus.groovy.grails.cli.support.GrailsStarter --main
> org.codehaus.groovy.grails.cli.GrailsScriptRunner --conf
> /Users/sean/.gvm/grails/2.3.0.RC1/conf/groovy-starter.conf helpError:
Could

> not find or load main class
> org.codehaus.groovy.grails.cli.support.GrailsStarter
> java.lang.NullPointerException
>    at org.jetbrains.groovy.grails.rt.Agent$2.run(Agent.java:135)
>
>    at java.lang.Thread.run(Thread.java:722)
> IDEA hook: Grails not found!
>
>
>
> Any ideas?  (Maybe I should pursue a JetBrains channel for this
> question, but since I'm using released IDEA and pre-release Grails, I
thought
> I'd ask here first.)
>
>
> Thanks,
>
> Sean
>
>
>
---------------------------------------------------------------------

> To unsubscribe from this list, please visit:
>
>   http://xircles.codehaus.org/manage_email
> <http://xircles.codehaus.org/manage_email>
>
>
>
>
>
>
>
> --
>
> Color me impractical but I'd rather be able to look at myself in the
mirror than
> be rich.
> -Evan Light



---------------------------------------------------------------------
To unsubscribe from this list, please visit:

    http://xircles.codehaus.org/manage_email


Reply | Threaded
Open this post in threaded view
|

Re: Grails 2.3.0.RC1 and IntelliJ IDEA: "IDEA hook: Grails not found!"

Sean Gilligan-4
In reply to this post by graham
Thanks, Graham.  That did the trick!

A few notes about the details:

I am using GVM on Mac OS X and I didn't want to remove sources and
javadoc from the GVM-managed/installed Grails 2.3.0.RC1 directory, so I
did the following:

$ cd ~/.gvm/grails/
$ cp -pR 2.3.0.RC1 2.3.0.RC1-IntelliJ
$ cd 2.3.0.RC1-IntelliJ/
$ rm dist/grails-*-javadoc.jar
$ rm dist/grails-*-sources.jar

I then used the IDEA "Add Framework Support" option as described here:
http://stackoverflow.com/questions/14757758/intellij-12-grails-2-1-configuration-grails-sdk-not-configured

I then went to Module Settings/Dependencies and removed the (unmodified)
"2.3.0.RC1" SDK.

The error message is gone and I can run Grails from within IDEA.

(I hope GVM doesn't have a problem with me adding another directory in
~/.gvm/grails)


---------------------------------------------------------------------
To unsubscribe from this list, please visit:

    http://xircles.codehaus.org/manage_email


Reply | Threaded
Open this post in threaded view
|

Re: Grails 2.3.0.RC1 and IntelliJ IDEA: "IDEA hook: Grails not found!"

Sean Gilligan-4
In reply to this post by Bob Brown
On 8/5/13 3:23 PM, Bob Brown wrote:
> Just to chip in FYI, IntelliJ 130.1365 seems fine.
>
> So there is a potential way forward, if you are able to take it.
>
> BOB


Thanks, Bob.  That's good to know.

As I've just started using IntelliJ and the warnings about the
"pre-betaness" of EAP are pretty severe, I'm going to play it safe and
stick with the latest release of 12.

-- Sean



---------------------------------------------------------------------
To unsubscribe from this list, please visit:

    http://xircles.codehaus.org/manage_email


Reply | Threaded
Open this post in threaded view
|

RE: Grails 2.3.0.RC1 and IntelliJ IDEA: "IDEA hook: Grails not found!"

Bob Brown
I wouldn't worry too much about those warnings. I've always used the EAP
versions.

BOB

> -----Original Message-----
> From: Sean Gilligan [mailto:[hidden email]] On Behalf Of Sean
Gilligan
> Sent: Tuesday, 6 August 2013 10:19 AM
> To: [hidden email]
> Subject: Re: [grails-user] Grails 2.3.0.RC1 and IntelliJ IDEA: "IDEA hook:
Grails

> not found!"
>
> On 8/5/13 3:23 PM, Bob Brown wrote:
> > Just to chip in FYI, IntelliJ 130.1365 seems fine.
> >
> > So there is a potential way forward, if you are able to take it.
> >
> > BOB
>
>
> Thanks, Bob.  That's good to know.
>
> As I've just started using IntelliJ and the warnings about the
"pre-betaness"
> of EAP are pretty severe, I'm going to play it safe and stick with the
latest

> release of 12.
>
> -- Sean
>
>
>
> ---------------------------------------------------------------------
> To unsubscribe from this list, please visit:
>
>     http://xircles.codehaus.org/manage_email
>



---------------------------------------------------------------------
To unsubscribe from this list, please visit:

    http://xircles.codehaus.org/manage_email


Reply | Threaded
Open this post in threaded view
|

Re: Grails 2.3.0.RC1 and IntelliJ IDEA: "IDEA hook: Grails not found!"

markatharvest
In reply to this post by graham
CONTENTS DELETED
The author has deleted this message.