Quantcast

Grails 2.3.11 and Java 8

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
7 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Grails 2.3.11 and Java 8

Radu-Stefan Zugravu
Hi! Because of Oracle ending support for Java 7 I decided that is time for me to upgrade to Java 8. But I am still on Grails 2.3.11. I was wondering, did someone tried Grails 2.3.x with Java 8 or is it only working starting from 2.4.x versions? Thanks!

--
You received this message because you are subscribed to the Google Groups "Grails Dev Discuss" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/grails-dev-discuss/c0d75066-6645-42f9-aadc-fad87d853eb9%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Grails 2.3.11 and Java 8

Grails Dev Discuss mailing list
> I was wondering, did someone tried Grails 2.3.x with Java 8
We tried with several apps, but there are allot of errors, and many plug-ins don't work either.

> or is it only working starting from 2.4.x versions? Thanks!
Really well works only with 2.5.x.

regards,

Adrian A.

--
You received this message because you are subscribed to the Google Groups "Grails Dev Discuss" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/grails-dev-discuss/b7cabc74-cd94-4cee-a1f2-dc45d3967098%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Grails 2.3.11 and Java 8

Radu-Stefan Zugravu
In reply to this post by Radu-Stefan Zugravu
Thanks for your answer. Did you also tried to change the BuildConfig to the following:
grails.project.target.level = 1.7
grails.project.source.level = 1.7

luni, 29 februarie 2016, 11:58:04 UTC+2, Radu-Stefan Zugravu a scris:
Hi! Because of Oracle ending support for Java 7 I decided that is time for me to upgrade to Java 8. But I am still on Grails 2.3.11. I was wondering, did someone tried Grails 2.3.x with Java 8 or is it only working starting from 2.4.x versions? Thanks!

--
You received this message because you are subscribed to the Google Groups "Grails Dev Discuss" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/grails-dev-discuss/01380dea-eb7c-4ebe-9e03-3a17f1929ff0%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Grails 2.3.11 and Java 8

Radu-Stefan Zugravu
In reply to this post by Radu-Stefan Zugravu
Can you also give me some examples of plugins not working after you switched to Java 8?

luni, 29 februarie 2016, 11:58:04 UTC+2, Radu-Stefan Zugravu a scris:
Hi! Because of Oracle ending support for Java 7 I decided that is time for me to upgrade to Java 8. But I am still on Grails 2.3.11. I was wondering, did someone tried Grails 2.3.x with Java 8 or is it only working starting from 2.4.x versions? Thanks!

--
You received this message because you are subscribed to the Google Groups "Grails Dev Discuss" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/grails-dev-discuss/aac517eb-84d0-486e-a38b-d1c0257f2e85%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Grails 2.3.11 and Java 8

Grails Dev Discuss mailing list
In reply to this post by Radu-Stefan Zugravu
> Did you also tried to change the BuildConfig to the following:
> grails.project.target.level = 1.7
> grails.project.source.level = 1.7
We were using with 2.3.11 the above settings already.
However the main problem is not that much in the Language level, but the changes Oracle did to the compiler between minor releases, thus breaking some groovy stuff.

--
You received this message because you are subscribed to the Google Groups "Grails Dev Discuss" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/grails-dev-discuss/704f189f-5665-495f-a133-904f5f0cdfd8%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Grails 2.3.11 and Java 8

Grails Dev Discuss mailing list
In reply to this post by Radu-Stefan Zugravu
> Can you also give me some examples of plugins not working after you switched to Java 8?
We updated to 2.5.x and also the the latest versions of all plug-ins, and most stuff was working again with Java 8.

Plug-ins that had problems despite the 2.5.x update with Java 8:
 - Resources plug-in, so we switched to AssetPipeline  - this was the biggest code change
 - Searchable: this plug-in breaks the schema-export tasks, so we need to deactivate it when we generate DDLs. There's also no update, since it's discontinued .
 - GORM - Many2Many relationships with Oracle when doing updates (hibernate 3) : the generated/scaffold code works with H2, but not with Oracle, so manual handling is required.


We also tried to jump directly to the 3.x path, but since it's backward incompatible, it requires practically a complete rewrite of applications (the customers won't ever pay for this), and the most important feature of Grails for us: dynamic scaffolding is not working correctly :(.

Regards,

Adrian A.

--
You received this message because you are subscribed to the Google Groups "Grails Dev Discuss" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/grails-dev-discuss/620c33d6-aeb7-4b9a-8605-afbe0178dfcf%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Grails 2.3.11 and Java 8

Radu-Stefan Zugravu
We will try to make the switch to 2.5.x. I guess our biggest change will also be the Resources plugin. Thank you very much for all the information.

luni, 29 februarie 2016, 15:09:21 UTC+2, Adrian A. a scris:
> Can you also give me some examples of plugins not working after you switched to Java 8?
We updated to 2.5.x and also the the latest versions of all plug-ins, and most stuff was working again with Java 8.

Plug-ins that had problems despite the 2.5.x update with Java 8:
 - Resources plug-in, so we switched to AssetPipeline  - this was the biggest code change
 - Searchable: this plug-in breaks the schema-export tasks, so we need to deactivate it when we generate DDLs. There's also no update, since it's discontinued .
 - GORM - Many2Many relationships with Oracle when doing updates (hibernate 3) : the generated/scaffold code works with H2, but not with Oracle, so manual handling is required.


We also tried to jump directly to the 3.x path, but since it's backward incompatible, it requires practically a complete rewrite of applications (the customers won't ever pay for this), and the most important feature of Grails for us: dynamic scaffolding is not working correctly :(.

Regards,

Adrian A.

--
You received this message because you are subscribed to the Google Groups "Grails Dev Discuss" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/grails-dev-discuss/d6bcf269-8b6d-4df9-8a5b-e000dd68356a%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.
Loading...