Grails 3 upgrade path: plugins you want migrated

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
101 messages Options
1234 ... 6
Reply | Threaded
Open this post in threaded view
|

Grails 3 upgrade path: plugins you want migrated

Graeme Rocher-2
Hi all,

We have taken note that a significant number of users will not or cannot upgrade to Grails 3.0 until some key plugins are upgraded.

With that in mind I would like feedback from the community about which plugins you would like to see migrated to Grails 3.0 so we can begin prioritising work in this area.

So please let us know which plugins are important and whose absence are preventing you from exploring upgrading to Grails 3.0

Thanks for your attention.

Cheers

Graeme Rocher
Grails Project lead
OCI - http://ociweb.com

--
You received this message because you are subscribed to the Google Groups "Grails Dev Discuss" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/grails-dev-discuss/1434459312279.2bb0f55a%40Nodemailer.
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

Re: Grails 3 upgrade path: plugins you want migrated

Ken Siprell
My suggestions:

spring-security-core

twitter-bootstrap

joda-time

remote-control

Thanks,
Ken

On Tuesday, June 16, 2015 at 2:55:15 PM UTC+2, Graeme Rocher wrote:
Hi all,

We have taken note that a significant number of users will not or cannot upgrade to Grails 3.0 until some key plugins are upgraded.

With that in mind I would like feedback from the community about which plugins you would like to see migrated to Grails 3.0 so we can begin prioritising work in this area.

So please let us know which plugins are important and whose absence are preventing you from exploring upgrading to Grails 3.0

Thanks for your attention.

Cheers

Graeme Rocher
Grails Project lead
OCI - <a href="http://ociweb.com" target="_blank" rel="nofollow" onmousedown="this.href='http://www.google.com/url?q\75http%3A%2F%2Fociweb.com\46sa\75D\46sntz\0751\46usg\75AFQjCNGzeZwvqKHLWu--y_uuay6-1VkagA';return true;" onclick="this.href='http://www.google.com/url?q\75http%3A%2F%2Fociweb.com\46sa\75D\46sntz\0751\46usg\75AFQjCNGzeZwvqKHLWu--y_uuay6-1VkagA';return true;">http://ociweb.com

--
You received this message because you are subscribed to the Google Groups "Grails Dev Discuss" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/grails-dev-discuss/8fde325d-3692-42b0-ac75-85495d1de43c%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

Re: Grails 3 upgrade path: plugins you want migrated

Thierry Nicola
In reply to this post by Graeme Rocher-2
I would love to see:

+ spring-security-core

+ DB-Migration

Those two are quite essential for our teams

On Tuesday, June 16, 2015 at 2:55:15 PM UTC+2, Graeme Rocher wrote:
Hi all,

We have taken note that a significant number of users will not or cannot upgrade to Grails 3.0 until some key plugins are upgraded.

With that in mind I would like feedback from the community about which plugins you would like to see migrated to Grails 3.0 so we can begin prioritising work in this area.

So please let us know which plugins are important and whose absence are preventing you from exploring upgrading to Grails 3.0

Thanks for your attention.

Cheers

Graeme Rocher
Grails Project lead
OCI - <a href="http://ociweb.com" target="_blank" rel="nofollow" onmousedown="this.href='http://www.google.com/url?q\75http%3A%2F%2Fociweb.com\46sa\75D\46sntz\0751\46usg\75AFQjCNGzeZwvqKHLWu--y_uuay6-1VkagA';return true;" onclick="this.href='http://www.google.com/url?q\75http%3A%2F%2Fociweb.com\46sa\75D\46sntz\0751\46usg\75AFQjCNGzeZwvqKHLWu--y_uuay6-1VkagA';return true;">http://ociweb.com

--
You received this message because you are subscribed to the Google Groups "Grails Dev Discuss" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/grails-dev-discuss/70e42e09-f9f1-4ac9-8d59-2fc2c8f862cd%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

Re: Grails 3 upgrade path: plugins you want migrated

Graeme Rocher-2
Have you tested: https://bintray.com/yamkazu/plugins/org.grails.plugins%3Adatabase-migration/view

It is a Grails 3.0 version of the database migration plugin

Graeme Rocher
Grails Project lead
OCI - http://ociweb.com


On Tue, Jun 16, 2015 at 3:47 PM, Thierry Nicola <[hidden email]> wrote:

I would love to see:

+ spring-security-core

+ DB-Migration

Those two are quite essential for our teams

On Tuesday, June 16, 2015 at 2:55:15 PM UTC+2, Graeme Rocher wrote:
Hi all,

We have taken note that a significant number of users will not or cannot upgrade to Grails 3.0 until some key plugins are upgraded.

With that in mind I would like feedback from the community about which plugins you would like to see migrated to Grails 3.0 so we can begin prioritising work in this area.

So please let us know which plugins are important and whose absence are preventing you from exploring upgrading to Grails 3.0

Thanks for your attention.

Cheers

Graeme Rocher
Grails Project lead

--
You received this message because you are subscribed to the Google Groups "Grails Dev Discuss" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/grails-dev-discuss/70e42e09-f9f1-4ac9-8d59-2fc2c8f862cd%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "Grails Dev Discuss" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/grails-dev-discuss/1434462793421.61976ef3%40Nodemailer.
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

Re: Grails 3 upgrade path: plugins you want migrated

Thierry Nicola
No, not yet. Will try it out and provide  feedback.

On Tuesday, June 16, 2015 at 3:53:16 PM UTC+2, Graeme Rocher wrote:
Have you tested: <a href="https://bintray.com/yamkazu/plugins/org.grails.plugins%3Adatabase-migration/view" target="_blank" rel="nofollow" onmousedown="this.href='https://www.google.com/url?q\75https%3A%2F%2Fbintray.com%2Fyamkazu%2Fplugins%2Forg.grails.plugins%253Adatabase-migration%2Fview\46sa\75D\46sntz\0751\46usg\75AFQjCNHEkXXRXFGsaeVmmWHS5rEFfURAUw';return true;" onclick="this.href='https://www.google.com/url?q\75https%3A%2F%2Fbintray.com%2Fyamkazu%2Fplugins%2Forg.grails.plugins%253Adatabase-migration%2Fview\46sa\75D\46sntz\0751\46usg\75AFQjCNHEkXXRXFGsaeVmmWHS5rEFfURAUw';return true;">https://bintray.com/yamkazu/plugins/org.grails.plugins%3Adatabase-migration/view

It is a Grails 3.0 version of the database migration plugin

Graeme Rocher
Grails Project lead
OCI - <a href="http://ociweb.com" target="_blank" rel="nofollow" onmousedown="this.href='http://www.google.com/url?q\75http%3A%2F%2Fociweb.com\46sa\75D\46sntz\0751\46usg\75AFQjCNGzeZwvqKHLWu--y_uuay6-1VkagA';return true;" onclick="this.href='http://www.google.com/url?q\75http%3A%2F%2Fociweb.com\46sa\75D\46sntz\0751\46usg\75AFQjCNGzeZwvqKHLWu--y_uuay6-1VkagA';return true;">http://ociweb.com


On Tue, Jun 16, 2015 at 3:47 PM, Thierry Nicola <<a href="javascript:" target="_blank" gdf-obfuscated-mailto="MhfBrhrJUMYJ" rel="nofollow" onmousedown="this.href='javascript:';return true;" onclick="this.href='javascript:';return true;">thierry...@...> wrote:

I would love to see:

+ spring-security-core

+ DB-Migration

Those two are quite essential for our teams

On Tuesday, June 16, 2015 at 2:55:15 PM UTC+2, Graeme Rocher wrote:
Hi all,

We have taken note that a significant number of users will not or cannot upgrade to Grails 3.0 until some key plugins are upgraded.

With that in mind I would like feedback from the community about which plugins you would like to see migrated to Grails 3.0 so we can begin prioritising work in this area.

So please let us know which plugins are important and whose absence are preventing you from exploring upgrading to Grails 3.0

Thanks for your attention.

Cheers

Graeme Rocher
Grails Project lead
OCI - <a href="http://ociweb.com" rel="nofollow" target="_blank" onmousedown="this.href='http://www.google.com/url?q\75http%3A%2F%2Fociweb.com\46sa\75D\46sntz\0751\46usg\75AFQjCNGzeZwvqKHLWu--y_uuay6-1VkagA';return true;" onclick="this.href='http://www.google.com/url?q\75http%3A%2F%2Fociweb.com\46sa\75D\46sntz\0751\46usg\75AFQjCNGzeZwvqKHLWu--y_uuay6-1VkagA';return true;">http://ociweb.com

--
You received this message because you are subscribed to the Google Groups "Grails Dev Discuss" group.
To unsubscribe from this group and stop receiving emails from it, send an email to <a href="javascript:" target="_blank" gdf-obfuscated-mailto="MhfBrhrJUMYJ" rel="nofollow" onmousedown="this.href='javascript:';return true;" onclick="this.href='javascript:';return true;">grails-dev-discuss+unsubscribe@....
To post to this group, send email to <a href="javascript:" target="_blank" gdf-obfuscated-mailto="MhfBrhrJUMYJ" rel="nofollow" onmousedown="this.href='javascript:';return true;" onclick="this.href='javascript:';return true;">grails-de...@googlegroups.com.
To view this discussion on the web visit <a href="https://groups.google.com/d/msgid/grails-dev-discuss/70e42e09-f9f1-4ac9-8d59-2fc2c8f862cd%40googlegroups.com?utm_medium=email&amp;utm_source=footer" target="_blank" rel="nofollow" onmousedown="this.href='https://groups.google.com/d/msgid/grails-dev-discuss/70e42e09-f9f1-4ac9-8d59-2fc2c8f862cd%40googlegroups.com?utm_medium\75email\46utm_source\75footer';return true;" onclick="this.href='https://groups.google.com/d/msgid/grails-dev-discuss/70e42e09-f9f1-4ac9-8d59-2fc2c8f862cd%40googlegroups.com?utm_medium\75email\46utm_source\75footer';return true;">https://groups.google.com/d/msgid/grails-dev-discuss/70e42e09-f9f1-4ac9-8d59-2fc2c8f862cd%40googlegroups.com.
For more options, visit <a href="https://groups.google.com/d/optout" target="_blank" rel="nofollow" onmousedown="this.href='https://groups.google.com/d/optout';return true;" onclick="this.href='https://groups.google.com/d/optout';return true;">https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "Grails Dev Discuss" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/grails-dev-discuss/de1c4faa-1fce-4206-a48d-e2e52417165f%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

Re: Grails 3 upgrade path: plugins you want migrated

Dominic Fui Dodzi-Nusenu
In reply to this post by Graeme Rocher-2
Hi all,

+ wkhtmltopdf
+ cookie-session
+ mandrill
+html-cleaner
+ spring-security-ui (and all spring security core sub plugins)
+ jaxrs
+ cache-ehcache
+ webxml

I know there are some old ones but they still are still used on my production system
On 06/16/2015 12:55 PM, Graeme Rocher wrote:
Hi all,

We have taken note that a significant number of users will not or cannot upgrade to Grails 3.0 until some key plugins are upgraded.

With that in mind I would like feedback from the community about which plugins you would like to see migrated to Grails 3.0 so we can begin prioritising work in this area.

So please let us know which plugins are important and whose absence are preventing you from exploring upgrading to Grails 3.0

Thanks for your attention.

Cheers

Graeme Rocher
Grails Project lead
--
You received this message because you are subscribed to the Google Groups "Grails Dev Discuss" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/grails-dev-discuss/1434459312279.2bb0f55a%40Nodemailer.
For more options, visit https://groups.google.com/d/optout.

-- 
Fui Nusenu
twitter: @daptordarattler

--
You received this message because you are subscribed to the Google Groups "Grails Dev Discuss" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/grails-dev-discuss/5580309B.6080201%40gmail.com.
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

Re: Grails 3 upgrade path: plugins you want migrated

Jeff Brown

> On Jun 16, 2015, at 9:20 AM, Dominic Fui Dodzi-Nusenu <[hidden email]> wrote:
>
> Hi all,
>
> + wkhtmltopdf
> + cookie-session
> + mandrill
> +html-cleaner
> + spring-security-ui (and all spring security core sub plugins)
> + jaxrs
> + cache-ehcache
> + webxml
>
> I know there are some old ones but they still are still used on my production system

Is webxml keeping you from upgrading to Grails 3?



JSB

Jeff Scott Brown
Principal Software Engineer
Grails Development Team
Object Computing Inc.
http://www.ociweb.com/

Autism Strikes 1 in 166
Find The Cause ~ Find The Cure
http://www.autismspeaks.org/

--
You received this message because you are subscribed to the Google Groups "Grails Dev Discuss" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/grails-dev-discuss/22A3A77D-A8B2-4C0A-8742-A465B43A36E9%40ociweb.com.
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

Re: Grails 3 upgrade path: plugins you want migrated

Dominic Fui Dodzi-Nusenu
Not really, its in my list, so I wanted to add it anyway.. But
obviously, there are workarounds I could use. This was just a copy paste
list :-)

On 06/16/2015 02:40 PM, Jeff Scott Brown wrote:

>> On Jun 16, 2015, at 9:20 AM, Dominic Fui Dodzi-Nusenu <[hidden email]> wrote:
>>
>> Hi all,
>>
>> + wkhtmltopdf
>> + cookie-session
>> + mandrill
>> +html-cleaner
>> + spring-security-ui (and all spring security core sub plugins)
>> + jaxrs
>> + cache-ehcache
>> + webxml
>>
>> I know there are some old ones but they still are still used on my production system
> Is webxml keeping you from upgrading to Grails 3?
>
>
>
> JSB
> —
> Jeff Scott Brown
> Principal Software Engineer
> Grails Development Team
> Object Computing Inc.
> http://www.ociweb.com/
>
> Autism Strikes 1 in 166
> Find The Cause ~ Find The Cure
> http://www.autismspeaks.org/
>

--
Fui Nusenu
twitter: @daptordarattler

--
You received this message because you are subscribed to the Google Groups "Grails Dev Discuss" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/grails-dev-discuss/558035CD.1030503%40gmail.com.
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

Re: Grails 3 upgrade path: plugins you want migrated

Rubén Mondéjar
In reply to this post by Graeme Rocher-2
Good idea!

In our case, we try to use the minimum number of plugins but these are essential for us : 

spring-security-cas (critical)
spring-security-ldap (critical)
grails-melody (not critical)
cache (done)
quartz (done)

I'm sure that Burt is working hard to finish the spring security plugin 2.0, but as I told him is critical to jump to grails 3 in our organization

PS: I want to say that the bintray site is great but the plugin presentations lack a lot of the previous site information that is useful and give some confidence when we are looking for a new plugin

Thanks in advance,

El martes, 16 de junio de 2015, 14:55:15 (UTC+2), Graeme Rocher escribió:
Hi all,

We have taken note that a significant number of users will not or cannot upgrade to Grails 3.0 until some key plugins are upgraded.

With that in mind I would like feedback from the community about which plugins you would like to see migrated to Grails 3.0 so we can begin prioritising work in this area.

So please let us know which plugins are important and whose absence are preventing you from exploring upgrading to Grails 3.0

Thanks for your attention.

Cheers

Graeme Rocher
Grails Project lead
OCI - <a href="http://ociweb.com" target="_blank" rel="nofollow" onmousedown="this.href='http://www.google.com/url?q\75http%3A%2F%2Fociweb.com\46sa\75D\46sntz\0751\46usg\75AFQjCNGzeZwvqKHLWu--y_uuay6-1VkagA';return true;" onclick="this.href='http://www.google.com/url?q\75http%3A%2F%2Fociweb.com\46sa\75D\46sntz\0751\46usg\75AFQjCNGzeZwvqKHLWu--y_uuay6-1VkagA';return true;">http://ociweb.com

--
You received this message because you are subscribed to the Google Groups "Grails Dev Discuss" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/grails-dev-discuss/2087032f-03f5-4af3-b43e-e6a7d6c7f4bd%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

Re: Grails 3 upgrade path: plugins you want migrated

Dominic Fui Dodzi-Nusenu
Yeah, I agree, but I think the real problem is that the ReadMe for a lot of the projects is lacking real content and walk through of how the plugins work. Which is mainly a problem with those that ported it, i guess.

On 06/16/2015 02:46 PM, Rubén Mondéjar wrote:
Good idea!

In our case, we try to use the minimum number of plugins but these are essential for us : 

spring-security-cas (critical)
spring-security-ldap (critical)
grails-melody (not critical)
cache (done)
quartz (done)

I'm sure that Burt is working hard to finish the spring security plugin 2.0, but as I told him is critical to jump to grails 3 in our organization

PS: I want to say that the bintray site is great but the plugin presentations lack a lot of the previous site information that is useful and give some confidence when we are looking for a new plugin

Thanks in advance,

El martes, 16 de junio de 2015, 14:55:15 (UTC+2), Graeme Rocher escribió:
Hi all,

We have taken note that a significant number of users will not or cannot upgrade to Grails 3.0 until some key plugins are upgraded.

With that in mind I would like feedback from the community about which plugins you would like to see migrated to Grails 3.0 so we can begin prioritising work in this area.

So please let us know which plugins are important and whose absence are preventing you from exploring upgrading to Grails 3.0

Thanks for your attention.

Cheers

Graeme Rocher
Grails Project lead
OCI - <a moz-do-not-send="true" href="http://ociweb.com" target="_blank" rel="nofollow" onmousedown="this.href='http://www.google.com/url?q\75http%3A%2F%2Fociweb.com\46sa\75D\46sntz\0751\46usg\75AFQjCNGzeZwvqKHLWu--y_uuay6-1VkagA';return true;" onclick="this.href='http://www.google.com/url?q\75http%3A%2F%2Fociweb.com\46sa\75D\46sntz\0751\46usg\75AFQjCNGzeZwvqKHLWu--y_uuay6-1VkagA';return true;">http://ociweb.com
--
You received this message because you are subscribed to the Google Groups "Grails Dev Discuss" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/grails-dev-discuss/2087032f-03f5-4af3-b43e-e6a7d6c7f4bd%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

-- 
Fui Nusenu
twitter: @daptordarattler

--
You received this message because you are subscribed to the Google Groups "Grails Dev Discuss" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/grails-dev-discuss/558038AA.4000703%40gmail.com.
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

Re: Grails 3 upgrade path: plugins you want migrated

Anthony Foulfoin
In reply to this post by Graeme Rocher-2
Hi,

- cookie-session
- json-apis


Le mardi 16 juin 2015 14:55:15 UTC+2, Graeme Rocher a écrit :
Hi all,

We have taken note that a significant number of users will not or cannot upgrade to Grails 3.0 until some key plugins are upgraded.

With that in mind I would like feedback from the community about which plugins you would like to see migrated to Grails 3.0 so we can begin prioritising work in this area.

So please let us know which plugins are important and whose absence are preventing you from exploring upgrading to Grails 3.0

Thanks for your attention.

Cheers

Graeme Rocher
Grails Project lead
OCI - <a href="http://ociweb.com" target="_blank" rel="nofollow" onmousedown="this.href='http://www.google.com/url?q\75http%3A%2F%2Fociweb.com\46sa\75D\46sntz\0751\46usg\75AFQjCNGzeZwvqKHLWu--y_uuay6-1VkagA';return true;" onclick="this.href='http://www.google.com/url?q\75http%3A%2F%2Fociweb.com\46sa\75D\46sntz\0751\46usg\75AFQjCNGzeZwvqKHLWu--y_uuay6-1VkagA';return true;">http://ociweb.com

--
You received this message because you are subscribed to the Google Groups "Grails Dev Discuss" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/grails-dev-discuss/16885cf4-ba6b-4270-b339-8f339a9fab3e%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

Re: Grails 3 upgrade path: plugins you want migrated

Andrés Garcia
In reply to this post by Graeme Rocher-2
These are what are stopping me from upgrading to 3.x:


database-migration
build-test-data


On Tuesday, June 16, 2015 at 7:55:15 AM UTC-5, Graeme Rocher wrote:
Hi all,

We have taken note that a significant number of users will not or cannot upgrade to Grails 3.0 until some key plugins are upgraded.

With that in mind I would like feedback from the community about which plugins you would like to see migrated to Grails 3.0 so we can begin prioritising work in this area.

So please let us know which plugins are important and whose absence are preventing you from exploring upgrading to Grails 3.0

Thanks for your attention.

Cheers

Graeme Rocher
Grails Project lead
OCI - <a href="http://ociweb.com" target="_blank" rel="nofollow" onmousedown="this.href='http://www.google.com/url?q\75http%3A%2F%2Fociweb.com\46sa\75D\46sntz\0751\46usg\75AFQjCNGzeZwvqKHLWu--y_uuay6-1VkagA';return true;" onclick="this.href='http://www.google.com/url?q\75http%3A%2F%2Fociweb.com\46sa\75D\46sntz\0751\46usg\75AFQjCNGzeZwvqKHLWu--y_uuay6-1VkagA';return true;">http://ociweb.com

--
You received this message because you are subscribed to the Google Groups "Grails Dev Discuss" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/grails-dev-discuss/d21829d5-5d13-4472-854f-9e4bb79e5276%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

Re: Grails 3 upgrade path: plugins you want migrated

dmurat
In reply to this post by Graeme Rocher-2
constraints
envers
miniprofiler
build-test-data
fixtures
jawr

--
You received this message because you are subscribed to the Google Groups "Grails Dev Discuss" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/grails-dev-discuss/8f571962-9160-4995-8e7e-4976c2acb2ea%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

Re: Grails 3 upgrade path: plugins you want migrated

Robert Kasanicky
In reply to this post by Graeme Rocher-2
With grails 2.x it's these plugins that together form a truly productive package for me (it's the sum of provided capabilities that really matters to me rather than any single plugin being a blocker).

console

shiro

geb

mail + greenmail + asynchronous-mail

quartz

ehcache

database-migration

fixtures

code-coverage

codenarc

On Tuesday, June 16, 2015 at 2:55:15 PM UTC+2, Graeme Rocher wrote:
Hi all,

We have taken note that a significant number of users will not or cannot upgrade to Grails 3.0 until some key plugins are upgraded.

With that in mind I would like feedback from the community about which plugins you would like to see migrated to Grails 3.0 so we can begin prioritising work in this area.

So please let us know which plugins are important and whose absence are preventing you from exploring upgrading to Grails 3.0

Thanks for your attention.

Cheers

Graeme Rocher
Grails Project lead
OCI - <a href="http://ociweb.com" target="_blank" rel="nofollow" onmousedown="this.href='http://www.google.com/url?q\75http%3A%2F%2Fociweb.com\46sa\75D\46sntz\0751\46usg\75AFQjCNGzeZwvqKHLWu--y_uuay6-1VkagA';return true;" onclick="this.href='http://www.google.com/url?q\75http%3A%2F%2Fociweb.com\46sa\75D\46sntz\0751\46usg\75AFQjCNGzeZwvqKHLWu--y_uuay6-1VkagA';return true;">http://ociweb.com

--
You received this message because you are subscribed to the Google Groups "Grails Dev Discuss" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/grails-dev-discuss/173b70bf-6a27-4722-9fb8-170becb7ad88%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

Re: Grails 3 upgrade path: plugins you want migrated

Juan Flynn
In reply to this post by Graeme Rocher-2
My top 4:

* spring-security-core
* spring-security-kerberos  (essential for SSO deployment in the enterprise)
* spring-secruity-ui
* jasper

Cheers,
Juan

--
You received this message because you are subscribed to the Google Groups "Grails Dev Discuss" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/grails-dev-discuss/c94e40a4-41ef-4985-8907-0eaa071eb129%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

Re: Grails 3 upgrade path: plugins you want migrated

zyro
In reply to this post by Graeme Rocher-2
seeing spring-security(-xyz) mentioned frequently in this topic, maybe a
viable approach for grails-3 successors of the spring-security plugins
would be a mixture of codegen scripts generating spring "java" config
and artifacts like domain classes/controllers and then just providing
the "glue"/"helpers" (taglib/service/utils etc.)?

regarding the codegen, migrating grails-spring-websocket to grails-3, i
took a similar approach (a very simple example) with
https://github.com/zyro23/grails-spring-websocket/blob/master/src/main/scripts/CreateWebSocketConfig.groovy

i wanted to stay as close as possible to how you would use it in
spring(-boot) to keep the flexibility of using your own "java" config.
(and to be able to point to the ref docs ;))

btw: the current bean definition loading order/precedence should still
allow groovy dsl defined beans to override those from "java" configs.

zyro

-------- Original Message  --------
Subject: Grails 3 upgrade path: plugins you want migrated
From: Graeme Rocher <[hidden email]>
To: [hidden email]
Date: Tue, 16 Jun 2015 05:55:13 -0700 (pdt)

> Hi all,
>
> We have taken note that a significant number of users will not or cannot
> upgrade to Grails 3.0 until some key plugins are upgraded.
>
> With that in mind I would like feedback from the community about which
> plugins you would like to see migrated to Grails 3.0 so we can begin
> prioritising work in this area.
>
> So please let us know which plugins are important and whose absence are
> preventing you from exploring upgrading to Grails 3.0
>
> Thanks for your attention.
>
> Cheers
>
> —
> Graeme Rocher
> Grails Project lead
> OCI - http://ociweb.com
>
> --
> You received this message because you are subscribed to the Google
> Groups "Grails Dev Discuss" group.
> To unsubscribe from this group and stop receiving emails from it, send
> an email to [hidden email]
> <mailto:[hidden email]>.
> To post to this group, send email to [hidden email]
> <mailto:[hidden email]>.
> To view this discussion on the web visit
> https://groups.google.com/d/msgid/grails-dev-discuss/1434459312279.2bb0f55a%40Nodemailer
> <https://groups.google.com/d/msgid/grails-dev-discuss/1434459312279.2bb0f55a%40Nodemailer?utm_medium=email&utm_source=footer>.
> For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "Grails Dev Discuss" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/grails-dev-discuss/558074F0.3070609%40zyro.net.
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

Re: Grails 3 upgrade path: plugins you want migrated

Owen Rubel
My plugin relied heavily on spring-plugin-core and as I'm converting to  grails-3/spring-boot, I took a more distributed architecture approach and realized that I should be passing a TOKEN instead as authentication/authorization can be 'edge functionality' which is handled at the PROXY as well as in the application.

By handling with a token, we can pass across the architecture... something I would suggest more people look into while they are waiting on spring-security-core. You can already integrate a solution quite easily with Stormpath for OAUTH.

Something to think about anyway.

On Tuesday, June 16, 2015 at 12:11:52 PM UTC-7, zyro wrote:
seeing spring-security(-xyz) mentioned frequently in this topic, maybe a
viable approach for grails-3 successors of the spring-security plugins
would be a mixture of codegen scripts generating spring "java" config
and artifacts like domain classes/controllers and then just providing
the "glue"/"helpers" (taglib/service/utils etc.)?

regarding the codegen, migrating grails-spring-websocket to grails-3, i
took a similar approach (a very simple example) with
<a href="https://github.com/zyro23/grails-spring-websocket/blob/master/src/main/scripts/CreateWebSocketConfig.groovy" target="_blank" rel="nofollow" onmousedown="this.href='https://www.google.com/url?q\75https%3A%2F%2Fgithub.com%2Fzyro23%2Fgrails-spring-websocket%2Fblob%2Fmaster%2Fsrc%2Fmain%2Fscripts%2FCreateWebSocketConfig.groovy\46sa\75D\46sntz\0751\46usg\75AFQjCNFOtR0uSy4jOxu-45uF8n9FEH46DQ';return true;" onclick="this.href='https://www.google.com/url?q\75https%3A%2F%2Fgithub.com%2Fzyro23%2Fgrails-spring-websocket%2Fblob%2Fmaster%2Fsrc%2Fmain%2Fscripts%2FCreateWebSocketConfig.groovy\46sa\75D\46sntz\0751\46usg\75AFQjCNFOtR0uSy4jOxu-45uF8n9FEH46DQ';return true;">https://github.com/zyro23/grails-spring-websocket/blob/master/src/main/scripts/CreateWebSocketConfig.groovy

i wanted to stay as close as possible to how you would use it in
spring(-boot) to keep the flexibility of using your own "java" config.
(and to be able to point to the ref docs ;))

btw: the current bean definition loading order/precedence should still
allow groovy dsl defined beans to override those from "java" configs.

zyro

-------- Original Message  --------
Subject: Grails 3 upgrade path: plugins you want migrated
From: Graeme Rocher <<a href="javascript:" target="_blank" gdf-obfuscated-mailto="lsgKCPSxhq8J" rel="nofollow" onmousedown="this.href='javascript:';return true;" onclick="this.href='javascript:';return true;">graeme...@...>
To: <a href="javascript:" target="_blank" gdf-obfuscated-mailto="lsgKCPSxhq8J" rel="nofollow" onmousedown="this.href='javascript:';return true;" onclick="this.href='javascript:';return true;">grails-de...@googlegroups.com
Date: Tue, 16 Jun 2015 05:55:13 -0700 (pdt)

> Hi all,
>
> We have taken note that a significant number of users will not or cannot
> upgrade to Grails 3.0 until some key plugins are upgraded.
>
> With that in mind I would like feedback from the community about which
> plugins you would like to see migrated to Grails 3.0 so we can begin
> prioritising work in this area.
>
> So please let us know which plugins are important and whose absence are
> preventing you from exploring upgrading to Grails 3.0
>
> Thanks for your attention.
>
> Cheers
>
> —
> Graeme Rocher
> Grails Project lead
> OCI - <a href="http://ociweb.com" target="_blank" rel="nofollow" onmousedown="this.href='http://www.google.com/url?q\75http%3A%2F%2Fociweb.com\46sa\75D\46sntz\0751\46usg\75AFQjCNGzeZwvqKHLWu--y_uuay6-1VkagA';return true;" onclick="this.href='http://www.google.com/url?q\75http%3A%2F%2Fociweb.com\46sa\75D\46sntz\0751\46usg\75AFQjCNGzeZwvqKHLWu--y_uuay6-1VkagA';return true;">http://ociweb.com
>
> --
> You received this message because you are subscribed to the Google
> Groups "Grails Dev Discuss" group.
> To unsubscribe from this group and stop receiving emails from it, send
> an email to <a href="javascript:" target="_blank" gdf-obfuscated-mailto="lsgKCPSxhq8J" rel="nofollow" onmousedown="this.href='javascript:';return true;" onclick="this.href='javascript:';return true;">grails-dev-discuss+unsubscribe@...
> <mailto:<a href="javascript:" target="_blank" gdf-obfuscated-mailto="lsgKCPSxhq8J" rel="nofollow" onmousedown="this.href='javascript:';return true;" onclick="this.href='javascript:';return true;">grails-dev-discuss+unsubscribe@...>.
> To post to this group, send email to <a href="javascript:" target="_blank" gdf-obfuscated-mailto="lsgKCPSxhq8J" rel="nofollow" onmousedown="this.href='javascript:';return true;" onclick="this.href='javascript:';return true;">grails-de...@googlegroups.com
> <mailto:<a href="javascript:" target="_blank" gdf-obfuscated-mailto="lsgKCPSxhq8J" rel="nofollow" onmousedown="this.href='javascript:';return true;" onclick="this.href='javascript:';return true;">grails-de...@googlegroups.com>.
> To view this discussion on the web visit
> <a href="https://groups.google.com/d/msgid/grails-dev-discuss/1434459312279.2bb0f55a%40Nodemailer" target="_blank" rel="nofollow" onmousedown="this.href='https://groups.google.com/d/msgid/grails-dev-discuss/1434459312279.2bb0f55a%40Nodemailer';return true;" onclick="this.href='https://groups.google.com/d/msgid/grails-dev-discuss/1434459312279.2bb0f55a%40Nodemailer';return true;">https://groups.google.com/d/msgid/grails-dev-discuss/1434459312279.2bb0f55a%40Nodemailer
> <<a href="https://groups.google.com/d/msgid/grails-dev-discuss/1434459312279.2bb0f55a%40Nodemailer?utm_medium=email&amp;utm_source=footer" target="_blank" rel="nofollow" onmousedown="this.href='https://groups.google.com/d/msgid/grails-dev-discuss/1434459312279.2bb0f55a%40Nodemailer?utm_medium\75email\46utm_source\75footer';return true;" onclick="this.href='https://groups.google.com/d/msgid/grails-dev-discuss/1434459312279.2bb0f55a%40Nodemailer?utm_medium\75email\46utm_source\75footer';return true;">https://groups.google.com/d/msgid/grails-dev-discuss/1434459312279.2bb0f55a%40Nodemailer?utm_medium=email&utm_source=footer>.
> For more options, visit <a href="https://groups.google.com/d/optout" target="_blank" rel="nofollow" onmousedown="this.href='https://groups.google.com/d/optout';return true;" onclick="this.href='https://groups.google.com/d/optout';return true;">https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "Grails Dev Discuss" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/grails-dev-discuss/a08ad95f-bd87-4bd3-9073-486bd72a8856%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

Re: Grails 3 upgrade path: plugins you want migrated

James Kleeh
In reply to this post by Graeme Rocher-2
Spring-security-core and spring-security-ldap are preventing me from switching to Grails 3.

On Tuesday, June 16, 2015 at 8:55:15 AM UTC-4, Graeme Rocher wrote:
Hi all,

We have taken note that a significant number of users will not or cannot upgrade to Grails 3.0 until some key plugins are upgraded.

With that in mind I would like feedback from the community about which plugins you would like to see migrated to Grails 3.0 so we can begin prioritising work in this area.

So please let us know which plugins are important and whose absence are preventing you from exploring upgrading to Grails 3.0

Thanks for your attention.

Cheers

Graeme Rocher
Grails Project lead
OCI - <a href="http://ociweb.com" target="_blank" rel="nofollow" onmousedown="this.href='http://www.google.com/url?q\75http%3A%2F%2Fociweb.com\46sa\75D\46sntz\0751\46usg\75AFQjCNGzeZwvqKHLWu--y_uuay6-1VkagA';return true;" onclick="this.href='http://www.google.com/url?q\75http%3A%2F%2Fociweb.com\46sa\75D\46sntz\0751\46usg\75AFQjCNGzeZwvqKHLWu--y_uuay6-1VkagA';return true;">http://ociweb.com

--
You received this message because you are subscribed to the Google Groups "Grails Dev Discuss" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/grails-dev-discuss/62271fc9-5a23-4196-ba19-56f2502f902c%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

Re: Grails 3 upgrade path: plugins you want migrated

Ronny Løvtangen
In reply to this post by Graeme Rocher-2
spring-security-core is what prevent us the most from upgrading. We have a custom plugin that builds on top of spring-security-core, which we use in most of our 20-30 applications.

Our must-have-list (some of which are already Grails3-ready):

spring-security-core
spring-security-ldap
cache
cache-ehcache
quartz
routing
routing-jms
mail
console (not really a blocker, but hard to live without)

Ronny


On 16 Jun 2015, at 14:55, Graeme Rocher <[hidden email]> wrote:

Hi all,

We have taken note that a significant number of users will not or cannot upgrade to Grails 3.0 until some key plugins are upgraded.

With that in mind I would like feedback from the community about which plugins you would like to see migrated to Grails 3.0 so we can begin prioritising work in this area.

So please let us know which plugins are important and whose absence are preventing you from exploring upgrading to Grails 3.0

Thanks for your attention.

Cheers

Graeme Rocher
Grails Project lead

--
You received this message because you are subscribed to the Google Groups "Grails Dev Discuss" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/grails-dev-discuss/1434459312279.2bb0f55a%40Nodemailer.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "Grails Dev Discuss" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/grails-dev-discuss/70D41F86-DF4B-4C59-90AD-A52269141A34%40lovtangen.com.
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

Grails 3 upgrade path: plugins you want migrated

YeIIowsnow
In reply to this post by Graeme Rocher-2
Thanks Graeme for asking, my top priority is:
- shiro
- database-migration
- console

Cheers

--
You received this message because you are subscribed to the Google Groups "Grails Dev Discuss" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/grails-dev-discuss/c48ccfff-aa55-4956-b58c-6404ff5ee6a8%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.
1234 ... 6