Grails 3 upgrade path: plugins you want migrated

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
101 messages Options
123456
Reply | Threaded
Open this post in threaded view
|

Grails 3 upgrade path: plugins you want migrated

YeIIowsnow
I forgot about this one:
- i18n-templates

Thanks again!

--
You received this message because you are subscribed to the Google Groups "Grails Dev Discuss" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/grails-dev-discuss/d861e5ef-b3c8-46d4-bdf2-8380efb5dc92%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

Re: Grails 3 upgrade path: plugins you want migrated

Grails Dev Discuss mailing list
In reply to this post by Graeme Rocher-2
Now that java.time exists and because of time types are used in any application of any size, I suggest there should be a native, in other words, a core plugin for this instead of being depending of Joda-Time be upgraded.

shiro is my other top plugin

--
You received this message because you are subscribed to the Google Groups "Grails Dev Discuss" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/grails-dev-discuss/d42647a9-9281-4236-beb0-3ef19aab3e11%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

Re: Grails 3 upgrade path: plugins you want migrated

Grails Dev Discuss mailing list
Giving me a reply to myself. After digging a while, I have concluded that an all round support for types in java.time packages ( tag libraries in web pages, controllers and databases) is on development still. So, sadly, because of the heavy use of time types in my application under development; I have to fall back to a safe place, that is, grails 2.3.11, java 1.7 and joda-time. 

El martes, 16 de junio de 2015, 17:36:07 (UTC-5), Hector Zendejas escribió:
Now that java.time exists and because of time types are used in any application of any size, I suggest there should be a native, in other words, a core plugin for this instead of being depending of Joda-Time be upgraded.

shiro is my other top plugin

--
You received this message because you are subscribed to the Google Groups "Grails Dev Discuss" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/grails-dev-discuss/43b3db83-20cd-4768-aa1c-5fbc56f3c778%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

Re: Grails 3 upgrade path: plugins you want migrated

Gregory Dickson
In reply to this post by Graeme Rocher-2
Here is what our production app would need as a minimum, (a quick dump from buildconfig)

asset-pipeline:2.1.1'
mail:1.0.7"
cookie:1.4'
:spring-security-core:2.0-RC4"
spring-security-oauth:2.1.0-RC4'
spring-security-oauth-google:0.3.1'
:spring-security-oauth-facebook:0.2"

quartz:1.0.2"

:spock:0.7"
 :geb:0.9.3"

  
        


        compile ":sass-asset-pipeline:2.0.4"
 

On Tuesday, June 16, 2015 at 7:55:15 AM UTC-5, Graeme Rocher wrote:
Hi all,

We have taken note that a significant number of users will not or cannot upgrade to Grails 3.0 until some key plugins are upgraded.

With that in mind I would like feedback from the community about which plugins you would like to see migrated to Grails 3.0 so we can begin prioritising work in this area.

So please let us know which plugins are important and whose absence are preventing you from exploring upgrading to Grails 3.0

Thanks for your attention.

Cheers

Graeme Rocher
Grails Project lead
OCI - <a href="http://ociweb.com" target="_blank" rel="nofollow" onmousedown="this.href='http://www.google.com/url?q\75http%3A%2F%2Fociweb.com\46sa\75D\46sntz\0751\46usg\75AFQjCNGzeZwvqKHLWu--y_uuay6-1VkagA';return true;" onclick="this.href='http://www.google.com/url?q\75http%3A%2F%2Fociweb.com\46sa\75D\46sntz\0751\46usg\75AFQjCNGzeZwvqKHLWu--y_uuay6-1VkagA';return true;">http://ociweb.com

--
You received this message because you are subscribed to the Google Groups "Grails Dev Discuss" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/grails-dev-discuss/6766ae83-9a02-46ad-8cf1-265d263ff290%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

Re: Grails 3 upgrade path: plugins you want migrated

Graeme Rocher-2
Thanks for the feedback, here is an initial list

https://github.com/grails/grails-core/wiki/Grails-3-Priority-Upgrade-Plugins

Let me know if we are missing anything standout / critical.

Cheers!

Graeme Rocher
Grails Project lead
OCI - http://ociweb.com


On Wed, Jun 17, 2015 at 7:37 AM, Gregory Dickson <[hidden email]> wrote:

Here is what our production app would need as a minimum, (a quick dump from buildconfig)

asset-pipeline:2.1.1'
mail:1.0.7"
cookie:1.4'
:spring-security-core:2.0-RC4"
spring-security-oauth:2.1.0-RC4'
spring-security-oauth-google:0.3.1'
:spring-security-oauth-facebook:0.2"

quartz:1.0.2"

:spock:0.7"
 :geb:0.9.3"

  
        


        compile ":sass-asset-pipeline:2.0.4"
 

On Tuesday, June 16, 2015 at 7:55:15 AM UTC-5, Graeme Rocher wrote:
Hi all,

We have taken note that a significant number of users will not or cannot upgrade to Grails 3.0 until some key plugins are upgraded.

With that in mind I would like feedback from the community about which plugins you would like to see migrated to Grails 3.0 so we can begin prioritising work in this area.

So please let us know which plugins are important and whose absence are preventing you from exploring upgrading to Grails 3.0

Thanks for your attention.

Cheers

Graeme Rocher
Grails Project lead

--
You received this message because you are subscribed to the Google Groups "Grails Dev Discuss" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/grails-dev-discuss/6766ae83-9a02-46ad-8cf1-265d263ff290%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "Grails Dev Discuss" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/grails-dev-discuss/1434525391993.81c94fe6%40Nodemailer.
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

Re: Grails 3 upgrade path: plugins you want migrated

dmurat
Graeme,

Please, include Grails constraints plugin (https://grails.org/plugin/constraints) in the list. I found it essential to write custom validators which is, I believe, important part of any application.
I didn't dig into grails 3 yet, so if there is similar functionality available, please ignore this message.

Tnx.

--
You received this message because you are subscribed to the Google Groups "Grails Dev Discuss" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/grails-dev-discuss/ca23d95f-4021-45e8-b290-f1423e169978%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

Re: Grails 3 upgrade path: plugins you want migrated

nicolas thon
In reply to this post by Graeme Rocher-2
Due to our application relies on:

-   spring-security-core
- spring-security-rest
- cxf-client
- jasper
And we appreciate if above plugin has been upgraded.
Please correct me if i have any mistake.
Thank you so much for your effort and kind.

On Tuesday, June 16, 2015 at 3:55:15 PM UTC+3, Graeme Rocher wrote:
Hi all,

We have taken note that a significant number of users will not or cannot upgrade to Grails 3.0 until some key plugins are upgraded.

With that in mind I would like feedback from the community about which plugins you would like to see migrated to Grails 3.0 so we can begin prioritising work in this area.

So please let us know which plugins are important and whose absence are preventing you from exploring upgrading to Grails 3.0

Thanks for your attention.

Cheers

Graeme Rocher
Grails Project lead
OCI - <a href="http://ociweb.com" target="_blank" rel="nofollow" onmousedown="this.href='http://www.google.com/url?q\75http%3A%2F%2Fociweb.com\46sa\75D\46sntz\0751\46usg\75AFQjCNGzeZwvqKHLWu--y_uuay6-1VkagA';return true;" onclick="this.href='http://www.google.com/url?q\75http%3A%2F%2Fociweb.com\46sa\75D\46sntz\0751\46usg\75AFQjCNGzeZwvqKHLWu--y_uuay6-1VkagA';return true;">http://ociweb.com

--
You received this message because you are subscribed to the Google Groups "Grails Dev Discuss" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/grails-dev-discuss/58e75e82-9aea-4a6c-bbb2-5d92a37a2a88%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

Re: Grails 3 upgrade path: plugins you want migrated

german
In reply to this post by Graeme Rocher-2
Hi Graeme,

This plugins are blockers for us:

rabbitmq-native
spring-security-rest
cache-headers

Thanks for this initiative that will help everyone moving to Grails 3!

Germán


On Tuesday, June 16, 2015 at 2:55:15 PM UTC+2, Graeme Rocher wrote:
Hi all,

We have taken note that a significant number of users will not or cannot upgrade to Grails 3.0 until some key plugins are upgraded.

With that in mind I would like feedback from the community about which plugins you would like to see migrated to Grails 3.0 so we can begin prioritising work in this area.

So please let us know which plugins are important and whose absence are preventing you from exploring upgrading to Grails 3.0

Thanks for your attention.

Cheers

Graeme Rocher
Grails Project lead
OCI - <a href="http://ociweb.com" target="_blank" rel="nofollow" onmousedown="this.href='http://www.google.com/url?q\75http%3A%2F%2Fociweb.com\46sa\75D\46sntz\0751\46usg\75AFQjCNGzeZwvqKHLWu--y_uuay6-1VkagA';return true;" onclick="this.href='http://www.google.com/url?q\75http%3A%2F%2Fociweb.com\46sa\75D\46sntz\0751\46usg\75AFQjCNGzeZwvqKHLWu--y_uuay6-1VkagA';return true;">http://ociweb.com

--
You received this message because you are subscribed to the Google Groups "Grails Dev Discuss" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/grails-dev-discuss/788c6912-81ab-4962-8c0a-ef7e0ad6f921%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

Re: Grails 3 upgrade path: plugins you want migrated

Miro Bezjak
In reply to this post by nicolas thon
For us, the most important plugin is `shiro`. Other, less important ones are: `mail` and `console`.

Kind Regards,
Miro

On Wed, Jun 17, 2015 at 10:47 AM, nicolas thon <[hidden email]> wrote:
Due to our application relies on:

-   spring-security-core
- spring-security-rest
- cxf-client
- jasper
And we appreciate if above plugin has been upgraded.
Please correct me if i have any mistake.
Thank you so much for your effort and kind.

On Tuesday, June 16, 2015 at 3:55:15 PM UTC+3, Graeme Rocher wrote:
Hi all,

We have taken note that a significant number of users will not or cannot upgrade to Grails 3.0 until some key plugins are upgraded.

With that in mind I would like feedback from the community about which plugins you would like to see migrated to Grails 3.0 so we can begin prioritising work in this area.

So please let us know which plugins are important and whose absence are preventing you from exploring upgrading to Grails 3.0

Thanks for your attention.

Cheers

Graeme Rocher
Grails Project lead

--
You received this message because you are subscribed to the Google Groups "Grails Dev Discuss" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/grails-dev-discuss/58e75e82-9aea-4a6c-bbb2-5d92a37a2a88%40googlegroups.com.

For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "Grails Dev Discuss" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/grails-dev-discuss/CAMJqDfPc5ZqYf%2BV0XNWhAW72G_7QODHvXLdSpCUNBbbH4MCfNA%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

Re: Grails 3 upgrade path: plugins you want migrated

Mirko Weber
In reply to this post by Graeme Rocher-2
Hi Graeme,

for  me it would be:
  • twitter-bootstrap
  • cache + cache-ehcache
  • codenarc
  • jquery (nobody mention this, did i miss something about this plugin already exists for grails3.0?, or nobody uses jquery as plugin anymore?)
  • export
  • wslite

Thanks,
Mirko

--
You received this message because you are subscribed to the Google Groups "Grails Dev Discuss" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/grails-dev-discuss/748f2b37-1c6b-414d-9522-cfe17196c3f9%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

Re: Grails 3 upgrade path: plugins you want migrated

Tamer
In reply to this post by Graeme Rocher-2
Hi Graeme,

This is my list of needed plugins:


rabbit
cache headers
spring security
spring-security-rest


I can't wait to move to grails 3! :)

Thanks

T

Il giorno martedì 16 giugno 2015 13:55:15 UTC+1, Graeme Rocher ha scritto:
Hi all,

We have taken note that a significant number of users will not or cannot upgrade to Grails 3.0 until some key plugins are upgraded.

With that in mind I would like feedback from the community about which plugins you would like to see migrated to Grails 3.0 so we can begin prioritising work in this area.

So please let us know which plugins are important and whose absence are preventing you from exploring upgrading to Grails 3.0

Thanks for your attention.

Cheers

Graeme Rocher
Grails Project lead
OCI - <a href="http://ociweb.com" target="_blank" rel="nofollow" onmousedown="this.href='http://www.google.com/url?q\75http%3A%2F%2Fociweb.com\46sa\75D\46sntz\0751\46usg\75AFQjCNGzeZwvqKHLWu--y_uuay6-1VkagA';return true;" onclick="this.href='http://www.google.com/url?q\75http%3A%2F%2Fociweb.com\46sa\75D\46sntz\0751\46usg\75AFQjCNGzeZwvqKHLWu--y_uuay6-1VkagA';return true;">http://ociweb.com

--
You received this message because you are subscribed to the Google Groups "Grails Dev Discuss" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/grails-dev-discuss/13afd512-cf62-44e7-bb83-6751c85b2434%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

Re: Grails 3 upgrade path: plugins you want migrated

iveta georgieva
Hi,

This is my list of needed plugins:

searchable 
remote pagination

jquery
jquery-ui

tooltip
build-test-data

сряда, 17 юни 2015 г., 13:38:41 UTC+3, Tamer Shahin написа:
Hi Graeme,

This is my list of needed plugins:


rabbit
cache headers
spring security
spring-security-rest


I can't wait to move to grails 3! :)

Thanks

T

Il giorno martedì 16 giugno 2015 13:55:15 UTC+1, Graeme Rocher ha scritto:
Hi all,

We have taken note that a significant number of users will not or cannot upgrade to Grails 3.0 until some key plugins are upgraded.

With that in mind I would like feedback from the community about which plugins you would like to see migrated to Grails 3.0 so we can begin prioritising work in this area.

So please let us know which plugins are important and whose absence are preventing you from exploring upgrading to Grails 3.0

Thanks for your attention.

Cheers

Graeme Rocher
Grails Project lead
OCI - <a href="http://ociweb.com" rel="nofollow" target="_blank" onmousedown="this.href='http://www.google.com/url?q\75http%3A%2F%2Fociweb.com\46sa\75D\46sntz\0751\46usg\75AFQjCNGzeZwvqKHLWu--y_uuay6-1VkagA';return true;" onclick="this.href='http://www.google.com/url?q\75http%3A%2F%2Fociweb.com\46sa\75D\46sntz\0751\46usg\75AFQjCNGzeZwvqKHLWu--y_uuay6-1VkagA';return true;">http://ociweb.com

--
You received this message because you are subscribed to the Google Groups "Grails Dev Discuss" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/grails-dev-discuss/3023663f-cd9e-4dbc-aa61-ff873970f687%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

Re: Grails 3 upgrade path: plugins you want migrated

Jeff Brown
In reply to this post by Dominic Fui Dodzi-Nusenu

> On Jun 16, 2015, at 9:42 AM, Dominic Fui Dodzi-Nusenu <[hidden email]> wrote:
>
> Not really, its in my list, so I wanted to add it anyway.. But obviously, there are workarounds I could use. This was just a copy paste list :-)
>
>

Do you know what kinds of things you are doing with the webxml plugin in Grails 2 that you would also like to do in Grails 3?



JSB


Jeff Scott Brown
Principal Software Engineer
Grails Development Team
Object Computing Inc.
http://www.ociweb.com/

Autism Strikes 1 in 166
Find The Cause ~ Find The Cure
http://www.autismspeaks.org/

--
You received this message because you are subscribed to the Google Groups "Grails Dev Discuss" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/grails-dev-discuss/158F2BE5-5CEB-44DC-9447-2198FE50527F%40ociweb.com.
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

Re: Grails 3 upgrade path: plugins you want migrated

tcrossland
In reply to this post by Graeme Rocher-2
Hi Graeme, Jeff, et. al.

Hope you're enjoying your new "home" in OCI. We're eager to migrate a few applications to Grails 3 but there are a few plugins which are preventing us from doing so at the moment. In order of importance:
  • spring-security-core
  • spring-security-acl
  • spring-security-ldap
  • audit-logging
  • quartz (already migrated?)
  • mail (already migrated?)
  • asynchronous-mail
If I manage to find any "free time" I'd be happy to help with the migration effort.

Cheers,


On Tuesday, 16 June 2015 14:55:15 UTC+2, Graeme Rocher wrote:
Hi all,

We have taken note that a significant number of users will not or cannot upgrade to Grails 3.0 until some key plugins are upgraded.

With that in mind I would like feedback from the community about which plugins you would like to see migrated to Grails 3.0 so we can begin prioritising work in this area.

So please let us know which plugins are important and whose absence are preventing you from exploring upgrading to Grails 3.0

Thanks for your attention.

Cheers

Graeme Rocher
Grails Project lead
OCI - <a href="http://ociweb.com" target="_blank" rel="nofollow" onmousedown="this.href='http://www.google.com/url?q\75http%3A%2F%2Fociweb.com\46sa\75D\46sntz\0751\46usg\75AFQjCNGzeZwvqKHLWu--y_uuay6-1VkagA';return true;" onclick="this.href='http://www.google.com/url?q\75http%3A%2F%2Fociweb.com\46sa\75D\46sntz\0751\46usg\75AFQjCNGzeZwvqKHLWu--y_uuay6-1VkagA';return true;">http://ociweb.com

--
You received this message because you are subscribed to the Google Groups "Grails Dev Discuss" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/grails-dev-discuss/a61a9394-010d-4f7f-9c13-a3dbc9d5b2c7%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

Re: Grails 3 upgrade path: plugins you want migrated

tcrossland
I forgot to mention my old friend "fields".

On Wednesday, 17 June 2015 17:31:18 UTC+2, Tom Crossland wrote:
Hi Graeme, Jeff, et. al.

Hope you're enjoying your new "home" in OCI. We're eager to migrate a few applications to Grails 3 but there are a few plugins which are preventing us from doing so at the moment. In order of importance:
  • spring-security-core
  • spring-security-acl
  • spring-security-ldap
  • audit-logging
  • quartz (already migrated?)
  • mail (already migrated?)
  • asynchronous-mail
If I manage to find any "free time" I'd be happy to help with the migration effort.

Cheers,


On Tuesday, 16 June 2015 14:55:15 UTC+2, Graeme Rocher wrote:
Hi all,

We have taken note that a significant number of users will not or cannot upgrade to Grails 3.0 until some key plugins are upgraded.

With that in mind I would like feedback from the community about which plugins you would like to see migrated to Grails 3.0 so we can begin prioritising work in this area.

So please let us know which plugins are important and whose absence are preventing you from exploring upgrading to Grails 3.0

Thanks for your attention.

Cheers

Graeme Rocher
Grails Project lead
OCI - <a href="http://ociweb.com" rel="nofollow" target="_blank" onmousedown="this.href='http://www.google.com/url?q\75http%3A%2F%2Fociweb.com\46sa\75D\46sntz\0751\46usg\75AFQjCNGzeZwvqKHLWu--y_uuay6-1VkagA';return true;" onclick="this.href='http://www.google.com/url?q\75http%3A%2F%2Fociweb.com\46sa\75D\46sntz\0751\46usg\75AFQjCNGzeZwvqKHLWu--y_uuay6-1VkagA';return true;">http://ociweb.com

--
You received this message because you are subscribed to the Google Groups "Grails Dev Discuss" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/grails-dev-discuss/926520e9-d35f-46fd-879c-728e14595203%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

Re: Grails 3 upgrade path: plugins you want migrated

Rishi Saraf
In reply to this post by Graeme Rocher-2
Hi Graeme,

We need upgrade of below plugins.

asynchronous-mail
email-confirmation
spring-security-core
events-push
grails-melody
searchable
taggable

Regards
Rishi


--
You received this message because you are subscribed to the Google Groups "Grails Dev Discuss" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/grails-dev-discuss/e546977c-111d-49f5-848c-82199b9d81c0%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

Re: Grails 3 upgrade path: plugins you want migrated

puneet.behl
In reply to this post by Graeme Rocher-2
I alongwith few of my colleagues have migrated the following plugins to Grails3:
- grails-asynchronous-mail
- grails-export
- closure
- joda-time.
- grails-simple-capcha

And these are next in our to-do list: 
- elasticsearch
- grails-excel-import
- remote-control

On Tuesday, June 16, 2015 at 6:25:15 PM UTC+5:30, Graeme Rocher wrote:
Hi all,

We have taken note that a significant number of users will not or cannot upgrade to Grails 3.0 until some key plugins are upgraded.

With that in mind I would like feedback from the community about which plugins you would like to see migrated to Grails 3.0 so we can begin prioritising work in this area.

So please let us know which plugins are important and whose absence are preventing you from exploring upgrading to Grails 3.0

Thanks for your attention.

Cheers

Graeme Rocher
Grails Project lead
OCI - <a href="http://ociweb.com" target="_blank" rel="nofollow" onmousedown="this.href='http://www.google.com/url?q\75http%3A%2F%2Fociweb.com\46sa\75D\46sntz\0751\46usg\75AFQjCNGzeZwvqKHLWu--y_uuay6-1VkagA';return true;" onclick="this.href='http://www.google.com/url?q\75http%3A%2F%2Fociweb.com\46sa\75D\46sntz\0751\46usg\75AFQjCNGzeZwvqKHLWu--y_uuay6-1VkagA';return true;">http://ociweb.com

--
You received this message because you are subscribed to the Google Groups "Grails Dev Discuss" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/grails-dev-discuss/fabd2432-0a76-46ae-9bcd-5bc5586d308d%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

Re: Grails 3 upgrade path: plugins you want migrated

Adrien Guichard
In reply to this post by Graeme Rocher-2
Many of my applications use the webflow plugin, any chance to see this plugin migrated to Grails 3.0?


Le mardi 16 juin 2015 14:55:15 UTC+2, Graeme Rocher a écrit :
Hi all,

We have taken note that a significant number of users will not or cannot upgrade to Grails 3.0 until some key plugins are upgraded.

With that in mind I would like feedback from the community about which plugins you would like to see migrated to Grails 3.0 so we can begin prioritising work in this area.

So please let us know which plugins are important and whose absence are preventing you from exploring upgrading to Grails 3.0

Thanks for your attention.

Cheers

Graeme Rocher
Grails Project lead
OCI - <a href="http://ociweb.com" target="_blank" rel="nofollow" onmousedown="this.href='http://www.google.com/url?q\75http%3A%2F%2Fociweb.com\46sa\75D\46sntz\0751\46usg\75AFQjCNGzeZwvqKHLWu--y_uuay6-1VkagA';return true;" onclick="this.href='http://www.google.com/url?q\75http%3A%2F%2Fociweb.com\46sa\75D\46sntz\0751\46usg\75AFQjCNGzeZwvqKHLWu--y_uuay6-1VkagA';return true;">http://ociweb.com

--
You received this message because you are subscribed to the Google Groups "Grails Dev Discuss" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/grails-dev-discuss/a8c8745f-ce7a-4080-acaf-2ed33399b7e0%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

Re: Grails 3 upgrade path: plugins you want migrated

chichibek bros
In reply to this post by Graeme Rocher-2
1. spring-security-core
2. webflow
3. quartz

I know it is alot of work i hope more people can help

On Tuesday, June 16, 2015 at 6:55:15 AM UTC-6, Graeme Rocher wrote:
Hi all,

We have taken note that a significant number of users will not or cannot upgrade to Grails 3.0 until some key plugins are upgraded.

With that in mind I would like feedback from the community about which plugins you would like to see migrated to Grails 3.0 so we can begin prioritising work in this area.

So please let us know which plugins are important and whose absence are preventing you from exploring upgrading to Grails 3.0

Thanks for your attention.

Cheers

Graeme Rocher
Grails Project lead
OCI - <a href="http://ociweb.com" target="_blank" rel="nofollow" onmousedown="this.href='http://www.google.com/url?q\75http%3A%2F%2Fociweb.com\46sa\75D\46sntz\0751\46usg\75AFQjCNGzeZwvqKHLWu--y_uuay6-1VkagA';return true;" onclick="this.href='http://www.google.com/url?q\75http%3A%2F%2Fociweb.com\46sa\75D\46sntz\0751\46usg\75AFQjCNGzeZwvqKHLWu--y_uuay6-1VkagA';return true;">http://ociweb.com

--
You received this message because you are subscribed to the Google Groups "Grails Dev Discuss" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/grails-dev-discuss/0b643930-8bbe-4126-82aa-32c9eb735110%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

Re: Grails 3 upgrade path: plugins you want migrated

Graeme Rocher-2
In reply to this post by puneet.behl
You contributions are really valued! I hope more in the community call
rally together to help us move forward

Cheers

On Fri, Jun 19, 2015 at 6:59 AM,  <[hidden email]> wrote:

> I alongwith few of my colleagues have migrated the following plugins to
> Grails3:
> - grails-asynchronous-mail
> - grails-export
> - closure
> - joda-time.
> - grails-simple-capcha
>
> And these are next in our to-do list:
> - elasticsearch
> - grails-excel-import
> - remote-control
>
> On Tuesday, June 16, 2015 at 6:25:15 PM UTC+5:30, Graeme Rocher wrote:
>>
>> Hi all,
>>
>> We have taken note that a significant number of users will not or cannot
>> upgrade to Grails 3.0 until some key plugins are upgraded.
>>
>> With that in mind I would like feedback from the community about which
>> plugins you would like to see migrated to Grails 3.0 so we can begin
>> prioritising work in this area.
>>
>> So please let us know which plugins are important and whose absence are
>> preventing you from exploring upgrading to Grails 3.0
>>
>> Thanks for your attention.
>>
>> Cheers
>>
>> —
>> Graeme Rocher
>> Grails Project lead
>> OCI - http://ociweb.com
>
> --
> You received this message because you are subscribed to the Google Groups
> "Grails Dev Discuss" group.
> To unsubscribe from this group and stop receiving emails from it, send an
> email to [hidden email].
> To post to this group, send email to [hidden email].
> To view this discussion on the web visit
> https://groups.google.com/d/msgid/grails-dev-discuss/fabd2432-0a76-46ae-9bcd-5bc5586d308d%40googlegroups.com.
>
> For more options, visit https://groups.google.com/d/optout.



--
Graeme Rocher

--
You received this message because you are subscribed to the Google Groups "Grails Dev Discuss" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/grails-dev-discuss/CAO_wNoe%2B8QnEggKLezJARFmSrbxrJJODOQ-%3D0zy-ixfgaCpDBg%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.
123456