Grails in STS: Groovy:unable to resolve class K

classic Classic list List threaded Threaded
7 messages Options
Reply | Threaded
Open this post in threaded view
|

Grails in STS: Groovy:unable to resolve class K

Octavian Covalschi
Has anyone seen this message before? This is something new for me... and I can't figure out a good workaround to get rid of it. If I'll do grails clean and/or project cleanup (from the toolbar) it may go away.. but not always.

I have recently upgraded STS to 2.7.1 so perhaps that's the reason?
Reply | Threaded
Open this post in threaded view
|

Re: Grails in STS: Groovy:unable to resolve class K

Andy Clement
Hi,

Can you confirm what version of Groovy-Eclipse you have installed?  If
you took the upgrade route from an old STS to a new one you may have
missed out on some important fixes in recent groovy-eclipse builds.
I'd recommend the 2.5.1 release for either Eclipse 3.6:
http://dist.springsource.org/release/GRECLIPSE/e3.6/

or 3.7:
http://dist.springsource.org/release/GRECLIPSE/e3.7/

(not sure which you are using, I presume an Eclipse 3.6 based STS if
you have been upgrading).

If that doesn't address it, I'd recommend raising a jira:
https://issuetracker.springsource.com/browse/STS (it may be a
groovy-eclipse issue but as you are in a grails project, we should
perhaps investigate it via an STS jira).

cheers
Andy

On 19 July 2011 20:43, Octavian Covalschi <[hidden email]> wrote:
> Has anyone seen this message before? This is something new for me... and I
> can't figure out a good workaround to get rid of it. If I'll do grails clean
> and/or project cleanup (from the toolbar) it may go away.. but not always.
>
> I have recently upgraded STS to 2.7.1 so perhaps that's the reason?
>

---------------------------------------------------------------------
To unsubscribe from this list, please visit:

    http://xircles.codehaus.org/manage_email


Reply | Threaded
Open this post in threaded view
|

Re: Grails in STS: Groovy:unable to resolve class K

davide.cavestro
I have the same problem even creating a new Groovy Project with an empty Groovy class

Screenshot for the groovy compiler issue on STS

I use
SpringSource Tool Suite

Version: 2.7.1.RELEASE
Build Id: 201107091000

and in particular this version of greclipse

  Groovy-Eclipse Feature 2.5.1.xx-20110628-1600-e37 org.codehaus.groovy.eclipse.feature.feature.group Codehaus.org
    Groovy Compiler 1.7.10 Feature 2.5.1.xx-20110628-1600-e37 org.codehaus.groovy17.feature.feature.group Codehaus.org
    Groovy-Eclipse Headless Feature 2.5.1.xx-20110628-1600-e37 org.codehaus.groovy.headless.feature.feature.group Codehaus.org
    JDT Core patch for Groovy-Eclipse plugin 2.1.3.xx-20110628-1600-e37 org.codehaus.groovy.jdt.patch.feature.group Codehaus.org


Cheers
Davide
Reply | Threaded
Open this post in threaded view
|

Re: Grails in STS: Groovy:unable to resolve class K

davide.cavestro
In reply to this post by Andy Clement
Just filed a new issue at STS jira

Cheers
Davide
Reply | Threaded
Open this post in threaded view
|

Re: Grails in STS: Groovy:unable to resolve class K

Octavian Covalschi
In reply to this post by Andy Clement
Sorry for late response.

Looks like I have Groovy-Eclipse of version: 2.5.1.xx-20110627-1300-e36

I had 2.5.1 installed an upgraded to 2.7.0 and then 2.7.1.. whenever it says it has something to update...

On Tue, Jul 19, 2011 at 11:42 PM, Andy Clement <[hidden email]> wrote:
Hi,

Can you confirm what version of Groovy-Eclipse you have installed?  If
you took the upgrade route from an old STS to a new one you may have
missed out on some important fixes in recent groovy-eclipse builds.
I'd recommend the 2.5.1 release for either Eclipse 3.6:
http://dist.springsource.org/release/GRECLIPSE/e3.6/

or 3.7:
http://dist.springsource.org/release/GRECLIPSE/e3.7/

(not sure which you are using, I presume an Eclipse 3.6 based STS if
you have been upgrading).

If that doesn't address it, I'd recommend raising a jira:
https://issuetracker.springsource.com/browse/STS (it may be a
groovy-eclipse issue but as you are in a grails project, we should
perhaps investigate it via an STS jira).

cheers
Andy

On 19 July 2011 20:43, Octavian Covalschi <[hidden email]> wrote:
> Has anyone seen this message before? This is something new for me... and I
> can't figure out a good workaround to get rid of it. If I'll do grails clean
> and/or project cleanup (from the toolbar) it may go away.. but not always.
>
> I have recently upgraded STS to 2.7.1 so perhaps that's the reason?
>

---------------------------------------------------------------------
To unsubscribe from this list, please visit:

   http://xircles.codehaus.org/manage_email



Reply | Threaded
Open this post in threaded view
|

Re: Grails in STS: Groovy:unable to resolve class K

Andrew Eisenberg
Hi Octavian,

Please make sure that you are running the latest dev build of
Groovy-Eclipse.  You should use this dev update site of
Groovy-Eclipse:

http://dist.codehaus.org/groovy/distributions/greclipse/snapshot/e3.7

Add it in the update manager (Help -> Install new software...).  This
issue is believed fixed in the latest dev build.

On Thu, Jul 21, 2011 at 9:51 PM, Octavian Covalschi
<[hidden email]> wrote:

> Sorry for late response.
>
> Looks like I have Groovy-Eclipse of version: 2.5.1.xx-20110627-1300-e36
>
> I had 2.5.1 installed an upgraded to 2.7.0 and then 2.7.1.. whenever it says
> it has something to update...
>
> On Tue, Jul 19, 2011 at 11:42 PM, Andy Clement <[hidden email]>
> wrote:
>>
>> Hi,
>>
>> Can you confirm what version of Groovy-Eclipse you have installed?  If
>> you took the upgrade route from an old STS to a new one you may have
>> missed out on some important fixes in recent groovy-eclipse builds.
>> I'd recommend the 2.5.1 release for either Eclipse 3.6:
>> http://dist.springsource.org/release/GRECLIPSE/e3.6/
>>
>> or 3.7:
>> http://dist.springsource.org/release/GRECLIPSE/e3.7/
>>
>> (not sure which you are using, I presume an Eclipse 3.6 based STS if
>> you have been upgrading).
>>
>> If that doesn't address it, I'd recommend raising a jira:
>> https://issuetracker.springsource.com/browse/STS (it may be a
>> groovy-eclipse issue but as you are in a grails project, we should
>> perhaps investigate it via an STS jira).
>>
>> cheers
>> Andy
>>
>> On 19 July 2011 20:43, Octavian Covalschi <[hidden email]>
>> wrote:
>> > Has anyone seen this message before? This is something new for me... and
>> > I
>> > can't figure out a good workaround to get rid of it. If I'll do grails
>> > clean
>> > and/or project cleanup (from the toolbar) it may go away.. but not
>> > always.
>> >
>> > I have recently upgraded STS to 2.7.1 so perhaps that's the reason?
>> >
>>
>> ---------------------------------------------------------------------
>> To unsubscribe from this list, please visit:
>>
>>    http://xircles.codehaus.org/manage_email
>>
>>
>
>

---------------------------------------------------------------------
To unsubscribe from this list, please visit:

    http://xircles.codehaus.org/manage_email


Reply | Threaded
Open this post in threaded view
|

Re: Grails in STS: Groovy:unable to resolve class K

Octavian Covalschi
Cannot complete the install because one or more required items could not be found.
  Software being installed: Groovy-Eclipse Feature 2.5.2.xx-20110724-1000-e37 (org.codehaus.groovy.eclipse.feature.feature.group 2.5.2.xx-20110724-1000-e37)
  Missing requirement: JDT Core patch for Groovy-Eclipse plugin 2.1.3.xx-20110724-1000-e37 (org.codehaus.groovy.jdt.patch.feature.group 2.1.3.xx-20110724-1000-e37) requires 'org.eclipse.jdt.feature.group [3.7.0,3.7.1)' but it could not be found
  Cannot satisfy dependency:
    From: Groovy-Eclipse Feature 2.5.2.xx-20110724-1000-e37 (org.codehaus.groovy.eclipse.feature.feature.group 2.5.2.xx-20110724-1000-e37)
    To: org.codehaus.groovy.jdt.patch.feature.group [2.1.3.xx-20110724-1000-e37]

PS: Using STS 2.7.1 (original install 2.5.1, upgraded to 2.7.1)

On Sun, Jul 24, 2011 at 3:09 PM, Andrew Eisenberg <[hidden email]> wrote:
Hi Octavian,

Please make sure that you are running the latest dev build of
Groovy-Eclipse.  You should use this dev update site of
Groovy-Eclipse:

http://dist.codehaus.org/groovy/distributions/greclipse/snapshot/e3.7

Add it in the update manager (Help -> Install new software...).  This
issue is believed fixed in the latest dev build.

On Thu, Jul 21, 2011 at 9:51 PM, Octavian Covalschi
<[hidden email]> wrote:
> Sorry for late response.
>
> Looks like I have Groovy-Eclipse of version: 2.5.1.xx-20110627-1300-e36
>
> I had 2.5.1 installed an upgraded to 2.7.0 and then 2.7.1.. whenever it says
> it has something to update...
>
> On Tue, Jul 19, 2011 at 11:42 PM, Andy Clement <[hidden email]>
> wrote:
>>
>> Hi,
>>
>> Can you confirm what version of Groovy-Eclipse you have installed?  If
>> you took the upgrade route from an old STS to a new one you may have
>> missed out on some important fixes in recent groovy-eclipse builds.
>> I'd recommend the 2.5.1 release for either Eclipse 3.6:
>> http://dist.springsource.org/release/GRECLIPSE/e3.6/
>>
>> or 3.7:
>> http://dist.springsource.org/release/GRECLIPSE/e3.7/
>>
>> (not sure which you are using, I presume an Eclipse 3.6 based STS if
>> you have been upgrading).
>>
>> If that doesn't address it, I'd recommend raising a jira:
>> https://issuetracker.springsource.com/browse/STS (it may be a
>> groovy-eclipse issue but as you are in a grails project, we should
>> perhaps investigate it via an STS jira).
>>
>> cheers
>> Andy
>>
>> On 19 July 2011 20:43, Octavian Covalschi <[hidden email]>
>> wrote:
>> > Has anyone seen this message before? This is something new for me... and
>> > I
>> > can't figure out a good workaround to get rid of it. If I'll do grails
>> > clean
>> > and/or project cleanup (from the toolbar) it may go away.. but not
>> > always.
>> >
>> > I have recently upgraded STS to 2.7.1 so perhaps that's the reason?
>> >
>>
>> ---------------------------------------------------------------------
>> To unsubscribe from this list, please visit:
>>
>>    http://xircles.codehaus.org/manage_email
>>
>>
>
>

---------------------------------------------------------------------
To unsubscribe from this list, please visit:

   http://xircles.codehaus.org/manage_email