Quantcast

Is withTransaction timing out

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Is withTransaction timing out

asachdeva

Hi,

We have multiple Oracle databases in our environment, recently on one of the databases we are getting the following error.

ORA-02050: transaction 30.46.333472 rolled back, some remote DBs may be in-doubt ORA-02051: another session or branch in same transaction failed or finalized

 

It happens that database is slowest of all and transaction takes more than 2 minutes to finish. Is it that my transaction is timing out? How can I print the transaction timeout or set the timeout to 10 minutes.

 

I tried the following,

DomainClass.withTransaction([timeout:1200]) { dbt->

}

But I got the same error with above transaction as well.

 

I am using grails 2.4.4 with Oracle 11g.

 

Regards

Arvind Sachdeva.

 

 

--
You received this message because you are subscribed to the Google Groups "Grails Dev Discuss" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/grails-dev-discuss/SIXPR0199MB0603037D8C206751D5B62CF7C6010%40SIXPR0199MB0603.apcprd01.prod.exchangelabs.com.
For more options, visit https://groups.google.com/d/optout.
Loading...