Quantcast

Jars corrupted in STS update site

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Jars corrupted in STS update site

barnesjd
Hi, I'm new to Groovy, Grails, and Spring but I have years of J2EE experience.  I'm unable to set up STS with Grails support, and it appears that the issue is the STS update site contains corrupt jars.  I had originally been trouble shooting this issue in a springsource forum thread, and I learned that I can download a copy of the update site here.  I opened it up to discover that both the artifacts.jar and contents.jar were corrupted.

Is there any other way I can get the Grails software installed into STS?  It will help this newbie tremendously!

Thanks,
Joe

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Jars corrupted in STS update site

Andrew Eisenberg-2
As far as I can tell, neither the update site nor the jar file since I
am able to perform the install myself.

Looking at your forum post, it seems like you might be behind a
firewall or have not set your proxies properly.  If you are on
windows, you may have to disable antivirus software.

On Sat, Feb 18, 2012 at 8:17 AM, barnesjd <[hidden email]> wrote:

> Hi, I'm new to Groovy, Grails, and Spring but I have years of J2EE
> experience.  I'm unable to set up STS with Grails support, and it appears
> that the issue is the STS update site contains corrupt jars.  I had
> originally been trouble shooting this issue in a
> http://forum.springsource.org/showthread.php?121835-Cannot-download-extensions
> springsource forum thread , and I learned that I can download a copy of the
> update site
> http://download.springsource.com/release/TOOLS/update/2.8.1.RELEASE/e3.7/springsource-tool-suite-2.8.1.RELEASE-e3.7.1-updatesite.zip
> here .  I opened it up to discover that both the artifacts.jar and
> contents.jar were corrupted.
>
> Is there any other way I can get the Grails software installed into STS?  It
> will help this newbie tremendously!
>
> Thanks,
> Joe
>
>
>
> --
> View this message in context: http://grails.1312388.n4.nabble.com/Jars-corrupted-in-STS-update-site-tp4399978p4399978.html
> Sent from the Grails - user mailing list archive at Nabble.com.
>
> ---------------------------------------------------------------------
> To unsubscribe from this list, please visit:
>
>    http://xircles.codehaus.org/manage_email
>
>

---------------------------------------------------------------------
To unsubscribe from this list, please visit:

    http://xircles.codehaus.org/manage_email


Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Jars corrupted in STS update site

barnesjd
It turned out that the jars were not corrupted.  I thought that I was opening them with 7-zip, but it was actually jar.exe trying to execute the jar.  So facepalm for me.  

Martin on the other forum helped me get all of the dependent plugins set up as local update sites.  I am FINALLY up and running!
Loading...