Quantcast

Not able to create hello world program using Grails 3.1.3 or Grails 2.5.4

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Not able to create hello world program using Grails 3.1.3 or Grails 2.5.4

dilipklv
This post has NOT been accepted by the mailing list yet.
Hi,

My project is based on Grails 2.2.2. Now I need to upgrade to Grails 2.5.4 in order to upgrade Groovy version 2.4.4

Hence, I downloaded Grails 2.5.4 and set up the Grails Home in environment variable and bin folder in class path.

From command line I can see grails -version is Grails 2.5.4

Next, I created grails create-app helloworld. It got created successfully.

Did cd into helloworld project and tried to run grails run-app.

after this, on command line I can see Configuring classpath for around 10-15 mins and ultimately I get error that tomcat:7.0.55.3 not found.
In grails 2.5.4 directory I see tomcat version 7.0.55.2 so in BuildConfig.groovy I changed tomcat to version 7.0.55.2 . and again ran grails run-app this time plugin got installed.

Next I got error for
    ':cache:1.1.8'      
   ":asset-pipeline:2.5.7"

I am surprised that these are there in plugins folder for Grails 2.5.4 but still it complains.

I added maven repo to
mavenRepo "http://repo.grails.org/grails/plugins"
mavenRepo "http://repo.grails.org/grails/core"
mavenRepo "http://repo1.maven.org/maven2"

But this did not worked.

I copied this manually and ran run-app again then I got error for dependencies related to cache and asset-pipeline.

I commented out this and did run-app .
Next I got error that catalina libraries not found. Then I copied libraries related to tomcat but still not able to run hello world project. I got error Spring parserContext class not found.

Earlier, when I was working on Grails 2.2.2 I did not had such problems and was able to create and run helloworld project within no time.

Now with Grails 2.5.4 and Grails 3.1.3 I am really frustrated.
I even tried Grails 2.4.4 and Grails 3.0.3.

Can any one guide me as to how I can create and run helloworld grails project with Grails version 2.5.4 or Grails 3.1.3 .
I am also ready to try with older Grails version which has Groovy 2.4.4.




Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Not able to create hello world program using Grails 3.1.3 or Grails 2.5.4

dilipklv
This post has NOT been accepted by the mailing list yet.
Added Proxy settings and it worked.
Loading...