Problem with app-info plugin and Grails 2.3.x

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

Problem with app-info plugin and Grails 2.3.x

rittinger
This post was updated on .
I have two eclipse environments.  One with Grails 2.2.4 the other with Grails 2.3.5.  Both are using the app-info plugin (1.0.3).  In Grails 2.2.4 everything works, Grails 2.3.5 I get 404 errors on every "admin/manage" URL.

I believe the problem lies within the DynamicController plugin.  Again using my two work spaces I created a simple example following the documentation for the plugin: http://grails.org/plugin/dynamic-controller

Works in 2.2.4, 404 errors for 2.3.5

Does anyone have a fix?  I use the app-info plugin to provide my "application state" page for a production app and unless this is resolved (quickly), I'll have to remove it (as the app is migrated to grails 2.3.5).

PS> Same error with Grails 2.3.7
Reply | Threaded
Open this post in threaded view
|

Re: Problem with app-info plugin and Grails 2.3.x

rittinger
ahh come on, surely someone else has tried to use the dynamic-controller or app-info plugin with grails 2.3.x?  
Reply | Threaded
Open this post in threaded view
|

Re: Problem with app-info plugin and Grails 2.3.x

burtbeckwith
I think I might have it fixed, but I need to do a little more testing. I should have an update out tonight.

Burt

rittinger wrote
ahh come on, surely someone else has tried to use the dynamic-controller or app-info plugin with grails 2.3.x?
Reply | Threaded
Open this post in threaded view
|

Re: Problem with app-info plugin and Grails 2.3.x

burtbeckwith
Ok, v1.1 of app-info and v0.4 of app-info-hibernate are now available and work with 2.3.

Burt

burtbeckwith wrote
I think I might have it fixed, but I need to do a little more testing. I should have an update out tonight.

Burt

rittinger wrote
ahh come on, surely someone else has tried to use the dynamic-controller or app-info plugin with grails 2.3.x?