Release a plugin as beta? grails iui plugin

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Release a plugin as beta? grails iui plugin

Sean Gilligan-2
I've updated the grails iUI plugin to use the latest version of iUI and
tested it briefly with Grails version 1.1.1 (I also bumped to required
version of Grails to 1.1.1, partly because of the limited testing.)

Although, the changes are minor, I'm very new to Grails plugin
development and may have made some stupid mistake or missed some change
required by newer version of Grails.

Is there a way to release a plugin as beta, to allow for some testing by
others before making a final release?  Any advice or suggestions would
be greatly appreciated.

Thanks,

Sean


---------------------------------------------------------------------
To unsubscribe from this list, please visit:

    http://xircles.codehaus.org/manage_email


Reply | Threaded
Open this post in threaded view
|

Re: Release a plugin as beta? grails iui plugin

Graeme Rocher-3
grails release-plugin --snapshot

To install the end user has explicitly specify the version

Cheers

On Sun, Sep 27, 2009 at 10:04 PM, Sean Gilligan <[hidden email]> wrote:

> I've updated the grails iUI plugin to use the latest version of iUI and
> tested it briefly with Grails version 1.1.1 (I also bumped to required
> version of Grails to 1.1.1, partly because of the limited testing.)
>
> Although, the changes are minor, I'm very new to Grails plugin development
> and may have made some stupid mistake or missed some change required by
> newer version of Grails.
>
> Is there a way to release a plugin as beta, to allow for some testing by
> others before making a final release?  Any advice or suggestions would be
> greatly appreciated.
>
> Thanks,
>
> Sean
>
>
> ---------------------------------------------------------------------
> To unsubscribe from this list, please visit:
>
>   http://xircles.codehaus.org/manage_email
>
>
>



--
Graeme Rocher
Head of Grails Development
SpringSource - Weapons for the War on Java Complexity
http://www.springsource.com

---------------------------------------------------------------------
To unsubscribe from this list, please visit:

    http://xircles.codehaus.org/manage_email


Reply | Threaded
Open this post in threaded view
|

Re: Release a plugin as beta? grails iui plugin

Sean Gilligan-2
Graeme Rocher wrote:
grails release-plugin --snapshot

To install the end user has explicitly specify the version
  
Thanks!

I gave it a try and got the error output shown below.
I'm on Mac OS X 10.5.8 with Java version "1.5.0_20" and Grails 1.1.1
I just installed Subversion version 1.6.5 using the CollabNet package.

Everything is checked in already, and SVN seems to be working fine.

Feel free to check out the iUI plugin and try 'grails release-plugin --snapshot' yourself.

Perhaps the problem is because I have upgraded a fairly old plugin to grails 1.1.1?

-- Sean

Command output with error message:
--------------------------------------------------------------------------
grails release-plugin --snapshot
Welcome to Grails 1.1.1 - http://grails.org/
Licensed under Apache Standard License 2.0
Grails home is set to: /usr/local/grails

Base Directory: /Users/sean/netsvn/grails-iui-plugin-trunk
Running script /usr/local/grails/scripts/ReleasePlugin.groovy
Environment set to development
   [delete] Deleting: /Users/sean/netsvn/grails-iui-plugin-trunk/grails-iui-0.3-SNAPSHOT.zip
      [zip] Building zip: /Users/sean/netsvn/grails-iui-plugin-trunk/grails-iui-0.3-SNAPSHOT.zip
[groovydoc] /Users/sean/netsvn/grails-iui-plugin-trunk contains source files in the default package, you must specify them as source files not packages.
Loading source files for [/IuiGrailsPlugin.groovy, scripts/_Install.groovy, scripts/_Upgrade.groovy, test/integration/IUIJavascriptTagTests.groovy]
Generating /Users/sean/netsvn/grails-iui-plugin-trunk/docs/gapi/index.html
Generating /Users/sean/netsvn/grails-iui-plugin-trunk/docs/gapi/overview-frame.html
Generating /Users/sean/netsvn/grails-iui-plugin-trunk/docs/gapi/allclasses-frame.html
Generating /Users/sean/netsvn/grails-iui-plugin-trunk/docs/gapi/overview-summary.html
Generating /Users/sean/netsvn/grails-iui-plugin-trunk/docs/gapi/help-doc.html
Generating /Users/sean/netsvn/grails-iui-plugin-trunk/docs/gapi/index-all.html
Generating /Users/sean/netsvn/grails-iui-plugin-trunk/docs/gapi/deprecated-list.html
Generating /Users/sean/netsvn/grails-iui-plugin-trunk/docs/gapi/stylesheet.css
Generating /Users/sean/netsvn/grails-iui-plugin-trunk/docs/gapi/inherit.gif
Generating /Users/sean/netsvn/grails-iui-plugin-trunk/docs/gapi/groovy.ico
Generating /Users/sean/netsvn/grails-iui-plugin-trunk/docs/gapi/DefaultPackage/package-frame.html
Generating /Users/sean/netsvn/grails-iui-plugin-trunk/docs/gapi/DefaultPackage/package-summary.html
Generating /Users/sean/netsvn/grails-iui-plugin-trunk/docs/gapi/scripts/package-frame.html
Generating /Users/sean/netsvn/grails-iui-plugin-trunk/docs/gapi/scripts/package-summary.html
Generating /Users/sean/netsvn/grails-iui-plugin-trunk/docs/gapi/test/integration/package-frame.html
Generating /Users/sean/netsvn/grails-iui-plugin-trunk/docs/gapi/test/integration/package-summary.html
Generating /Users/sean/netsvn/grails-iui-plugin-trunk/docs/gapi/package-list
Generating /Users/sean/netsvn/grails-iui-plugin-trunk/docs/gapi/test/integration/IUIJavascriptTagTests.html
Generating /Users/sean/netsvn/grails-iui-plugin-trunk/docs/gapi/DefaultPackage/IuiGrailsPlugin.html
Generating /Users/sean/netsvn/grails-iui-plugin-trunk/docs/gapi/scripts/_Install.html
Generating /Users/sean/netsvn/grails-iui-plugin-trunk/docs/gapi/scripts/_Upgrade.html

The current directory is not a working copy and your latest changes won't be committed. You need to checkout
a working copy and make your changes there. Alternatively, do you want to proceed and create a release from what is in SVN now?
                     (y, n)
y
Preparing to publish the release...
Enter a SVN commit message:
0.30-SNAPSHOT release-plugin
org.tmatesoft.svn.core.SVNException: svn: Path '.' ends in '.', which is unsupported for this operation
    at org.tmatesoft.svn.core.internal.wc.SVNErrorManager.error(SVNErrorManager.java:64)
    at org.tmatesoft.svn.core.internal.wc.SVNErrorManager.error(SVNErrorManager.java:51)
    at org.tmatesoft.svn.core.internal.wc.admin.SVNWCAccess.probe(SVNWCAccess.java:692)
    at org.tmatesoft.svn.core.internal.wc.admin.SVNWCAccess.probeOpen(SVNWCAccess.java:279)
    at org.tmatesoft.svn.core.internal.wc.admin.SVNWCAccess.probeOpen(SVNWCAccess.java:275)
    at org.tmatesoft.svn.core.wc.SVNWCClient.crawlEntries(SVNWCClient.java:2904)
    at org.tmatesoft.svn.core.wc.SVNWCClient.doInfo(SVNWCClient.java:2148)
    at org.tmatesoft.svn.core.wc.SVNWCClient.doInfo(SVNWCClient.java:2524)
    at ReleasePlugin$_run_closure8.doCall(ReleasePlugin.groovy:338)
    at ReleasePlugin$_run_closure3.doCall(ReleasePlugin.groovy:131)
    at ReleasePlugin$_run_closure1.doCall(ReleasePlugin.groovy:42)
    at gant.Gant$_dispatch_closure4.doCall(Gant.groovy:324)
    at gant.Gant$_dispatch_closure6.doCall(Gant.groovy:334)
    at gant.Gant$_dispatch_closure6.doCall(Gant.groovy)
    at gant.Gant.withBuildListeners(Gant.groovy:344)
    at gant.Gant.this$2$withBuildListeners(Gant.groovy)
    at gant.Gant$this$2$withBuildListeners.callCurrent(Unknown Source)
    at gant.Gant.dispatch(Gant.groovy:334)
    at gant.Gant.this$2$dispatch(Gant.groovy)
    at gant.Gant.invokeMethod(Gant.groovy)
    at gant.Gant.processTargets(Gant.groovy:495)
    at gant.Gant.processTargets(Gant.groovy:480)
Error occurred with release-plugin: svn: Path '.' ends in '.', which is unsupported for this operation



Cheers

On Sun, Sep 27, 2009 at 10:04 PM, Sean Gilligan [hidden email] wrote:
  
I've updated the grails iUI plugin to use the latest version of iUI and
tested it briefly with Grails version 1.1.1 (I also bumped to required
version of Grails to 1.1.1, partly because of the limited testing.)

Although, the changes are minor, I'm very new to Grails plugin development
and may have made some stupid mistake or missed some change required by
newer version of Grails.

Is there a way to release a plugin as beta, to allow for some testing by
others before making a final release?  Any advice or suggestions would be
greatly appreciated.

Thanks,

Sean


---------------------------------------------------------------------
To unsubscribe from this list, please visit:

  http://xircles.codehaus.org/manage_email