Update Export plugin for my project

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

Update Export plugin for my project

stephing
Hello,
I'm new in Grails and I don't know how to update the Export plugin.
In my project I need the export some data in excel, for that I used the export plugin. To have the excel file in the right format I must make a little change in a class of the export plugin (DefaultExcelExporter) and it works fine.
 
But now I think I have to increase the version of the plugin and rebuild it to use it with the change I made, is it right? If yes, how can I do that? Do I have to fork it from git repository? or just download the code?
I'm a little lost, some help would be great ;-)

Thanks

St├ęphanie
Reply | Threaded
Open this post in threaded view
|

Re: Update Export plugin for my project

Graeme Rocher-2
Fork the plugin, the sources are here https://github.com/gpc/grails-export

You can install your version locally with 'grails maven-install' or
setup an artefactory instance, see
http://wordpress.transentia.com.au/wordpress/2014/04/09/artifactory-and-grails/

On Wed, Jun 11, 2014 at 4:27 PM, stephing <[hidden email]> wrote:

> Hello,
> I'm new in Grails and I don't know how to update the Export plugin.
> In my project I need the export some data in excel, for that I used the
> export plugin. To have the excel file in the right format I must make a
> little change in a class of the export plugin (DefaultExcelExporter) and it
> works fine.
>
> But now I think I have to increase the version of the plugin and rebuild it
> to use it with the change I made, is it right? If yes, how can I do that? Do
> I have to fork it from git repository? or just download the code?
> I'm a little lost, some help would be great ;-)
>
> Thanks
>
> St├ęphanie
>
>
>
> --
> View this message in context: http://grails.1312388.n4.nabble.com/Update-Export-plugin-for-my-project-tp4657101.html
> Sent from the Grails - dev mailing list archive at Nabble.com.
>
> ---------------------------------------------------------------------
> To unsubscribe from this list, please visit:
>
>     http://xircles.codehaus.org/manage_email
>
>



--
Graeme Rocher
Grails Project Lead
SpringSource

---------------------------------------------------------------------
To unsubscribe from this list, please visit:

    http://xircles.codehaus.org/manage_email


Reply | Threaded
Open this post in threaded view
|

Re: Update Export plugin for my project

stephing
Thank you, but now I have a problem of dependencies.
So I fork the plugin, git clone the repo, import it on Groovy/Grails Tool suite, made the change needed and made the grails maven-install. It create a grails-export-1.7-SNAPSHOT.zip and a pom.xml file in my grails-export repository.
After that, I change the version of the plugin (from ":export:1.5" to ":export:1.7-SNAPSHOT") in the BuildConfig.groovy of my app and try to compile my app with grails compile but I have the following error

| Error Resolve error obtaining dependencies: Could not find artifact org.odftoolkit:odfdom-java:jar:0.8.5 in grailsCentral (http://repo.grails.org/grails/plugins) (Use --stacktrace to see the full trace)

Did I do something wrong? Do you know why I have this error?
Reply | Threaded
Open this post in threaded view
|

Re: Update Export plugin for my project

stephing
I found a workaround here : https://jira.grails.org/browse/GPEXPORT-28
I just add the following lines in the BuildConfig.groovy =>
repositories {
   ...
   mavenRepo "http://repo.grails.org/grails/core"
}

dependencies {
   ...
   compile 'commons-beanutils:commons-beanutils:1.8.3'
}

and it works :-)