Upgrade from MongoDB plugin 1.3.0 to 1.3.1 compile error

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

Upgrade from MongoDB plugin 1.3.0 to 1.3.1 compile error

netwiser
I have Grails 2.2.4 with Spring security 1.2.7.3 and mongo DB plugin 1.3.0, I tried to upgrade MongoDB1.3.1 but is experiencing this error:

| Installed plugin mongodb-1.3.1.....
| Error Fatal error during compilation org.springframework.beans.factory.BeanDefinitionStoreException: Failed to read candidate component class: URL [jar:file:/home/netwiser/.grails/ivy-cache/org.grails/grails-hibernate/jars/grails-hibernate-2.2.4.jar!/org/codehaus/groovy/grails/compiler/gorm/GormTransformer.class]; nested exception is java.lang.NoClassDefFoundError: org/springframework/core/type/classreading/AnnotationMetadataReadingVisitor (Use --stacktrace to see the full trace)

I did remove the ivy-cache folder, and try to upgrade the spring security to 2.0-RC2 but no luck. If I switch back to MongoDB1.3.0 then anything is fine. 

PS. I don't have hibernate plugin installed. 

Regards,

James
Reply | Threaded
Open this post in threaded view
|

Re: Upgrade from MongoDB plugin 1.3.0 to 1.3.1 compile error

Graeme Rocher-2
Hmm, seems a compatibility issue between datastore core and Spring in 2.2.4, please raise a JIRA

Thanks


On Thu, Nov 14, 2013 at 3:32 AM, James Zhang <[hidden email]> wrote:
I have Grails 2.2.4 with Spring security 1.2.7.3 and mongo DB plugin 1.3.0, I tried to upgrade MongoDB1.3.1 but is experiencing this error:

| Installed plugin mongodb-1.3.1.....
| Error Fatal error during compilation org.springframework.beans.factory.BeanDefinitionStoreException: Failed to read candidate component class: URL [jar:file:/home/netwiser/.grails/ivy-cache/org.grails/grails-hibernate/jars/grails-hibernate-2.2.4.jar!/org/codehaus/groovy/grails/compiler/gorm/GormTransformer.class]; nested exception is java.lang.NoClassDefFoundError: org/springframework/core/type/classreading/AnnotationMetadataReadingVisitor (Use --stacktrace to see the full trace)

I did remove the ivy-cache folder, and try to upgrade the spring security to 2.0-RC2 but no luck. If I switch back to MongoDB1.3.0 then anything is fine. 

PS. I don't have hibernate plugin installed. 

Regards,

James



--
Graeme Rocher
Grails Project Lead
SpringSource
Reply | Threaded
Open this post in threaded view
|

Re: Upgrade from MongoDB plugin 1.3.0 to 1.3.1 compile error

will.woodman
In reply to this post by netwiser
getting the same problem with the Neoj plugin also

i have GGTS 2.4 - tried to create neo4j plugin and fails with

| Error Fatal error during compilation org.springframework.beans.factory.BeanDefinitionStoreException: Failed to read candidate component class: URL [jar:file:/C:/Users/802518659/.grails/ivy-cache/org.grails/grails-hibernate/jars/grails-hibernate-2.2.4.jar!/org/codehaus/groovy/grails/compiler/gorm/GormTransformer.class]; nested exception is java.lang.NoClassDefFoundError: org/springframework/core/type/classreading/AnnotationMetadataReadingVisitor


i removed the entry from ivy cache - no soap.  

i tried i fresh install fro 2.2.3 to 2.2.4 - that doesnt work either

bad news

Reply | Threaded
Open this post in threaded view
|

Re: Upgrade from MongoDB plugin 1.3.0 to 1.3.1 compile error

Graeme Rocher-2
Upgrading to 2.3.5 is not an option?

Cheers

On Thu, Jan 30, 2014 at 8:52 PM, will.woodman
<[hidden email]> wrote:

> getting the same problem with the Neoj plugin also
>
> i have GGTS 2.4 - tried to create neo4j plugin and fails with
>
> | Error Fatal error during compilation
> org.springframework.beans.factory.BeanDefinitionStoreException: Failed to
> read candidate component class: URL
> [jar:file:/C:/Users/802518659/.grails/ivy-cache/org.grails/grails-hibernate/jars/grails-hibernate-2.2.4.jar!/org/codehaus/groovy/grails/compiler/gorm/GormTransformer.class];
> nested exception is java.lang.NoClassDefFoundError:
> org/springframework/core/type/classreading/AnnotationMetadataReadingVisitor
>
>
> i removed the entry from ivy cache - no soap.
>
> i tried i fresh install fro 2.2.3 to 2.2.4 - that doesnt work either
>
> bad news
>
>
>
>
>
> --
> View this message in context: http://grails.1312388.n4.nabble.com/Upgrade-from-MongoDB-plugin-1-3-0-to-1-3-1-compile-error-tp4651482p4653746.html
> Sent from the Grails - user mailing list archive at Nabble.com.
>
> ---------------------------------------------------------------------
> To unsubscribe from this list, please visit:
>
>     http://xircles.codehaus.org/manage_email
>
>



--
Graeme Rocher
Grails Project Lead
SpringSource

---------------------------------------------------------------------
To unsubscribe from this list, please visit:

    http://xircles.codehaus.org/manage_email