Why Grails 2.5.0 loads two versions of grails-datastore-core?

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

Why Grails 2.5.0 loads two versions of grails-datastore-core?

sergiomichels
I'm getting the follow exception when running my unit tests:

java.lang.NoClassDefFoundError: org/grails/datastore/mapping/query/api/BuildableCriteria

Looking at the classpath configuration I can see two grails-datastore-core jars loaded:

|Downloading: org/grails/plugins/tomcat/7.0.52.1/tomcat-7.0.52.1.pom
|Downloading: org/grails/plugins/tomcat/7.0.52.1/tomcat-7.0.52.1.zip
|Downloading: org/grails/grails-datastore-core/3.1.4.RELEASE/grails-datastore-core-3.1.4.RELEASE.pom
|Downloading: org/grails/grails-datastore-gorm/3.1.4.RELEASE/grails-datastore-gorm-3.1.4.RELEASE.pom
|Downloading: org/grails/grails-datastore-simple/3.1.4.RELEASE/grails-datastore-simple-3.1.4.RELEASE.pom
|Downloading: org/grails/plugins/scaffolding/2.1.0/scaffolding-2.1.0.pom
|Downloading: org/grails/plugins/asset-pipeline/1.9.9/asset-pipeline-1.9.9.pom
|Downloading: org/grails/plugins/webxml/1.4.1/webxml-1.4.1.pom
|Downloading: org/grails/plugins/build-info/1.2.8/build-info-1.2.8.pom
|Downloading: org/grails/plugins/uploadr/1.1.1/uploadr-1.1.1.pom
|Downloading: org/grails/plugins/sass-asset-pipeline/1.9.0/sass-asset-pipeline-1.9.0.pom
|Downloading: org/grails/plugins/asset-pipeline/1.9.2/asset-pipeline-1.9.2.pom
|Downloading: org/grails/plugins/cache-ehcache/1.0.5/cache-ehcache-1.0.5.pom
|Downloading: org/grails/plugins/cache/1.1.8/cache-1.1.8.pom
|Downloading: org/grails/plugins/hibernate/3.6.10.14/hibernate-3.6.10.14.pom
|Downloading: org/grails/grails-datastore-core/3.1.0.RELEASE/grails-datastore-core-3.1.0.RELEASE.pom
|Downloading: org/grails/grails-datastore-gorm/3.1.0.RELEASE/grails-datastore-gorm-3.1.0.RELEASE.pom

Is there a way to solve it in my local installation?

--
Sérgio Michels

--
You received this message because you are subscribed to the Google Groups "Grails Dev Discuss" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/grails-dev-discuss/CAHTf1NUdqDFd1fH4H%2BoMCuz_6jdiT-Q-hW9QnCqTTfz_Vib34w%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

Re: Why Grails 2.5.0 loads two versions of grails-datastore-core?

sergiomichels
No one having problems with unit tests in this version?

--
Sérgio Michels

On Thu, May 14, 2015 at 9:15 PM, Sergio Michels <[hidden email]> wrote:
I'm getting the follow exception when running my unit tests:

java.lang.NoClassDefFoundError: org/grails/datastore/mapping/query/api/BuildableCriteria

Looking at the classpath configuration I can see two grails-datastore-core jars loaded:

|Downloading: org/grails/plugins/tomcat/7.0.52.1/tomcat-7.0.52.1.pom
|Downloading: org/grails/plugins/tomcat/7.0.52.1/tomcat-7.0.52.1.zip
|Downloading: org/grails/grails-datastore-core/3.1.4.RELEASE/grails-datastore-core-3.1.4.RELEASE.pom
|Downloading: org/grails/grails-datastore-gorm/3.1.4.RELEASE/grails-datastore-gorm-3.1.4.RELEASE.pom
|Downloading: org/grails/grails-datastore-simple/3.1.4.RELEASE/grails-datastore-simple-3.1.4.RELEASE.pom
|Downloading: org/grails/plugins/scaffolding/2.1.0/scaffolding-2.1.0.pom
|Downloading: org/grails/plugins/asset-pipeline/1.9.9/asset-pipeline-1.9.9.pom
|Downloading: org/grails/plugins/webxml/1.4.1/webxml-1.4.1.pom
|Downloading: org/grails/plugins/build-info/1.2.8/build-info-1.2.8.pom
|Downloading: org/grails/plugins/uploadr/1.1.1/uploadr-1.1.1.pom
|Downloading: org/grails/plugins/sass-asset-pipeline/1.9.0/sass-asset-pipeline-1.9.0.pom
|Downloading: org/grails/plugins/asset-pipeline/1.9.2/asset-pipeline-1.9.2.pom
|Downloading: org/grails/plugins/cache-ehcache/1.0.5/cache-ehcache-1.0.5.pom
|Downloading: org/grails/plugins/cache/1.1.8/cache-1.1.8.pom
|Downloading: org/grails/plugins/hibernate/3.6.10.14/hibernate-3.6.10.14.pom
|Downloading: org/grails/grails-datastore-core/3.1.0.RELEASE/grails-datastore-core-3.1.0.RELEASE.pom
|Downloading: org/grails/grails-datastore-gorm/3.1.0.RELEASE/grails-datastore-gorm-3.1.0.RELEASE.pom

Is there a way to solve it in my local installation?

--
Sérgio Michels

--
You received this message because you are subscribed to the Google Groups "Grails Dev Discuss" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/grails-dev-discuss/CAHTf1NWfwwNonbQPPF_G6j-_DMwmrAUiY5oKNg8R2MT5CFz%3Dkw%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

Re: Why Grails 2.5.0 loads two versions of grails-datastore-core?

sergiomichels
So, I tried a fresh new app and the problem not happens, seems something specific to this application. Since it's an upgrade I think that my BuildConfig.groovy may be wrong.

--
Sérgio Michels

On Mon, May 25, 2015 at 4:18 PM, Sergio Michels <[hidden email]> wrote:
No one having problems with unit tests in this version?

--
Sérgio Michels

On Thu, May 14, 2015 at 9:15 PM, Sergio Michels <[hidden email]> wrote:
I'm getting the follow exception when running my unit tests:

java.lang.NoClassDefFoundError: org/grails/datastore/mapping/query/api/BuildableCriteria

Looking at the classpath configuration I can see two grails-datastore-core jars loaded:

|Downloading: org/grails/plugins/tomcat/7.0.52.1/tomcat-7.0.52.1.pom
|Downloading: org/grails/plugins/tomcat/7.0.52.1/tomcat-7.0.52.1.zip
|Downloading: org/grails/grails-datastore-core/3.1.4.RELEASE/grails-datastore-core-3.1.4.RELEASE.pom
|Downloading: org/grails/grails-datastore-gorm/3.1.4.RELEASE/grails-datastore-gorm-3.1.4.RELEASE.pom
|Downloading: org/grails/grails-datastore-simple/3.1.4.RELEASE/grails-datastore-simple-3.1.4.RELEASE.pom
|Downloading: org/grails/plugins/scaffolding/2.1.0/scaffolding-2.1.0.pom
|Downloading: org/grails/plugins/asset-pipeline/1.9.9/asset-pipeline-1.9.9.pom
|Downloading: org/grails/plugins/webxml/1.4.1/webxml-1.4.1.pom
|Downloading: org/grails/plugins/build-info/1.2.8/build-info-1.2.8.pom
|Downloading: org/grails/plugins/uploadr/1.1.1/uploadr-1.1.1.pom
|Downloading: org/grails/plugins/sass-asset-pipeline/1.9.0/sass-asset-pipeline-1.9.0.pom
|Downloading: org/grails/plugins/asset-pipeline/1.9.2/asset-pipeline-1.9.2.pom
|Downloading: org/grails/plugins/cache-ehcache/1.0.5/cache-ehcache-1.0.5.pom
|Downloading: org/grails/plugins/cache/1.1.8/cache-1.1.8.pom
|Downloading: org/grails/plugins/hibernate/3.6.10.14/hibernate-3.6.10.14.pom
|Downloading: org/grails/grails-datastore-core/3.1.0.RELEASE/grails-datastore-core-3.1.0.RELEASE.pom
|Downloading: org/grails/grails-datastore-gorm/3.1.0.RELEASE/grails-datastore-gorm-3.1.0.RELEASE.pom

Is there a way to solve it in my local installation?

--
Sérgio Michels


--
You received this message because you are subscribed to the Google Groups "Grails Dev Discuss" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/grails-dev-discuss/CAHTf1NVOAkk_aXdFZ0J2RK7f-D-z%3D5P_B61ErUxMQrUa9nBx5Q%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

Re: Why Grails 2.5.0 loads two versions of grails-datastore-core?

Graeme Rocher-2
Probably a plugin that depends on an older version

On Wed, Jun 3, 2015 at 11:59 PM, Sergio Michels
<[hidden email]> wrote:

> So, I tried a fresh new app and the problem not happens, seems something
> specific to this application. Since it's an upgrade I think that my
> BuildConfig.groovy may be wrong.
>
> --
> Sérgio Michels
>
> On Mon, May 25, 2015 at 4:18 PM, Sergio Michels <[hidden email]>
> wrote:
>>
>> No one having problems with unit tests in this version?
>>
>> --
>> Sérgio Michels
>>
>> On Thu, May 14, 2015 at 9:15 PM, Sergio Michels <[hidden email]>
>> wrote:
>>>
>>> I'm getting the follow exception when running my unit tests:
>>>
>>> java.lang.NoClassDefFoundError:
>>> org/grails/datastore/mapping/query/api/BuildableCriteria
>>>
>>> Looking at the classpath configuration I can see two
>>> grails-datastore-core jars loaded:
>>>
>>> |Downloading: org/grails/plugins/tomcat/7.0.52.1/tomcat-7.0.52.1.pom
>>> |Downloading: org/grails/plugins/tomcat/7.0.52.1/tomcat-7.0.52.1.zip
>>> |Downloading:
>>> org/grails/grails-datastore-core/3.1.4.RELEASE/grails-datastore-core-3.1.4.RELEASE.pom
>>> |Downloading:
>>> org/grails/grails-datastore-gorm/3.1.4.RELEASE/grails-datastore-gorm-3.1.4.RELEASE.pom
>>> |Downloading:
>>> org/grails/grails-datastore-simple/3.1.4.RELEASE/grails-datastore-simple-3.1.4.RELEASE.pom
>>> |Downloading: org/grails/plugins/scaffolding/2.1.0/scaffolding-2.1.0.pom
>>> |Downloading:
>>> org/grails/plugins/asset-pipeline/1.9.9/asset-pipeline-1.9.9.pom
>>> |Downloading: org/grails/plugins/webxml/1.4.1/webxml-1.4.1.pom
>>> |Downloading: org/grails/plugins/build-info/1.2.8/build-info-1.2.8.pom
>>> |Downloading: org/grails/plugins/uploadr/1.1.1/uploadr-1.1.1.pom
>>> |Downloading:
>>> org/grails/plugins/sass-asset-pipeline/1.9.0/sass-asset-pipeline-1.9.0.pom
>>> |Downloading:
>>> org/grails/plugins/asset-pipeline/1.9.2/asset-pipeline-1.9.2.pom
>>> |Downloading:
>>> org/grails/plugins/cache-ehcache/1.0.5/cache-ehcache-1.0.5.pom
>>> |Downloading: org/grails/plugins/cache/1.1.8/cache-1.1.8.pom
>>> |Downloading:
>>> org/grails/plugins/hibernate/3.6.10.14/hibernate-3.6.10.14.pom
>>> |Downloading:
>>> org/grails/grails-datastore-core/3.1.0.RELEASE/grails-datastore-core-3.1.0.RELEASE.pom
>>> |Downloading:
>>> org/grails/grails-datastore-gorm/3.1.0.RELEASE/grails-datastore-gorm-3.1.0.RELEASE.pom
>>>
>>> Is there a way to solve it in my local installation?
>>>
>>> --
>>> Sérgio Michels
>>
>>
>
> --
> You received this message because you are subscribed to the Google Groups
> "Grails Dev Discuss" group.
> To unsubscribe from this group and stop receiving emails from it, send an
> email to [hidden email].
> To post to this group, send email to [hidden email].
> To view this discussion on the web visit
> https://groups.google.com/d/msgid/grails-dev-discuss/CAHTf1NVOAkk_aXdFZ0J2RK7f-D-z%3D5P_B61ErUxMQrUa9nBx5Q%40mail.gmail.com.
>
> For more options, visit https://groups.google.com/d/optout.



--
Graeme Rocher

--
You received this message because you are subscribed to the Google Groups "Grails Dev Discuss" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/grails-dev-discuss/CAO_wNofZpTRtCuoGxcvzdsBhM5ccktMr%2BnJszeBwDoasD9Wt0w%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.