can there be more than one 'latest' plugin version?

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

can there be more than one 'latest' plugin version?

Dierk König
Hiall,

with the WebTest Plugin we now have the situation that we have a  
latest version for the 0.x releases and a different one for the 1.x  
releases.
Is it possible to use the "depends" feature such that the user gets  
the correct version when typing

grails install-plugin webtest

regardless on whether he is on the 0.x or 1.x route?

cheers
Dierk

---------------------------------------------------------------------
To unsubscribe from this list, please visit:

    http://xircles.codehaus.org/manage_email


Reply | Threaded
Open this post in threaded view
|

Re: can there be more than one 'latest' plugin version?

Graeme Rocher-3
Not currently no, users of 0.6 will have to type

grails install-plugin webtest 0.6

Cheers

On Thu, Feb 26, 2009 at 1:00 PM, Dierk König <[hidden email]> wrote:

> Hiall,
>
> with the WebTest Plugin we now have the situation that we have a latest
> version for the 0.x releases and a different one for the 1.x releases.
> Is it possible to use the "depends" feature such that the user gets the
> correct version when typing
>
> grails install-plugin webtest
>
> regardless on whether he is on the 0.x or 1.x route?
>
> cheers
> Dierk
>
> ---------------------------------------------------------------------
> To unsubscribe from this list, please visit:
>
>   http://xircles.codehaus.org/manage_email
>
>
>



--
Graeme Rocher
Head of Grails Development
SpringSource - Weapons for the War on Java Complexity
http://www.springsource.com

---------------------------------------------------------------------
To unsubscribe from this list, please visit:

    http://xircles.codehaus.org/manage_email


Reply | Threaded
Open this post in threaded view
|

Re: can there be more than one 'latest' plugin version?

Dierk König
ok, thanks Graeme.

Would be a cool feature if install-plugin could find the latest plugin  
version that's "depends" property is compliant to the current core  
version...

ciao
Dierk

Am 26.02.2009 um 14:10 schrieb Graeme Rocher:

> Not currently no, users of 0.6 will have to type
>
> grails install-plugin webtest 0.6
>
> Cheers
>
> On Thu, Feb 26, 2009 at 1:00 PM, Dierk König  
> <[hidden email]> wrote:
>> Hiall,
>>
>> with the WebTest Plugin we now have the situation that we have a  
>> latest
>> version for the 0.x releases and a different one for the 1.x  
>> releases.
>> Is it possible to use the "depends" feature such that the user gets  
>> the
>> correct version when typing
>>
>> grails install-plugin webtest
>>
>> regardless on whether he is on the 0.x or 1.x route?
>>
>> cheers
>> Dierk
>>
>> ---------------------------------------------------------------------
>> To unsubscribe from this list, please visit:
>>
>>   http://xircles.codehaus.org/manage_email
>>
>>
>>
>
>
>
> --
> Graeme Rocher
> Head of Grails Development
> SpringSource - Weapons for the War on Java Complexity
> http://www.springsource.com
>
> ---------------------------------------------------------------------
> To unsubscribe from this list, please visit:
>
>    http://xircles.codehaus.org/manage_email
>
>


---------------------------------------------------------------------
To unsubscribe from this list, please visit:

    http://xircles.codehaus.org/manage_email


Reply | Threaded
Open this post in threaded view
|

Re: can there be more than one 'latest' plugin version?

Graeme Rocher-3
On Thu, Feb 26, 2009 at 1:18 PM, Dierk König <[hidden email]> wrote:
> ok, thanks Graeme.
>
> Would be a cool feature if install-plugin could find the latest plugin
> version that's "depends" property is compliant to the current core
> version...

Yes we'll look at it after 1.1

Cheers

>
> ciao
> Dierk
>
> Am 26.02.2009 um 14:10 schrieb Graeme Rocher:
>
>> Not currently no, users of 0.6 will have to type
>>
>> grails install-plugin webtest 0.6
>>
>> Cheers
>>
>> On Thu, Feb 26, 2009 at 1:00 PM, Dierk König <[hidden email]>
>> wrote:
>>>
>>> Hiall,
>>>
>>> with the WebTest Plugin we now have the situation that we have a latest
>>> version for the 0.x releases and a different one for the 1.x releases.
>>> Is it possible to use the "depends" feature such that the user gets the
>>> correct version when typing
>>>
>>> grails install-plugin webtest
>>>
>>> regardless on whether he is on the 0.x or 1.x route?
>>>
>>> cheers
>>> Dierk
>>>
>>> ---------------------------------------------------------------------
>>> To unsubscribe from this list, please visit:
>>>
>>>  http://xircles.codehaus.org/manage_email
>>>
>>>
>>>
>>
>>
>>
>> --
>> Graeme Rocher
>> Head of Grails Development
>> SpringSource - Weapons for the War on Java Complexity
>> http://www.springsource.com
>>
>> ---------------------------------------------------------------------
>> To unsubscribe from this list, please visit:
>>
>>   http://xircles.codehaus.org/manage_email
>>
>>
>
>
> ---------------------------------------------------------------------
> To unsubscribe from this list, please visit:
>
>   http://xircles.codehaus.org/manage_email
>
>
>



--
Graeme Rocher
Head of Grails Development
SpringSource - Weapons for the War on Java Complexity
http://www.springsource.com

---------------------------------------------------------------------
To unsubscribe from this list, please visit:

    http://xircles.codehaus.org/manage_email