grails 3.1.10 failed running: Could not find artifact org.grails:grails-bom:pom:3.1.10 in grailsCent

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

grails 3.1.10 failed running: Could not find artifact org.grails:grails-bom:pom:3.1.10 in grailsCent

Yingyuan Cheng
Hello everyone.

I installed grails 3.1.10 in my windows 10 laptop, but failed running. The error is:

| Error Error occurred running Grails CLI: Could not find artifact org.grails:grails-bom:pom:3.1.10 in grailsCentral (https://repo.grails.org/grails/core) (NOTE: Stack trace has been filtered. Use --verbose to see entire trace.)
org.eclipse.aether.transfer.ArtifactNotFoundException: Could not find artifact org.grails:grails-bom:pom:3.1.10 in grailsCentral (https://repo.grails.org/grails/core)
        at org.eclipse.aether.connector.basic.ArtifactTransportListener.transferFailed(ArtifactTransportListener.java:39)
        at org.eclipse.aether.connector.basic.BasicRepositoryConnector$TaskRunner.run(BasicRepositoryConnector.java:355)
        at org.eclipse.aether.util.concurrency.RunnableErrorForwarder$1.run(RunnableErrorForwarder.java:67)
        at org.eclipse.aether.connector.basic.BasicRepositoryConnector$DirectExecutor.execute(BasicRepositoryConnector.java:581)
        at org.eclipse.aether.connector.basic.BasicRepositoryConnector.get(BasicRepositoryConnector.java:249)
        at org.eclipse.aether.internal.impl.DefaultArtifactResolver.performDownloads(DefaultArtifactResolver.java:520)
        at org.eclipse.aether.internal.impl.DefaultArtifactResolver.resolve(DefaultArtifactResolver.java:421)
        at org.eclipse.aether.internal.impl.DefaultArtifactResolver.resolveArtifacts(DefaultArtifactResolver.java:246)
        at org.eclipse.aether.internal.impl.DefaultRepositorySystem.resolveDependencies(DefaultRepositorySystem.java:367)
        at org.springframework.boot.cli.compiler.grape.AetherGrapeEngine.resolve(AetherGrapeEngine.java:302)
        at org.springframework.boot.cli.compiler.grape.AetherGrapeEngine.resolve(AetherGrapeEngine.java:284)
        at org.springframework.boot.cli.compiler.grape.AetherGrapeEngine.resolve(AetherGrapeEngine.java:276)
        at org.grails.cli.boot.GrailsDependencyVersions.<init>(GrailsDependencyVersions.groovy:53)
        at org.grails.cli.boot.GrailsDependencyVersions.<init>(GrailsDependencyVersions.groovy:49)
        at org.grails.cli.profile.repository.MavenProfileRepository.<init>(MavenProfileRepository.groovy:55)
        at org.grails.cli.GrailsCli.createMavenProfileRepository(GrailsCli.groovy:329)
        at org.grails.cli.GrailsCli.execute(GrailsCli.groovy:238)
        at org.grails.cli.GrailsCli.main(GrailsCli.groovy:163)
| Error Error occurred running Grails CLI: Could not find artifact org.grails:grails-bom:pom:3.1.10 in grailsCentral (https://repo.grails.org/grails/core)

I've set GRAILS_HOME and JAVA_HOME, and my jdk version is 1.8. I visited https://repo.grails.org/grails/core with chrome but got a empty page(404 error).

Any suggestion?

Regards,

Leo Cheng


--
You received this message because you are subscribed to the Google Groups "Grails Dev Discuss" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/grails-dev-discuss/0aca35b8-fef9-42cd-88b4-12771b049165%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

Re: grails 3.1.10 failed running: Could not find artifact org.grails:grails-bom:pom:3.1.10 in grailsCent

manish jindal
with grails version 3.1.10 am Facing the same problem .

If using grails 3.1.4 than getting following error-

  grails --stacktrace
Resolving dependencies...
Error |
Failed to load latest version of profile [angular]. Trying Grails release version (NOTE: Stack trace has been filtered. Use --verbose to see ent                                ire trace.)
org.springframework.boot.cli.compiler.grape.DependencyResolutionFailedException: org.eclipse.aether.resolution.DependencyResolutionException: Co                                uld not find artifact org.grails.profiles:angular:jar:3.1.4 in grailsCentral (https://repo.grails.org/grails/core)
        at org.springframework.boot.cli.compiler.grape.AetherGrapeEngine.resolve(AetherGrapeEngine.java:307)
        at org.springframework.boot.cli.compiler.grape.AetherGrapeEngine.grab(AetherGrapeEngine.java:112)
        at org.springframework.boot.cli.compiler.grape.AetherGrapeEngine.grab(AetherGrapeEngine.java:104)
        at org.grails.cli.profile.repository.MavenProfileRepository.getAllProfiles(MavenProfileRepository.groovy:128)
        at org.grails.cli.GrailsCli.execute(GrailsCli.groovy:241)
        at org.grails.cli.GrailsCli.main(GrailsCli.groovy:162)
Caused by: org.eclipse.aether.resolution.DependencyResolutionException: Could not find artifact org.grails.profiles:angular:jar:3.1.4 in grailsC                                entral (https://repo.grails.org/grails/core)
        at org.eclipse.aether.internal.impl.DefaultRepositorySystem.resolveDependencies(DefaultRepositorySystem.java:384)
        at org.springframework.boot.cli.compiler.grape.AetherGrapeEngine.resolve(AetherGrapeEngine.java:302)
        ... 5 more
Caused by: org.eclipse.aether.resolution.ArtifactResolutionException: Could not find artifact org.grails.profiles:angular:jar:3.1.4 in grailsCen                                tral (https://repo.grails.org/grails/core)
        at org.eclipse.aether.internal.impl.DefaultArtifactResolver.resolve(DefaultArtifactResolver.java:444)
        at org.eclipse.aether.internal.impl.DefaultArtifactResolver.resolveArtifacts(DefaultArtifactResolver.java:246)
        at org.eclipse.aether.internal.impl.DefaultRepositorySystem.resolveDependencies(DefaultRepositorySystem.java:367)
        ... 6 more
Caused by: org.eclipse.aether.transfer.ArtifactNotFoundException: Could not find artifact org.grails.profiles:angular:jar:3.1.4 in grailsCentral                                 (https://repo.grails.org/grails/core)
        at org.eclipse.aether.connector.basic.ArtifactTransportListener.transferFailed(ArtifactTransportListener.java:39)
        at org.eclipse.aether.connector.basic.BasicRepositoryConnector$TaskRunner.run(BasicRepositoryConnector.java:355)
        at org.eclipse.aether.util.concurrency.RunnableErrorForwarder$1.run(RunnableErrorForwarder.java:67)
        at org.eclipse.aether.connector.basic.BasicRepositoryConnector$DirectExecutor.execute(BasicRepositoryConnector.java:581)
        at org.eclipse.aether.connector.basic.BasicRepositoryConnector.get(BasicRepositoryConnector.java:249)
        at org.eclipse.aether.internal.impl.DefaultArtifactResolver.performDownloads(DefaultArtifactResolver.java:520)
        at org.eclipse.aether.internal.impl.DefaultArtifactResolver.resolve(DefaultArtifactResolver.java:421)
        ... 8 more

Error |
Failed to load latest version of profile [angular]. Trying Grails release version
Error |
Error occurred running Grails CLI: Could not find artifact org.grails.profiles:angular:jar:3.1.4 in grailsCentral (https://repo.grails.org/grail                                s/core) (NOTE: Stack trace has been filtered. Use --verbose to see entire trace.)
org.eclipse.aether.transfer.ArtifactNotFoundException: Could not find artifact org.grails.profiles:angular:jar:3.1.4 in grailsCentral (https://r                                epo.grails.org/grails/core)
        at org.eclipse.aether.connector.basic.ArtifactTransportListener.transferFailed(ArtifactTransportListener.java:39)
        at org.eclipse.aether.connector.basic.BasicRepositoryConnector$TaskRunner.run(BasicRepositoryConnector.java:355)
        at org.eclipse.aether.util.concurrency.RunnableErrorForwarder$1.run(RunnableErrorForwarder.java:67)
        at org.eclipse.aether.connector.basic.BasicRepositoryConnector$DirectExecutor.execute(BasicRepositoryConnector.java:581)
        at org.eclipse.aether.connector.basic.BasicRepositoryConnector.get(BasicRepositoryConnector.java:249)
        at org.eclipse.aether.internal.impl.DefaultArtifactResolver.performDownloads(DefaultArtifactResolver.java:520)
        at org.eclipse.aether.internal.impl.DefaultArtifactResolver.resolve(DefaultArtifactResolver.java:421)
        at org.eclipse.aether.internal.impl.DefaultArtifactResolver.resolveArtifacts(DefaultArtifactResolver.java:246)
        at org.eclipse.aether.internal.impl.DefaultRepositorySystem.resolveDependencies(DefaultRepositorySystem.java:367)
        at org.springframework.boot.cli.compiler.grape.AetherGrapeEngine.resolve(AetherGrapeEngine.java:302)
        at org.springframework.boot.cli.compiler.grape.AetherGrapeEngine.grab(AetherGrapeEngine.java:112)
        at org.springframework.boot.cli.compiler.grape.AetherGrapeEngine.grab(AetherGrapeEngine.java:104)
        at org.grails.cli.profile.repository.MavenProfileRepository.getAllProfiles(MavenProfileRepository.groovy:133)
        at org.grails.cli.GrailsCli.execute(GrailsCli.groovy:241)
        at org.grails.cli.GrailsCli.main(GrailsCli.groovy:162)

Error |
Error occurred running Grails CLI: Could not find artifact org.grails.profiles:angular:jar:3.1.4 in grailsCentral (https://repo.grails.org/grail                                s/core)


Any help ?

Thanks,
Manish




On Monday, August 1, 2016 at 5:45:02 AM UTC+5:30, Yingyuan Cheng wrote:
Hello everyone.

I installed grails 3.1.10 in my windows 10 laptop, but failed running. The error is:

| Error Error occurred running Grails CLI: Could not find artifact org.grails:grails-bom:pom:3.1.10 in grailsCentral (<a href="https://repo.grails.org/grails/core" target="_blank" rel="nofollow" onmousedown="this.href=&#39;https://www.google.com/url?q\x3dhttps%3A%2F%2Frepo.grails.org%2Fgrails%2Fcore\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNGWOirgAenARrLiqNe99c1kCEdMIw&#39;;return true;" onclick="this.href=&#39;https://www.google.com/url?q\x3dhttps%3A%2F%2Frepo.grails.org%2Fgrails%2Fcore\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNGWOirgAenARrLiqNe99c1kCEdMIw&#39;;return true;">https://repo.grails.org/grails/core) (NOTE: Stack trace has been filtered. Use --verbose to see entire trace.)
org.eclipse.aether.transfer.ArtifactNotFoundException: Could not find artifact org.grails:grails-bom:pom:3.1.10 in grailsCentral (<a href="https://repo.grails.org/grails/core" target="_blank" rel="nofollow" onmousedown="this.href=&#39;https://www.google.com/url?q\x3dhttps%3A%2F%2Frepo.grails.org%2Fgrails%2Fcore\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNGWOirgAenARrLiqNe99c1kCEdMIw&#39;;return true;" onclick="this.href=&#39;https://www.google.com/url?q\x3dhttps%3A%2F%2Frepo.grails.org%2Fgrails%2Fcore\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNGWOirgAenARrLiqNe99c1kCEdMIw&#39;;return true;">https://repo.grails.org/grails/core)
        at org.eclipse.aether.connector.basic.ArtifactTransportListener.transferFailed(ArtifactTransportListener.java:39)
        at org.eclipse.aether.connector.basic.BasicRepositoryConnector$TaskRunner.run(BasicRepositoryConnector.java:355)
        at org.eclipse.aether.util.concurrency.RunnableErrorForwarder$1.run(RunnableErrorForwarder.java:67)
        at org.eclipse.aether.connector.basic.BasicRepositoryConnector$DirectExecutor.execute(BasicRepositoryConnector.java:581)
        at org.eclipse.aether.connector.basic.BasicRepositoryConnector.get(BasicRepositoryConnector.java:249)
        at org.eclipse.aether.internal.impl.DefaultArtifactResolver.performDownloads(DefaultArtifactResolver.java:520)
        at org.eclipse.aether.internal.impl.DefaultArtifactResolver.resolve(DefaultArtifactResolver.java:421)
        at org.eclipse.aether.internal.impl.DefaultArtifactResolver.resolveArtifacts(DefaultArtifactResolver.java:246)
        at org.eclipse.aether.internal.impl.DefaultRepositorySystem.resolveDependencies(DefaultRepositorySystem.java:367)
        at org.springframework.boot.cli.compiler.grape.AetherGrapeEngine.resolve(AetherGrapeEngine.java:302)
        at org.springframework.boot.cli.compiler.grape.AetherGrapeEngine.resolve(AetherGrapeEngine.java:284)
        at org.springframework.boot.cli.compiler.grape.AetherGrapeEngine.resolve(AetherGrapeEngine.java:276)
        at org.grails.cli.boot.GrailsDependencyVersions.<init>(GrailsDependencyVersions.groovy:53)
        at org.grails.cli.boot.GrailsDependencyVersions.<init>(GrailsDependencyVersions.groovy:49)
        at org.grails.cli.profile.repository.MavenProfileRepository.<init>(MavenProfileRepository.groovy:55)
        at org.grails.cli.GrailsCli.createMavenProfileRepository(GrailsCli.groovy:329)
        at org.grails.cli.GrailsCli.execute(GrailsCli.groovy:238)
        at org.grails.cli.GrailsCli.main(GrailsCli.groovy:163)
| Error Error occurred running Grails CLI: Could not find artifact org.grails:grails-bom:pom:3.1.10 in grailsCentral (<a href="https://repo.grails.org/grails/core" target="_blank" rel="nofollow" onmousedown="this.href=&#39;https://www.google.com/url?q\x3dhttps%3A%2F%2Frepo.grails.org%2Fgrails%2Fcore\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNGWOirgAenARrLiqNe99c1kCEdMIw&#39;;return true;" onclick="this.href=&#39;https://www.google.com/url?q\x3dhttps%3A%2F%2Frepo.grails.org%2Fgrails%2Fcore\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNGWOirgAenARrLiqNe99c1kCEdMIw&#39;;return true;">https://repo.grails.org/grails/core)

I've set GRAILS_HOME and JAVA_HOME, and my jdk version is 1.8. I visited <a href="https://repo.grails.org/grails/core" target="_blank" rel="nofollow" onmousedown="this.href=&#39;https://www.google.com/url?q\x3dhttps%3A%2F%2Frepo.grails.org%2Fgrails%2Fcore\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNGWOirgAenARrLiqNe99c1kCEdMIw&#39;;return true;" onclick="this.href=&#39;https://www.google.com/url?q\x3dhttps%3A%2F%2Frepo.grails.org%2Fgrails%2Fcore\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNGWOirgAenARrLiqNe99c1kCEdMIw&#39;;return true;">https://repo.grails.org/grails/core with chrome but got a empty page(404 error).

Any suggestion?

Regards,

Leo Cheng


--
You received this message because you are subscribed to the Google Groups "Grails Dev Discuss" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/grails-dev-discuss/39c524ad-e5b7-4392-bb08-e1d00b9315a3%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

Re: grails 3.1.10 failed running: Could not find artifact org.grails:grails-bom:pom:3.1.10 in grailsCent

Yingyuan Cheng
In reply to this post by Yingyuan Cheng
I can run grails 3.1.10 smoothly now. I didn't make any change. Maybe it was a temporary network error. Anyway, it works. I'm estimating grails as my new web framework, after tired of django and codeignite. Hope it could do what i want.


On Monday, August 1, 2016 at 8:15:02 AM UTC+8, Yingyuan Cheng wrote:
Hello everyone.

I installed grails 3.1.10 in my windows 10 laptop, but failed running. The error is:

| Error Error occurred running Grails CLI: Could not find artifact org.grails:grails-bom:pom:3.1.10 in grailsCentral (<a href="https://repo.grails.org/grails/core" target="_blank" rel="nofollow" onmousedown="this.href=&#39;https://www.google.com/url?q\x3dhttps%3A%2F%2Frepo.grails.org%2Fgrails%2Fcore\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNGWOirgAenARrLiqNe99c1kCEdMIw&#39;;return true;" onclick="this.href=&#39;https://www.google.com/url?q\x3dhttps%3A%2F%2Frepo.grails.org%2Fgrails%2Fcore\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNGWOirgAenARrLiqNe99c1kCEdMIw&#39;;return true;">https://repo.grails.org/grails/core) (NOTE: Stack trace has been filtered. Use --verbose to see entire trace.)
org.eclipse.aether.transfer.ArtifactNotFoundException: Could not find artifact org.grails:grails-bom:pom:3.1.10 in grailsCentral (<a href="https://repo.grails.org/grails/core" target="_blank" rel="nofollow" onmousedown="this.href=&#39;https://www.google.com/url?q\x3dhttps%3A%2F%2Frepo.grails.org%2Fgrails%2Fcore\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNGWOirgAenARrLiqNe99c1kCEdMIw&#39;;return true;" onclick="this.href=&#39;https://www.google.com/url?q\x3dhttps%3A%2F%2Frepo.grails.org%2Fgrails%2Fcore\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNGWOirgAenARrLiqNe99c1kCEdMIw&#39;;return true;">https://repo.grails.org/grails/core)
        at org.eclipse.aether.connector.basic.ArtifactTransportListener.transferFailed(ArtifactTransportListener.java:39)
        at org.eclipse.aether.connector.basic.BasicRepositoryConnector$TaskRunner.run(BasicRepositoryConnector.java:355)
        at org.eclipse.aether.util.concurrency.RunnableErrorForwarder$1.run(RunnableErrorForwarder.java:67)
        at org.eclipse.aether.connector.basic.BasicRepositoryConnector$DirectExecutor.execute(BasicRepositoryConnector.java:581)
        at org.eclipse.aether.connector.basic.BasicRepositoryConnector.get(BasicRepositoryConnector.java:249)
        at org.eclipse.aether.internal.impl.DefaultArtifactResolver.performDownloads(DefaultArtifactResolver.java:520)
        at org.eclipse.aether.internal.impl.DefaultArtifactResolver.resolve(DefaultArtifactResolver.java:421)
        at org.eclipse.aether.internal.impl.DefaultArtifactResolver.resolveArtifacts(DefaultArtifactResolver.java:246)
        at org.eclipse.aether.internal.impl.DefaultRepositorySystem.resolveDependencies(DefaultRepositorySystem.java:367)
        at org.springframework.boot.cli.compiler.grape.AetherGrapeEngine.resolve(AetherGrapeEngine.java:302)
        at org.springframework.boot.cli.compiler.grape.AetherGrapeEngine.resolve(AetherGrapeEngine.java:284)
        at org.springframework.boot.cli.compiler.grape.AetherGrapeEngine.resolve(AetherGrapeEngine.java:276)
        at org.grails.cli.boot.GrailsDependencyVersions.<init>(GrailsDependencyVersions.groovy:53)
        at org.grails.cli.boot.GrailsDependencyVersions.<init>(GrailsDependencyVersions.groovy:49)
        at org.grails.cli.profile.repository.MavenProfileRepository.<init>(MavenProfileRepository.groovy:55)
        at org.grails.cli.GrailsCli.createMavenProfileRepository(GrailsCli.groovy:329)
        at org.grails.cli.GrailsCli.execute(GrailsCli.groovy:238)
        at org.grails.cli.GrailsCli.main(GrailsCli.groovy:163)
| Error Error occurred running Grails CLI: Could not find artifact org.grails:grails-bom:pom:3.1.10 in grailsCentral (<a href="https://repo.grails.org/grails/core" target="_blank" rel="nofollow" onmousedown="this.href=&#39;https://www.google.com/url?q\x3dhttps%3A%2F%2Frepo.grails.org%2Fgrails%2Fcore\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNGWOirgAenARrLiqNe99c1kCEdMIw&#39;;return true;" onclick="this.href=&#39;https://www.google.com/url?q\x3dhttps%3A%2F%2Frepo.grails.org%2Fgrails%2Fcore\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNGWOirgAenARrLiqNe99c1kCEdMIw&#39;;return true;">https://repo.grails.org/grails/core)

I've set GRAILS_HOME and JAVA_HOME, and my jdk version is 1.8. I visited <a href="https://repo.grails.org/grails/core" target="_blank" rel="nofollow" onmousedown="this.href=&#39;https://www.google.com/url?q\x3dhttps%3A%2F%2Frepo.grails.org%2Fgrails%2Fcore\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNGWOirgAenARrLiqNe99c1kCEdMIw&#39;;return true;" onclick="this.href=&#39;https://www.google.com/url?q\x3dhttps%3A%2F%2Frepo.grails.org%2Fgrails%2Fcore\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNGWOirgAenARrLiqNe99c1kCEdMIw&#39;;return true;">https://repo.grails.org/grails/core with chrome but got a empty page(404 error).

Any suggestion?

Regards,

Leo Cheng


--
You received this message because you are subscribed to the Google Groups "Grails Dev Discuss" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/grails-dev-discuss/bfbe2875-11fa-42bf-9a46-5016c29e0603%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.