Quantcast

how to upgrade grails and groovy in SpringSource STS

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

how to upgrade grails and groovy in SpringSource STS

Sven Prevrhal
Hi, I am using STS 2.5.0 and just downloaded Grails 1.3.5 and Groovy
1.7.5. Now I want STS to use those. For grails, I found
Windows->Preferences->Groovy->Grails in the IDE but it's apparently
not as simple as setting the path there to the new grails version,
because I get lots of errors when I try to run after setting that to
1.3.5.
I didn't see anything at all to set Groovy - how do I control what
version STS will use, or is that a wrong question?

Thanks and Cheers,Sven

---------------------------------------------------------------------
To unsubscribe from this list, please visit:

    http://xircles.codehaus.org/manage_email


Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: how to upgrade grails and groovy in SpringSource STS

burtbeckwith
Try [hidden email]

Burt

> Hi, I am using STS 2.5.0 and just downloaded Grails 1.3.5 and Groovy
> 1.7.5. Now I want STS to use those. For grails, I found
> Windows->Preferences->Groovy->Grails in the IDE but it's apparently
> not as simple as setting the path there to the new grails version,
> because I get lots of errors when I try to run after setting that to
> 1.3.5.
> I didn't see anything at all to set Groovy - how do I control what
> version STS will use, or is that a wrong question?
>
> Thanks and Cheers,Sven

signature.asc (205 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: how to upgrade grails and groovy in SpringSource STS

Paul B. Hill
In reply to this post by Sven Prevrhal
Hi Sven,

The following should work, although they are project specific:

Right click on your Grails project within the IDE. Select "Properties"
from the context menu. In the dialog box click on "Grails", then check
"Enable project specific settings" and click on "Configure Workspace
Settings".

For a Groovy project, right click on the project and select
"Properties". Next select "Java Build Path", and then open the
"Libraries" property sheet. Expand "Groovy Libraries". You can then add
the new version and remove the old version from the project settings.

You'll probably get more informative answers to questions about STS on
the STS forum. <http://forum.springsource.org/forumdisplay.php?f=32>

Paul

On 10/11/2010 12:23 PM, Sven Prevrhal wrote:

> Hi, I am using STS 2.5.0 and just downloaded Grails 1.3.5 and Groovy
> 1.7.5. Now I want STS to use those. For grails, I found
> Windows->Preferences->Groovy->Grails in the IDE but it's apparently
> not as simple as setting the path there to the new grails version,
> because I get lots of errors when I try to run after setting that to
> 1.3.5.
> I didn't see anything at all to set Groovy - how do I control what
> version STS will use, or is that a wrong question?
>
> Thanks and Cheers,Sven
>
> ---------------------------------------------------------------------
> To unsubscribe from this list, please visit:
>
>      http://xircles.codehaus.org/manage_email
>
>

---------------------------------------------------------------------
To unsubscribe from this list, please visit:

    http://xircles.codehaus.org/manage_email


Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: how to upgrade grails and groovy in SpringSource STS

Andy Clement
> For a Groovy project, right click on the project and select "Properties".
> Next select "Java Build Path", and then open the "Libraries" property sheet.
> Expand "Groovy Libraries". You can then add the new version and remove the
> old version from the project settings.

Just to note, this only switches the runtime dependency groovy level,
it does not change the compiler level used by groovy-eclipse.  Groovy
Eclipse is currently using the Groovy 1.7.5 compiler.  You may get
problems if you change the dependencies as described above, as there
are no guarantees that code built with 1.7.5 will run against a
runtime level other than 1.7.5.

Andy

On 11 October 2010 10:24, Paul B. Hill <[hidden email]> wrote:

> Hi Sven,
>
> The following should work, although they are project specific:
>
> Right click on your Grails project within the IDE. Select "Properties" from
> the context menu. In the dialog box click on "Grails", then check "Enable
> project specific settings" and click on "Configure Workspace Settings".
>
> For a Groovy project, right click on the project and select "Properties".
> Next select "Java Build Path", and then open the "Libraries" property sheet.
> Expand "Groovy Libraries". You can then add the new version and remove the
> old version from the project settings.
>
> You'll probably get more informative answers to questions about STS on the
> STS forum. <http://forum.springsource.org/forumdisplay.php?f=32>
>
> Paul
>
> On 10/11/2010 12:23 PM, Sven Prevrhal wrote:
>>
>> Hi, I am using STS 2.5.0 and just downloaded Grails 1.3.5 and Groovy
>> 1.7.5. Now I want STS to use those. For grails, I found
>> Windows->Preferences->Groovy->Grails in the IDE but it's apparently
>> not as simple as setting the path there to the new grails version,
>> because I get lots of errors when I try to run after setting that to
>> 1.3.5.
>> I didn't see anything at all to set Groovy - how do I control what
>> version STS will use, or is that a wrong question?
>>
>> Thanks and Cheers,Sven
>>
>> ---------------------------------------------------------------------
>> To unsubscribe from this list, please visit:
>>
>>     http://xircles.codehaus.org/manage_email
>>
>>
>
> ---------------------------------------------------------------------
> To unsubscribe from this list, please visit:
>
>   http://xircles.codehaus.org/manage_email
>
>
>

---------------------------------------------------------------------
To unsubscribe from this list, please visit:

    http://xircles.codehaus.org/manage_email


Loading...