platform-core plugin deprecated?

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

platform-core plugin deprecated?

Mirko Weber-4
Hi,

I read on the grails-events page, that this plugin claims to be a successor of the Event Api of the platform-core plugin. 

So my questions are:
  • Is the platform-core plugin deprecated as whole? 
  • Are there problemes to use platform-core and grails-event plugin at the same project?
  • Are there recommended equivalent successors of the other parts, esspecialy the navigation and the configuration api?
Thanks,
Mirko

--
You received this message because you are subscribed to the Google Groups "Grails Dev Discuss" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/grails-dev-discuss/5c98254d-04c1-4705-9e62-2a97c47e637b%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

Re: platform-core plugin deprecated?

Graeme Rocher-2
The plugin is at 1.0.0 and isn't deprecated you can continue to use it
but no further development is planned other than routine maintenance
from community pull requests

On Wed, Dec 17, 2014 at 11:06 PM, Mirko Weber <[hidden email]> wrote:

> Hi,
>
> I read on the grails-events page, that this plugin claims to be a successor
> of the Event Api of the platform-core plugin.
>
> So my questions are:
>
> Is the platform-core plugin deprecated as whole?
> Are there problemes to use platform-core and grails-event plugin at the same
> project?
> Are there recommended equivalent successors of the other parts, esspecialy
> the navigation and the configuration api?
>
> Thanks,
> Mirko
>
> --
> You received this message because you are subscribed to the Google Groups
> "Grails Dev Discuss" group.
> To unsubscribe from this group and stop receiving emails from it, send an
> email to [hidden email].
> To post to this group, send email to [hidden email].
> To view this discussion on the web visit
> https://groups.google.com/d/msgid/grails-dev-discuss/5c98254d-04c1-4705-9e62-2a97c47e637b%40googlegroups.com.
> For more options, visit https://groups.google.com/d/optout.



--
Graeme Rocher
Grails Project Lead
Pivotal

--
You received this message because you are subscribed to the Google Groups "Grails Dev Discuss" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/grails-dev-discuss/CAO_wNocnfp540oL59o7_HbN1dJ5crHxEqR7TByKuNFSg6VFwVQ%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

Re: platform-core plugin deprecated?

PaulWaldo
In reply to this post by Mirko Weber-4
Hi Mirko,

I also need platform-core for a project I'm upgrading to grails 3.  I'm debating how to handle this, as I need only the Navigation stuff.  I'm thinking I might just pull Navigation out into its own plugin, rather than trying to port the whole thing.  Trying to get my head wrapped around all of platform-core will ensure that it is done sometime in the 4.x version of Grails ;-)

If just navigation will suffice, I'd be happy to collaborate with you.  Have you found any other replacements that are working now?

Paul

On Wednesday, December 17, 2014 at 5:06:54 PM UTC-5, Mirko Weber wrote:
Hi,

I read on the <a href="https://github.com/reactor/grails-events" target="_blank" rel="nofollow" onmousedown="this.href=&#39;https://www.google.com/url?q\75https%3A%2F%2Fgithub.com%2Freactor%2Fgrails-events\46sa\75D\46sntz\0751\46usg\75AFQjCNGjDmczFCaDOAGKSvhNO9wt21hWjg&#39;;return true;" onclick="this.href=&#39;https://www.google.com/url?q\75https%3A%2F%2Fgithub.com%2Freactor%2Fgrails-events\46sa\75D\46sntz\0751\46usg\75AFQjCNGjDmczFCaDOAGKSvhNO9wt21hWjg&#39;;return true;">grails-events page, that this plugin claims to be a successor of the Event Api of the platform-core plugin. 

So my questions are:
  • Is the platform-core plugin deprecated as whole? 
  • Are there problemes to use platform-core and grails-event plugin at the same project?
  • Are there recommended equivalent successors of the other parts, esspecialy the navigation and the configuration api?
Thanks,
Mirko

--
You received this message because you are subscribed to the Google Groups "Grails Dev Discuss" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/grails-dev-discuss/1d1b9f61-18c5-4c2a-8c43-c3e79a92206e%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

Re: platform-core plugin deprecated?

Mirko Weber-4
Hello Paul,

at the moment I not activ mirgrate my projects to grails3 and do not have a new project that give me time to develop the plugin. But the navigation part is one of the parts I use often and a big stoper to migrate my project on the fly to grails3.

Kind regards,
Mirko

Paul Waldo <[hidden email]> schrieb am Di., 27. Okt. 2015 um 20:59 Uhr:
Hi Mirko,

I also need platform-core for a project I'm upgrading to grails 3.  I'm debating how to handle this, as I need only the Navigation stuff.  I'm thinking I might just pull Navigation out into its own plugin, rather than trying to port the whole thing.  Trying to get my head wrapped around all of platform-core will ensure that it is done sometime in the 4.x version of Grails ;-)

If just navigation will suffice, I'd be happy to collaborate with you.  Have you found any other replacements that are working now?

Paul


On Wednesday, December 17, 2014 at 5:06:54 PM UTC-5, Mirko Weber wrote:
Hi,

I read on the grails-events page, that this plugin claims to be a successor of the Event Api of the platform-core plugin. 

So my questions are:
  • Is the platform-core plugin deprecated as whole? 
  • Are there problemes to use platform-core and grails-event plugin at the same project?
  • Are there recommended equivalent successors of the other parts, esspecialy the navigation and the configuration api?
Thanks,
Mirko

--
You received this message because you are subscribed to a topic in the Google Groups "Grails Dev Discuss" group.
To unsubscribe from this topic, visit https://groups.google.com/d/topic/grails-dev-discuss/dKSK7juULm8/unsubscribe.
To unsubscribe from this group and all its topics, send an email to [hidden email].
To post to this group, send email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/grails-dev-discuss/1d1b9f61-18c5-4c2a-8c43-c3e79a92206e%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "Grails Dev Discuss" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/grails-dev-discuss/CABF2gHTFCp0GsSBFB4KnmE%3DKG%3D0VL3wocz_JjJjuu%3DwDnxeJiw%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

Re: platform-core plugin deprecated?

PaulWaldo

Hi Mirko,


It's been a while since this thread, but I wanted to let you know I have a first cut of the platform-core plugin for grails 3.  It's a straight port, but as far as I can tell, everything is working OK.  I use only the navigation stuff, so that is where I have been concentrating.  If you would like to give it a go, I would appreciate your feedback.  To use it on your grails 3 project, do the following:

  • Fork or clone the repo at https://github.com/PaulWaldo/grails-platform-core.git
  • Add compile "org.grails.plugins:grails-platform-core:3.0.0-SNAPSHOT" to your build.gradle dependencies
  • Enjoy Navigation tags
I hope this works for you!

Paul

On Wednesday, October 28, 2015 at 3:49:11 AM UTC-4, Mirko Weber wrote:
Hello Paul,

at the moment I not activ mirgrate my projects to grails3 and do not have a new project that give me time to develop the plugin. But the navigation part is one of the parts I use often and a big stoper to migrate my project on the fly to grails3.

Kind regards,
Mirko

Paul Waldo <<a href="javascript:" target="_blank" gdf-obfuscated-mailto="4Zj6pBdcBwAJ" rel="nofollow" onmousedown="this.href=&#39;javascript:&#39;;return true;" onclick="this.href=&#39;javascript:&#39;;return true;">paulw...@...> schrieb am Di., 27. Okt. 2015 um 20:59 Uhr:
Hi Mirko,

I also need platform-core for a project I'm upgrading to grails 3.  I'm debating how to handle this, as I need only the Navigation stuff.  I'm thinking I might just pull Navigation out into its own plugin, rather than trying to port the whole thing.  Trying to get my head wrapped around all of platform-core will ensure that it is done sometime in the 4.x version of Grails ;-)

If just navigation will suffice, I'd be happy to collaborate with you.  Have you found any other replacements that are working now?

Paul


On Wednesday, December 17, 2014 at 5:06:54 PM UTC-5, Mirko Weber wrote:
Hi,

I read on the <a href="https://github.com/reactor/grails-events" rel="nofollow" target="_blank" onmousedown="this.href=&#39;https://www.google.com/url?q\75https%3A%2F%2Fgithub.com%2Freactor%2Fgrails-events\46sa\75D\46sntz\0751\46usg\75AFQjCNGjDmczFCaDOAGKSvhNO9wt21hWjg&#39;;return true;" onclick="this.href=&#39;https://www.google.com/url?q\75https%3A%2F%2Fgithub.com%2Freactor%2Fgrails-events\46sa\75D\46sntz\0751\46usg\75AFQjCNGjDmczFCaDOAGKSvhNO9wt21hWjg&#39;;return true;">grails-events page, that this plugin claims to be a successor of the Event Api of the platform-core plugin. 

So my questions are:
  • Is the platform-core plugin deprecated as whole? 
  • Are there problemes to use platform-core and grails-event plugin at the same project?
  • Are there recommended equivalent successors of the other parts, esspecialy the navigation and the configuration api?
Thanks,
Mirko

--
You received this message because you are subscribed to a topic in the Google Groups "Grails Dev Discuss" group.
To unsubscribe from this topic, visit <a href="https://groups.google.com/d/topic/grails-dev-discuss/dKSK7juULm8/unsubscribe" target="_blank" rel="nofollow" onmousedown="this.href=&#39;https://groups.google.com/d/topic/grails-dev-discuss/dKSK7juULm8/unsubscribe&#39;;return true;" onclick="this.href=&#39;https://groups.google.com/d/topic/grails-dev-discuss/dKSK7juULm8/unsubscribe&#39;;return true;">https://groups.google.com/d/topic/grails-dev-discuss/dKSK7juULm8/unsubscribe.
To unsubscribe from this group and all its topics, send an email to <a href="javascript:" target="_blank" gdf-obfuscated-mailto="4Zj6pBdcBwAJ" rel="nofollow" onmousedown="this.href=&#39;javascript:&#39;;return true;" onclick="this.href=&#39;javascript:&#39;;return true;">grails-dev-discuss+unsubscribe@....
To post to this group, send email to <a href="javascript:" target="_blank" gdf-obfuscated-mailto="4Zj6pBdcBwAJ" rel="nofollow" onmousedown="this.href=&#39;javascript:&#39;;return true;" onclick="this.href=&#39;javascript:&#39;;return true;">grails-de...@googlegroups.com.
To view this discussion on the web visit <a href="https://groups.google.com/d/msgid/grails-dev-discuss/1d1b9f61-18c5-4c2a-8c43-c3e79a92206e%40googlegroups.com?utm_medium=email&amp;utm_source=footer" target="_blank" rel="nofollow" onmousedown="this.href=&#39;https://groups.google.com/d/msgid/grails-dev-discuss/1d1b9f61-18c5-4c2a-8c43-c3e79a92206e%40googlegroups.com?utm_medium\75email\46utm_source\75footer&#39;;return true;" onclick="this.href=&#39;https://groups.google.com/d/msgid/grails-dev-discuss/1d1b9f61-18c5-4c2a-8c43-c3e79a92206e%40googlegroups.com?utm_medium\75email\46utm_source\75footer&#39;;return true;">https://groups.google.com/d/msgid/grails-dev-discuss/1d1b9f61-18c5-4c2a-8c43-c3e79a92206e%40googlegroups.com.
For more options, visit <a href="https://groups.google.com/d/optout" target="_blank" rel="nofollow" onmousedown="this.href=&#39;https://groups.google.com/d/optout&#39;;return true;" onclick="this.href=&#39;https://groups.google.com/d/optout&#39;;return true;">https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "Grails Dev Discuss" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/grails-dev-discuss/4dc78a50-12bb-4cea-8e4c-492252ba15ab%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.