plugins not installing when running gails run-app

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
5 messages Options
Den
Reply | Threaded
Open this post in threaded view
|

plugins not installing when running gails run-app

Den
 following is my console 


C:\workspace\storeApps>grails run-app
Java HotSpot(TM) Client VM warning: ignoring option MaxPermSize=96m; support was removed in 8.0
Welcome to Grails 1.3.7 - http://grails.org/
Licensed under Apache Standard License 2.0
Grails home is set to: C:\grails\grails-1.3.7

Base Directory: C:\workspace\storeApps
Resolving dependencies...
Dependencies resolved in 484ms.
Running script C:\grails\grails-1.3.7\scripts\RunApp.groovy
Environment set to development
Plugin [jquery-ui-1.8.15] not installed. ...
Plugin [mail-1.0] not installed. ...
Plugin [tooltip-0.7] not installed. ...
Plugin [jquery-1.7.1] not installed. ...
Plugin [spring-security-core-1.2.7.3] not installed. ...
Plugin [tomcat-1.3.7] not installed. ...
Plugin [hibernate-1.3.7] not installed. ...
Resolving new plugins. Please wait... ...

--
You received this message because you are subscribed to the Google Groups "Grails Dev Discuss" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/grails-dev-discuss/219917f2-1c6f-49d4-a516-4cb31b641fb8%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

Re: plugins not installing when running gails run-app

Colin Harrington-4
Looks like you are using JDK8 based on the Client VM warning.  Grails 1.3.x predates Java 8.  When JDK8 was released there were some issues identified with the version of Groovy that Grails 1.3.x uses and the JDK.  You are going to need to use JDK 6 or 7 to work with Grails 1.3.x applications. 

Also note that you may want to update to 1.3.8 or 1.3.9 or at least be aware of the databinding issue (similar to Rails' issue) affecting earlier versions.  https://www.cvedetails.com/cve/CVE-2012-1833/

Happy Trails



On Wed, Jul 5, 2017 at 1:10 PM, Den <[hidden email]> wrote:
 following is my console 


C:\workspace\storeApps>grails run-app
Java HotSpot(TM) Client VM warning: ignoring option MaxPermSize=96m; support was removed in 8.0
Welcome to Grails 1.3.7 - http://grails.org/
Licensed under Apache Standard License 2.0
Grails home is set to: C:\grails\grails-1.3.7

Base Directory: C:\workspace\storeApps
Resolving dependencies...
Dependencies resolved in 484ms.
Running script C:\grails\grails-1.3.7\scripts\RunApp.groovy
Environment set to development
Plugin [jquery-ui-1.8.15] not installed. ...
Plugin [mail-1.0] not installed. ...
Plugin [tooltip-0.7] not installed. ...
Plugin [jquery-1.7.1] not installed. ...
Plugin [spring-security-core-1.2.7.3] not installed. ...
Plugin [tomcat-1.3.7] not installed. ...
Plugin [hibernate-1.3.7] not installed. ...
Resolving new plugins. Please wait... ...

--
You received this message because you are subscribed to the Google Groups "Grails Dev Discuss" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/grails-dev-discuss/219917f2-1c6f-49d4-a516-4cb31b641fb8%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.



--
Colin Harrington
[hidden email]
Grails Developer
@ColinHarrington

--
You received this message because you are subscribed to the Google Groups "Grails Dev Discuss" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/grails-dev-discuss/CAMRV%3Dg57Vjs6kTahFLYXZ4SdZC%3DTjkzq2EtOLPcjoRMmq5oq2Q%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.
Den
Reply | Threaded
Open this post in threaded view
|

Re: plugins not installing when running gails run-app

Den
In reply to this post by Den
Hello Colin,

Thanks a lot for the quick response.
I installed jdk 6. Still getting the following


C:\workspace\storeApps>grails run-app
Welcome to Grails 1.3.7 - http://grails.org/
Licensed under Apache Standard License 2.0
Grails home is set to: C:\grails\grails-1.3.7

Base Directory: C:\workspace\storeApps
Resolving dependencies...
Dependencies resolved in 781ms.
Running script C:\grails\grails-1.3.7\scripts\RunApp.groovy
Environment set to development
Plugin [jquery-1.7.1] not installed. ...
Plugin [mail-1.0] not installed. ...
Plugin [tooltip-0.7] not installed. ...
Plugin [spring-security-core-1.2.7.3] not installed. ...
Plugin [tomcat-1.3.7] not installed. ...
Plugin [jquery-ui-1.8.15] not installed. ...
Plugin [hibernate-1.3.7] not installed. ...
Resolving new plugins. Please wait... ...

On Wednesday, July 5, 2017 at 2:10:53 PM UTC-4, Den wrote:
 following is my console 


C:\workspace\storeApps>grails run-app
Java HotSpot(TM) Client VM warning: ignoring option MaxPermSize=96m; support was removed in 8.0
Welcome to Grails 1.3.7 - <a href="http://grails.org/" target="_blank" rel="nofollow" onmousedown="this.href=&#39;http://www.google.com/url?q\x3dhttp%3A%2F%2Fgrails.org%2F\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNF7NCBg0A8H0fAvFguCKERjwL_FGQ&#39;;return true;" onclick="this.href=&#39;http://www.google.com/url?q\x3dhttp%3A%2F%2Fgrails.org%2F\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNF7NCBg0A8H0fAvFguCKERjwL_FGQ&#39;;return true;">http://grails.org/
Licensed under Apache Standard License 2.0
Grails home is set to: C:\grails\grails-1.3.7

Base Directory: C:\workspace\storeApps
Resolving dependencies...
Dependencies resolved in 484ms.
Running script C:\grails\grails-1.3.7\scripts\RunApp.groovy
Environment set to development
Plugin [jquery-ui-1.8.15] not installed. ...
Plugin [mail-1.0] not installed. ...
Plugin [tooltip-0.7] not installed. ...
Plugin [jquery-1.7.1] not installed. ...
Plugin [spring-security-core-1.2.7.3] not installed. ...
Plugin [tomcat-1.3.7] not installed. ...
Plugin [hibernate-1.3.7] not installed. ...
Resolving new plugins. Please wait... ...

--
You received this message because you are subscribed to the Google Groups "Grails Dev Discuss" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/grails-dev-discuss/4f579d95-de54-4589-af9e-2038d0ac18c1%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

Re: plugins not installing when running gails run-app

tommyhulk
This post has NOT been accepted by the mailing list yet.
In reply to this post by Den
Many thanks for sharing this very diverse opinion post where each expert has no doubt shared his best knowledge on the topic. Have more success in your journey.
usps tracking
Reply | Threaded
Open this post in threaded view
|

Re: plugins not installing when running gails run-app

clr meno
In reply to this post by Den
Can you try using the following command from project directory and select the type of installation for example maven install
grails install

On Wednesday, July 5, 2017 at 2:10:53 PM UTC-4, Den wrote:
 following is my console 


C:\workspace\storeApps>grails run-app
Java HotSpot(TM) Client VM warning: ignoring option MaxPermSize=96m; support was removed in 8.0
Welcome to Grails 1.3.7 - <a href="http://grails.org/" target="_blank" rel="nofollow" onmousedown="this.href=&#39;http://www.google.com/url?q\x3dhttp%3A%2F%2Fgrails.org%2F\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNF7NCBg0A8H0fAvFguCKERjwL_FGQ&#39;;return true;" onclick="this.href=&#39;http://www.google.com/url?q\x3dhttp%3A%2F%2Fgrails.org%2F\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNF7NCBg0A8H0fAvFguCKERjwL_FGQ&#39;;return true;">http://grails.org/
Licensed under Apache Standard License 2.0
Grails home is set to: C:\grails\grails-1.3.7

Base Directory: C:\workspace\storeApps
Resolving dependencies...
Dependencies resolved in 484ms.
Running script C:\grails\grails-1.3.7\scripts\RunApp.groovy
Environment set to development
Plugin [jquery-ui-1.8.15] not installed. ...
Plugin [mail-1.0] not installed. ...
Plugin [tooltip-0.7] not installed. ...
Plugin [jquery-1.7.1] not installed. ...
Plugin [spring-security-core-1.2.7.3] not installed. ...
Plugin [tomcat-1.3.7] not installed. ...
Plugin [hibernate-1.3.7] not installed. ...
Resolving new plugins. Please wait... ...

--
You received this message because you are subscribed to the Google Groups "Grails Dev Discuss" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/grails-dev-discuss/a0663981-1147-45d1-9bea-d52626f6bf18%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.