publish-plugin command fails with loader constrain violation

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

publish-plugin command fails with loader constrain violation

Rob Bugh
Has anyone seen this error before and can advise me how to fix it? I'm
trying to run the "publish-plugin" command (Release-3.0.1 plugin) on my
Jenkins build machine and am getting this error:

Error executing script PublishPlugin: loader constraint violation: when
resolving method
"org.apache.http.impl.cookie.NetscapeDraftHeaderParser.parseHeader(Lorg/apache/http/util/CharArrayBuffer;Lorg/apache/http/message/ParserCursor;)Lorg/apache/http/HeaderElement;"
the class loader (instance of groovy/lang/GroovyClassLoader) of the
current class, org/apache/http/impl/cookie/BestMatchSpec, and the class
loader (instance of
org/codehaus/groovy/grails/cli/support/GrailsRootLoader) for resolved
class, org/apache/http/impl/cookie/NetscapeDraftHeaderParser, have
different Class objects for the type
arser.parseHeader(Lorg/apache/http/util/CharArrayBuffer;Lorg/apache/http/message/ParserCursor;)Lorg/apache/http/HeaderElement;
used in the signature (Use --stacktrace to see the full trace)

Regards,
Rob

---------------------------------------------------------------------
To unsubscribe from this list, please visit:

    http://xircles.codehaus.org/manage_email


Reply | Threaded
Open this post in threaded view
|

Re: publish-plugin command fails with loader constrain violation

Vahid Pazirandeh
Did you ever get this resolved?

It started happening for me today after I changed the version of the Hibernate4 plugin that I'm using, however I'm not convinced that my Hibernate plugin has anything to do with the error.

The error started happening in Jenkins, and I noticed that Jenkins was configured to run "clean" and then "maven-deploy". I removed "clean" and things started working fine.

I hope not to see it again... :)