rendering plugin install problems

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
6 messages Options
Reply | Threaded
Open this post in threaded view
|

rendering plugin install problems

wilsonaikeda@gmail.com
Hi, when trying to install the rendering plugin somehow it's not including the iText and the flyingsaucer classes, all services methods throw a unable to resolve class (xhtml and lowagie) when trying to compile the app, it's just me experiencing this? All others plugins install and compile fine.

Deleted the .grails dir, tried on a newly created app with only bare grails plugins without success:

BuildConfig.groovy:

    plugins {
        runtime ":hibernate:$grailsVersion"
        runtime ":jquery:1.8.3"
        build ":tomcat:$grailsVersion"
        compile ":rendering:0.4.3"
    }

OS X 10.8.3, JVM 1.6.0_45, Grails 2.2.1.

TIA
---------------------------------------------------------------------
To unsubscribe from this list, please visit:

    http://xircles.codehaus.org/manage_email


Reply | Threaded
Open this post in threaded view
|

Re: rendering plugin install problems

burtbeckwith
Does it help to run "grails compile"? That should resolve dependencies.

Burt

Akira Ikeda wrote
Hi, when trying to install the rendering plugin somehow it's not including the iText and the flyingsaucer classes, all services methods throw a unable to resolve class (xhtml and lowagie) when trying to compile the app, it's just me experiencing this? All others plugins install and compile fine.

Deleted the .grails dir, tried on a newly created app with only bare grails plugins without success:

BuildConfig.groovy:

    plugins {
        runtime ":hibernate:$grailsVersion"
        runtime ":jquery:1.8.3"
        build ":tomcat:$grailsVersion"
        compile ":rendering:0.4.3"
    }

OS X 10.8.3, JVM 1.6.0_45, Grails 2.2.1.

TIA
Reply | Threaded
Open this post in threaded view
|

Re: rendering plugin install problems

wilsonaikeda@gmail.com
Hi Burt thanks for the answer, i did delete the .grails dir, run grails compile and got the same error, i attached a clean app that doesn't compile due to class not found errors, the rendering folder was installed on the plugins folder but cannot find the xhtml or lowagie classes.
As a workaround i donwloaded the last xhtml jars (R8) and put in the lib folder then the app compile and runs fine.




/Users/sartre/.grails/2.2.1/projects/renderingtest/plugins/rendering-0.4.3/src/groovy/grails/plugin/rendering/datauri/DataUriAwareITextUserAgent.groovy: 20: unable to resolve class org.xhtmlrenderer.resource.ImageResource
 @ line 20, column 1.
   import org.xhtmlrenderer.resource.ImageResource
   ^

/Users/sartre/.grails/2.2.1/projects/renderingtest/plugins/rendering-0.4.3/src/groovy/grails/plugin/rendering/datauri/DataUriAwareITextUserAgent.groovy: 22: unable to resolve class com.lowagie.text.Image
 @ line 22, column 1.
   import com.lowagie.text.Image
   ^

/Users/sartre/.grails/2.2.1/projects/renderingtest/plugins/rendering-0.4.3/src/groovy/grails/plugin/rendering/datauri/DataUriAwareITextUserAgent.groovy: 28: unable to resolve class ITextUserAgent
 @ line 28, column 1.
   class DataUriAwareITextUserAgent extends ITextUserAgent {
   ^

/Users/sartre/.grails/2.2.1/projects/renderingtest/plugins/rendering-0.4.3/src/groovy/grails/plugin/rendering/datauri/DataUriAwareITextUserAgent.groovy: 32: unable to resolve class ITextOutputDevice
 @ line 32, column 29.
    DataUriAwareITextUserAgent(ITextOutputDevice outputDevice) {
                               ^

/Users/sartre/.grails/2.2.1/projects/renderingtest/plugins/rendering-0.4.3/src/groovy/grails/plugin/rendering/datauri/DataUriAwareITextUserAgent.groovy: 36: unable to resolve class org.xhtmlrenderer.resource.ImageResource
 @ line 36, column 2.
    ImageResource getImageResource(String uri) {

On Apr 21, 2013, at 10:53 AM, burtbeckwith <[hidden email]> wrote:

> Does it help to run "grails compile"? That should resolve dependencies.
>
> Burt
>
>
> Akira Ikeda wrote
>> Hi, when trying to install the rendering plugin somehow it's not including
>> the iText and the flyingsaucer classes, all services methods throw a
>> unable to resolve class (xhtml and lowagie) when trying to compile the
>> app, it's just me experiencing this? All others plugins install and
>> compile fine.
>>
>> Deleted the .grails dir, tried on a newly created app with only bare
>> grails plugins without success:
>>
>> BuildConfig.groovy:
>>
>>    plugins {
>>        runtime ":hibernate:$grailsVersion"
>>        runtime ":jquery:1.8.3"
>>        build ":tomcat:$grailsVersion"
>>        compile ":rendering:0.4.3"
>>    }
>>
>> OS X 10.8.3, JVM 1.6.0_45, Grails 2.2.1.
>>
>> TIA
>
>
>
>
>
> --
> View this message in context: http://grails.1312388.n4.nabble.com/rendering-plugin-install-problems-tp4643814p4643815.html
> Sent from the Grails - user mailing list archive at Nabble.com.
>
> ---------------------------------------------------------------------
> To unsubscribe from this list, please visit:
>
>    http://xircles.codehaus.org/manage_email
>
>



---------------------------------------------------------------------
To unsubscribe from this list, please visit:

    http://xircles.codehaus.org/manage_email

renderingtest.zip (170K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: rendering plugin install problems

burtbeckwith
It looks like the POM isn't correct for newer Grails apps. Change the value of legacyResolve to true:

    legacyResolve true

You may also need this in the repositories section:

   mavenRepo "http://download.java.net/maven/2/"

I'll do a minor release to fix the POM.

Burt

On 04/20/2013 10:45 PM, [hidden email] wrote:
Hi Burt thanks for the answer, i did delete the .grails dir, run grails compile and got the same error, i attached a clean app that doesn't compile due to class not found errors, the rendering folder was installed on the plugins folder but cannot find the xhtml or lowagie classes.
As a workaround i donwloaded the last xhtml jars (R8) and put in the lib folder then the app compile and runs fine.




/Users/sartre/.grails/2.2.1/projects/renderingtest/plugins/rendering-0.4.3/src/groovy/grails/plugin/rendering/datauri/DataUriAwareITextUserAgent.groovy: 20: unable to resolve class org.xhtmlrenderer.resource.ImageResource
 @ line 20, column 1.
   import org.xhtmlrenderer.resource.ImageResource
   ^

/Users/sartre/.grails/2.2.1/projects/renderingtest/plugins/rendering-0.4.3/src/groovy/grails/plugin/rendering/datauri/DataUriAwareITextUserAgent.groovy: 22: unable to resolve class com.lowagie.text.Image
 @ line 22, column 1.
   import com.lowagie.text.Image
   ^

/Users/sartre/.grails/2.2.1/projects/renderingtest/plugins/rendering-0.4.3/src/groovy/grails/plugin/rendering/datauri/DataUriAwareITextUserAgent.groovy: 28: unable to resolve class ITextUserAgent
 @ line 28, column 1.
   class DataUriAwareITextUserAgent extends ITextUserAgent {
   ^

/Users/sartre/.grails/2.2.1/projects/renderingtest/plugins/rendering-0.4.3/src/groovy/grails/plugin/rendering/datauri/DataUriAwareITextUserAgent.groovy: 32: unable to resolve class ITextOutputDevice
 @ line 32, column 29.
   	DataUriAwareITextUserAgent(ITextOutputDevice outputDevice) {
                               ^

/Users/sartre/.grails/2.2.1/projects/renderingtest/plugins/rendering-0.4.3/src/groovy/grails/plugin/rendering/datauri/DataUriAwareITextUserAgent.groovy: 36: unable to resolve class org.xhtmlrenderer.resource.ImageResource
 @ line 36, column 2.
   	ImageResource getImageResource(String uri) {

On Apr 21, 2013, at 10:53 AM, burtbeckwith [hidden email] wrote:

Does it help to run "grails compile"? That should resolve dependencies.

Burt


Akira Ikeda wrote
Hi, when trying to install the rendering plugin somehow it's not including
the iText and the flyingsaucer classes, all services methods throw a
unable to resolve class (xhtml and lowagie) when trying to compile the
app, it's just me experiencing this? All others plugins install and
compile fine.

Deleted the .grails dir, tried on a newly created app with only bare
grails plugins without success:

BuildConfig.groovy:

   plugins {
       runtime ":hibernate:$grailsVersion"
       runtime ":jquery:1.8.3"
       build ":tomcat:$grailsVersion"
       compile ":rendering:0.4.3"
   }

OS X 10.8.3, JVM 1.6.0_45, Grails 2.2.1. 

TIA




--
View this message in context: http://grails.1312388.n4.nabble.com/rendering-plugin-install-problems-tp4643814p4643815.html
Sent from the Grails - user mailing list archive at Nabble.com.

---------------------------------------------------------------------
To unsubscribe from this list, please visit:

   http://xircles.codehaus.org/manage_email





---------------------------------------------------------------------
To unsubscribe from this list, please visit:

    http://xircles.codehaus.org/manage_email

-- 
Burt
Reply | Threaded
Open this post in threaded view
|

Re: rendering plugin install problems

wilsonaikeda@gmail.com
Burt, the two lines fixed it, thank you.

On Apr 21, 2013, at 11:58 AM, Burt Beckwith <[hidden email]> wrote:

It looks like the POM isn't correct for newer Grails apps. Change the value of legacyResolve to true:

    legacyResolve true

You may also need this in the repositories section:

   mavenRepo "http://download.java.net/maven/2/"

I'll do a minor release to fix the POM.

Burt

On 04/20/2013 10:45 PM, [hidden email] wrote:
Hi Burt thanks for the answer, i did delete the .grails dir, run grails compile and got the same error, i attached a clean app that doesn't compile due to class not found errors, the rendering folder was installed on the plugins folder but cannot find the xhtml or lowagie classes.
As a workaround i donwloaded the last xhtml jars (R8) and put in the lib folder then the app compile and runs fine.



/Users/sartre/.grails/2.2.1/projects/renderingtest/plugins/rendering-0.4.3/src/groovy/grails/plugin/rendering/datauri/DataUriAwareITextUserAgent.groovy: 20: unable to resolve class org.xhtmlrenderer.resource.ImageResource
 @ line 20, column 1.
   import org.xhtmlrenderer.resource.ImageResource
   ^

/Users/sartre/.grails/2.2.1/projects/renderingtest/plugins/rendering-0.4.3/src/groovy/grails/plugin/rendering/datauri/DataUriAwareITextUserAgent.groovy: 22: unable to resolve class com.lowagie.text.Image
 @ line 22, column 1.
   import com.lowagie.text.Image
   ^

/Users/sartre/.grails/2.2.1/projects/renderingtest/plugins/rendering-0.4.3/src/groovy/grails/plugin/rendering/datauri/DataUriAwareITextUserAgent.groovy: 28: unable to resolve class ITextUserAgent
 @ line 28, column 1.
   class DataUriAwareITextUserAgent extends ITextUserAgent {
   ^

/Users/sartre/.grails/2.2.1/projects/renderingtest/plugins/rendering-0.4.3/src/groovy/grails/plugin/rendering/datauri/DataUriAwareITextUserAgent.groovy: 32: unable to resolve class ITextOutputDevice
 @ line 32, column 29.
   	DataUriAwareITextUserAgent(ITextOutputDevice outputDevice) {
                               ^

/Users/sartre/.grails/2.2.1/projects/renderingtest/plugins/rendering-0.4.3/src/groovy/grails/plugin/rendering/datauri/DataUriAwareITextUserAgent.groovy: 36: unable to resolve class org.xhtmlrenderer.resource.ImageResource
 @ line 36, column 2.
   	ImageResource getImageResource(String uri) {

On Apr 21, 2013, at 10:53 AM, burtbeckwith [hidden email] wrote:

Does it help to run "grails compile"? That should resolve dependencies.

Burt


Akira Ikeda wrote
Hi, when trying to install the rendering plugin somehow it's not including
the iText and the flyingsaucer classes, all services methods throw a
unable to resolve class (xhtml and lowagie) when trying to compile the
app, it's just me experiencing this? All others plugins install and
compile fine.

Deleted the .grails dir, tried on a newly created app with only bare
grails plugins without success:

BuildConfig.groovy:

   plugins {
       runtime ":hibernate:$grailsVersion"
       runtime ":jquery:1.8.3"
       build ":tomcat:$grailsVersion"
       compile ":rendering:0.4.3"
   }

OS X 10.8.3, JVM 1.6.0_45, Grails 2.2.1. 

TIA



--
View this message in context: http://grails.1312388.n4.nabble.com/rendering-plugin-install-problems-tp4643814p4643815.html
Sent from the Grails - user mailing list archive at Nabble.com.

---------------------------------------------------------------------
To unsubscribe from this list, please visit:

   http://xircles.codehaus.org/manage_email



      

---------------------------------------------------------------------
To unsubscribe from this list, please visit:

    http://xircles.codehaus.org/manage_email

-- 
Burt

Reply | Threaded
Open this post in threaded view
|

Re: rendering plugin install problems

basejump (Josh)
You can also add the following to your dependencies to fix the issue
compile "org.xhtmlrenderer:core-renderer:R8"

On Apr 20, 2013, at 10:21 PM, [hidden email] wrote:

Burt, the two lines fixed it, thank you.

On Apr 21, 2013, at 11:58 AM, Burt Beckwith <[hidden email]> wrote:

It looks like the POM isn't correct for newer Grails apps. Change the value of legacyResolve to true:

    legacyResolve true

You may also need this in the repositories section:

   mavenRepo "http://download.java.net/maven/2/"

I'll do a minor release to fix the POM.