unresolved dependencies for most of the plugins

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

unresolved dependencies for most of the plugins

bekirdogru
Hi,
I have a problem that for most of the plugins I want to add to BuildConfig.groovy get error as
unresolved dependencies. My BuildConfig.groovy is look like this:

grails.project.dependency.resolution = {

}    repositories {
        inherits true

        grailsPlugins()
        grailsHome()
        grailsCentral()

        mavenLocal()
        mavenCentral()
    }
dependencies {
    test "org.spockframework:spock-grails-support:0.7-groovy-2.0"
}
plugins {
        compile ":remote-pagination:0.4.8"
        compile ":jmesa:2.0.4-SNAPSHOT-0.1"
        compile ":filter:0.2"
    test(":spock:0.7") {
      exclude "spock-grails-support"
    }
}
 
my system configuration is:
JDK 1.7.0_51
STS 3.5.0.M1
Groovy Compiler 2.07
Grails 2.2.0